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About This Guide
This guide explains how to configure and use Media Manager software on a Windows 
server (see the Terms section below for the supported Windows server platforms). 

Media Manager is the component of VERITAS NetBackup BusinesServer that manages 
the devices and media that are used to store your backup data.

In this guide, the term NetBackup refers to the VERITAS NetBackup BusinesServer 
product.

Audience
This guide is intended for system administrators and assumes a good working knowledge 
of the Windows operating system on the server where the product is used.

In this guide, a system administrator is defined as a person with Windows system 
administrator privileges and responsibilities.

Organization
This guide contains the following chapters:

� “Introduction to Media Manager” on page 1 provides an overview of Media Manager 
and its capabilities.

� “Configuring Storage Devices” on page 9 explains how to configure Media Manager 
to manage the drives and robots at your site.

� “Managing Media” on page 43 provides an overview of the Media node. It also 
contains topics on configuring Media Manager to use the media (volumes and 
volume pools) that it requires to store backups.

� “Managing Media in Robots” on page 91 explains how to configure Media Manager 
to use the media in robots (using robot inventory).

� “Monitoring Storage Devices” on page 135 explains tasks such as monitoring drives 
and media mount requests, and assigning a requested volume to a drive. 
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Related Documents
In addition to these chapters, there are the following appendixes, a glossary of NetBackup 
terms and an index. 

� “Media Manager Commands and Processes” on page 161 explains the commands that 
can be run from a Windows command prompt.

� “Media Manager Reference Topics” on page 213 provides background information on 
important Media Manager features and concepts.

� “Robot Drive and Slot Layouts” on page 251 contains diagrams that show the drive 
layout and slot locations for many of the robots that Media Manager supports.

� “Microsoft Removable Storage Manager (RSM)” on page 269 explains how Media 
Manager communicates with robots under the control of Microsoft Removable 
Storage Manager.

Related Documents
NetBackup documents that will be useful are listed below. For a complete list of related 
documents, see the NetBackup release notes. Depending on your configuration, other 
documents may also be required.

� NetBackup BusinesServer Getting Started Guide for Windows

Gives you the information you need to quickly get NetBackup BusinesServer server 
software installed and running. This is the first document that you should read after 
opening the NetBackup BusinesServer package.

� NetBackup BusinesServer System Administrator’s Guide for Windows

Explains how to configure and manage NetBackup BusinesServer on a Windows 
server.

� NetBackup Global Data Manager System Administrator’s Guide for UNIX and Windows

Explains how to install, configure, and use Global Data Manager (GDM) for 
NetBackup DataCenter and BusinesServer products on UNIX and Windows-based 
operating systems.

� NetBackup Release Notes for UNIX and Windows

Provides important information about NetBackup DataCenter and BusinesServer 
products on UNIX- and Windows-based servers, such as the platforms and operating 
systems that are supported and operating notes that may not be in the NetBackup 
manuals or the online help.

� NetBackup Troubleshooting Guide for Windows

Provides troubleshooting information for Windows-based NetBackup DataCenter 
and BusinesServer products.
xviii NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



Accessibility
� NetBackup Vault 4.5 System Administrator’s Guide for UNIX and Windows

Describes how to configure and use logical vaults and profiles to duplicate backups, 
perform catalog backups, eject media, and generate reports.

Accessibility
NetBackup contains features that make the user interface easier to use by people who are 
visually impaired and by people who have limited dexterity. Accessibility features 
include:

� Support for assistive technologies such as screen readers and voice input (Windows 
servers only)

� Support for keyboard (mouseless) navigation using accelerator keys and mnemonic 
keys

For more information, see the NetBackup system administrator’s guide.

Conventions
The following explains typographical and other conventions used in this guide.

Type Style

Typographic Conventions

Typeface Usage

Bold fixed width Input. For example, type cd to change directories.

Fixed width Paths, commands, filenames, or output. For example: The default installation 
directory is /opt/VRTSxx.

Italics Book titles, new terms, or used for emphasis. For example: Do not ignore cautions.

Sans serif (italics) Placeholder text or variables. For example: Replace filename with the name of your 
file.

Serif (no italics) Graphical user interface (GUI) objects, such as fields, menu choices, etc.

For example: Enter your password in the Password field.
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Conventions
Notes and Cautions

Note This is a Note. Notes are used to call attention to information that makes using the 
product easier or helps in avoiding problems.

Caution This is a Caution. Cautions are used to warn about situations that could cause 
data loss.

Key Combinations
Some keyboard command sequences use two or more keys at the same time. For example, 
holding down the Ctrl key while pressing another key. Keyboard command sequences are 
indicated by connecting the keys with a plus sign. For example:

Press Ctrl+t

Command Usage
The following conventions are frequently used in the synopsis of command usage.

brackets [ ]

The enclosed command line component is optional.

Vertical bar or pipe (|)

Separates optional arguments from which the user can choose. For example, when a 
command has the following format:

command arg1|arg2

the user can use either the arg1 or arg2 variable.
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Getting Help
Terms
The terms listed in the table below are used in the VERITAS NetBackup documentation to 
increase readability while maintaining technical accuracy. 

Getting Help
For updated information about this product, including system requirements, supported 
platforms, supported peripherals, and a list of current patches available from Technical 
Support, visit our web site:

http://www.support.veritas.com/

VERITAS Customer Support has an extensive technical support structure that enables you 
to contact technical support teams that are trained to answer questions to specific 
products. You can contact Customer Support by sending an e-mail to 
support@veritas.com, or by finding a product-specific phone number from the VERITAS 
support web site. The following steps describe how to locate the proper phone number.

Term Definition

Microsoft Windows, 
Windows

Terms used as nouns to describe a line of operating systems 
developed by Microsoft, Inc. 

A term used as an adjective to describe a specific product or 
noun. Some examples are: Windows 95, Windows 98, 
Windows NT, Windows 2000, Windows servers, Windows 
clients, Windows platforms, Windows hosts, and Windows GUI.

Where a specific Windows product is identified, then only that 
particular product is valid with regards to the instance in which 
it is being used. 
For more information on the Windows operating systems that 
NetBackup supports, refer to the VERITAS support web site at 
http://www.support.veritas.com.

Windows servers A term that defines the Windows server platforms that 
NetBackup supports; those platforms are: Windows NT and 
Windows 2000.

Windows clients A term that defines the Windows client platforms that 
NetBackup supports; those platforms are: Windows 95, 98, ME, 
NT, 2000, XP (for 32- and 64-bit versions), and LE.
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Getting Help
1. Open http://www.support.veritas.com/ in your web browser.

2. Click Contact Support. The Contacting Support Product List page appears.

3. Select a product line and then a product from the lists that appear. The page will 
refresh with a list of technical support phone numbers that are specific to the product 
you just selected.
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Introduction to Media Manager
 1

Media Manager provides control of tape storage devices and tracks the location of the 
removable media that are used in these devices. Media Manager is an integral part of 
NetBackup and is installed with it on every NetBackup server.

This chapter provides an overview of Media Manager and contains the following topics:

� Media Manager Features

� Media Manager Hosts

� Media Manager-Controlled Storage Devices

� Media Manager Volumes

� Media Manager Administration Utilities

� Device and Media Configuration Overview

Caution If you want to use devices with some other application and these devices are 
currently being controlled by Media Manger, you must down the drive if the 
drive is in the Media Manager up state.

Media Manager Features
� Robotic and Standalone Drive Support

In Media Manager, a robot is a peripheral device for the automated mounting and 
dismounting of volumes in tape drives. A standalone drive is a drive that is not 
associated with a robot.

Media Manager supports a wide range of robots and automates the handling of 
volumes in these devices. Except for initial setup and loading of tapes or an 
equipment failure, manual intervention is not required.

Visit the VERITAS support web site for a list of the platforms and peripherals that 
Media Manager supports.

Media handling in standalone drives is also automated to the extent that Media 
Manager automatically uses the tape that is in a drive, if it is required by NetBackup.
1



Media Manager Features
� Media Location Tracking

Media Manager maintains a volume database that shows the location of all media (for 
example, the robot and slot). This information permits Media Manager to find media 
when it is required to satisfy a request.

� Media Statistics Tracking

Media Manager keeps a record of statistics that are useful in tracking the useful life of 
media (for example, an expiration date and the number of times that media has been 
mounted).

� Security

Media Manager vmd security works in conjunction with NetBackup 
authentication/authorization security to control user access to vmd (the NetBackup 
Volume Manager service).

“vmd Security” on page 236 explains important security features.

� Robot Inventory and Update

Media Manager can inventory a robot, provide reports, and update the volume 
database to match the results of the inventory. This simplifies administration, by 
permitting you to quickly determine the contents of a robot. This also automates the 
configuration process.

� Automatic Volume Recognition

Media Manager compares the media IDs on media with media IDs that are requested 
and then assigns the correct media to requests. This is an essential part of providing 
hands-off operation for both robots and standalone drives.

� Automatic Scanning of Media Labels

Media Manager scans the labels of media that are in drives and displays them in the 
Device Monitor. This is useful if you want to know whether a certain drive contains a 
particular volume.

� Volume Pools

During configuration, you can assign media to pools that are reserved for specific 
uses. For example, media can be reserved for backups of specific departments. It is 
also possible to create a scratch pool from which media can be allocated to other pools 
as they are needed.

A pool named NetBackup is created by default and, unless you specify otherwise in 
the class or schedule, all NetBackup images go to media in the NetBackup pool. You 
can create other volume pools as desired. Other volume pools that are created by 
default are named None and DataStore.

� Volume Groups
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When media is added, it is assigned (or you can assign) a volume group name that 
corresponds to the physical location of the media (for example, the robot that has the 
media). This is useful for administering groups of volumes and for tracking location. 
For example, when media is taken to offsite storage, you can move the media to 
specific standalone groups.

� Graphical User Interfaces for Media and Device Management

The following interfaces (or tree nodes) are available from the NetBackup 
Administration Console.

- Device Monitor shows the current status of all drives and allows you to easily 
change the state of a drive. For example, it is possible to set a drive to DOWN to 
prevent its use by Media Manager or reset it to clear a hang condition. You can 
also assign requests to drives in those instances when assignment does not occur 
automatically. 

- Media provides intuitive and easy-to-use methods for managing your media, 
volume pools, and volume groups. 

- Devices provides intuitive and easy-to-use methods for managing your device 
hosts, robots, and drives. 

Media Manager Hosts
In the NetBackup Console and in this guide, a host that has Media Manager software 
installed is called a media server or a device host (remember that Media Manager is 
installed as part of NetBackup).

Two related terms that you will encounter and should be familiar with are:

� Device host

A host is called a device host if it controls devices for Media Manager.

� Volume Database Host

A host is called a volume database host if it contains information about the volumes 
that Media Manager uses. 

For NetBackup BusinesServer, the host where Media Manager is installed is both the 
device host and the volume database host.
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Media Manager-Controlled Storage Devices
Drives and robots must be added to the Media Manager configuration before NetBackup 
can use them. Devices can be easily added using either of the following methods using the 
NetBackup Administration Console:

� The Device Configuration Wizard (this is the recommended method). This wizard is 
available from the right pane of the NetBackup Administration Console, if you have 
selected Media and Device Management in the tree pane.

� Using Devices (use the new robot and new drive menu items).

NetBackup BusinesServer has the following storage device configuration limitations. You 
can configure only

� One robot on each host.

� Two drives on each host.

� 30 slots in a robot.

Media Manager Volumes
The tapes that Media Manager uses are referred to as volumes in NetBackup. Volumes are 
assigned media IDs and other attributes that are required for tracking and management. 
You can do the assignment manually or let Media Manager do it automatically.

� “Managing Media” on page 43

� “Managing Media in Robots” on page 91

The following are examples of what occurs when NetBackup requests a volume for a 
backup:

� If NetBackup requests an existing volume, Media Manager locates the volume and 
performs the steps necessary to have the volume mounted in a drive.

� If NetBackup requests a new volume, Media Manager looks for a volume of the 
requested density and assigns it to NetBackup before mounting it in a drive. Once a 
volume is assigned to NetBackup, other applications cannot use it until NetBackup no 
longer needs the backups on the volume.

� If Media Manager does not have a record of a volume suitable for the request, an error 
occurs and you must configure a volume to use before the operation can proceed.
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Mounting and Using Volumes
Mounting a volume consists of the steps necessary to make it available for reading or 
writing data. After finding a volume, Media Manager mounts it as follows:

� If the volume is in a robot, Media Manager issues the commands that move the 
volume to a drive, position the heads to the beginning of the volume, and assign it to 
the request. No manual intervention is required.

� If the volume happens to be in a standalone drive and has been requested by 
NetBackup, Media Manager automatically mounts and assigns it. Again, no manual 
intervention is required.

� If the volume is not in a robot or a standalone drive, Media Manager displays a 
pending request in the Device Monitor. The operator must then find the volume and 
do one of the following:

- Check the Device Monitor to find a suitable drive, and mount the requested 
volume in that drive.

- Move the volume into the robot and update the volume configuration to reflect 
the correct location for the media, and resubmit the request.

� The administrator or operator can then find the required volume, insert it into the 
drive, and assign the drive to the request with the Device Monitor. This situation will 
exist, for example, if the requested volume happens to be offsite.

In robots that have barcode readers, Media Manager verifies the barcode to ensure that the 
robot loads the correct volume. If the barcode on the volume does not match the barcode 
in the Media Manager volume database, it is considered an error and the operation is 
stopped.

Note Media Manager is involved only in backups that are stored on removable media. If 
the defined NetBackup storage unit is on magnetic disk, NetBackup sends the 
backup to the file path specified during configuration of the storage unit and 
records the location in the NetBackup media database. Media Manager, in this 
instance, does not have a record of the storage location.

Media Manager Administration Utilities
Utilities for managing media and devices are available in the NetBackup Administration 
Console. 

There are also some operations that may require you to use a command from the 
Windows command prompt (see “Media Manager Commands and Processes” on 
page 161). These operations are not required in normal use of NetBackup.
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Starting the Media Manager Administration Utilities

1. Log on to a Windows workstation as a member of the Administrators group.

2. From Start > Programs, select VERITAS NetBackup > NetBackup Administration 
Console. The NetBackup Administration Console appears on your workstation.

The NetBackup Administration Console is the starting point for administering 
NetBackup. The left pane of the console window has a node for each major area of 
NetBackup administration (including nodes for optional VERITAS products).

The right pane initially contains the NetBackup wizards that apply to each node. The 
figure shows the available wizards for Media Manager (the Media and Device 
Management node).

Clicking a node displays information related to that node in the right pane. The 
menus contain commands relevant to the selected node.

Note See the NetBackup system administrator’s guide for Windows servers for details on 
the other NetBackup Administration Console nodes, other NetBackup 
administration utilities, and menu commands.

The Media and Device Management node
 Media and Device Management wizards
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3. The Media and Device Management node contains the Media Manager utilities. 
Expand Media and Device Management to view these utilities.

- Click Device Monitor. The device monitor has commands for monitoring the 
operation of storage devices.

“Monitoring Storage Devices” on page 135 explains how to use the Device 
Monitor.

- Click Media. This node has commands for managing media.

“Managing Media” on page 43 and “Managing Media in Robots” on page 91 
explain how to manage your media. 

- Click Devices. This node has commands for configuring and managing hosts, 
robots, and drives.

“Configuring Storage Devices” on page 9 explains how to configure robots and 
drives.

Shortcut Menus
Pressing the right-mouse button while the pointer is over sections of the NetBackup 
Administration Console, displays shortcut menus. Different menus appear depending on 
where your pointer is positioned.

Device and Media Configuration Overview
The following summarizes the steps for configuring storage devices and media. Complete 
your NetBackup configuration as explained in the NetBackup system administrator’s 
guide for Windows servers.

1. Install NetBackup software by following the instructions in the NetBackup 
installation program. Media Manager is installed as a part of NetBackup.

2. Use the Device Configuration Wizard (select Configure Storage Devices in the right 
pane of NetBackup Console) to configure your robots and drives. For more 
information, see “Using the Device Configuration Wizard to Configure Devices” on 
page 25.

To configure unsupported devices, you must use the menus of the Devices node. See 
“Configuring Storage Devices” on page 9.
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3. Use the Volume Configuration Wizard (select Configure Volumes in the right pane of 
the NetBackup Console) to add the media that you will be using in the storage 
devices. This wizard configures volumes for all supported standalone drives and 
robots.

When you logically add a new volume (or move volumes) in a robot that supports 
barcodes, a scan occurs and the Media Manager volume database is updated to reflect 
the contents of the robotic library.

To configure volumes for unsupported devices, use the menus of the Media node. See 
“Managing Media” on page 43 and “Managing Media in Robots” on page 91 for 
advanced robot inventory operations.
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Configuring Storage Devices
 2

The device management window provides the tools required to add, configure, and 
manage the devices that Media Manager uses. 

This chapter explains how to attach drives and robotic libraries and configure Media 
Manager to use them. The topics in this chapter are listed below. If this is the first time you 
have configured devices, read the topics in the order they are presented.

� Starting Device Management

� Using the Device Management Window

� Performing Initial Device Configuration

� Using the Device Configuration Wizard to Configure Devices

� Managing Partially-Configured Devices

� Adding Robots

� Adding Drives

� Managing Robots and Drives

� Printing Your Device Configuration

� Robot and Drive Configuration Example

Starting Device Management
In NetBackup Administration Console, click Media and Device Management > Devices.

The device management window appears.
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Using the Device Management Window
Device Management Window

In addition to the tree pane on the left, two panes are displayed on the right when you 
start device management:

� A pane showing global topology.

� A pane showing devices.

Using the Device Management Window
The following topics provide an overview of the window’s contents:

� Menus and Commands

� Toolbars

� Tree Pane

� Global Topology Pane

� Devices Pane

� Status Bar

� Shortcut Menus and Commands
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� Tool Tips

� Customizing the Window

� Allowable Media Manager Characters

Menus and Commands
The device management window has available the menus and commands shown in the 
following table.

The menu items are enabled based on the items that are currently selected in the tree pane 
or topology pane, or which tab is selected in the devices pane. For example, if the robot 
tab is selected in the devices pane and a robotic library is selected in the list, Inventory 
Robot is enabled on the Actions menu.

Device Management Menus and Commands

Menu Commands

File Change Server - Displays a dialog box that allows you to change to a different host that 
is running NetBackup.

New Console - Starts another instance of NetBackup Administration Console.

New Window from Here - Starts another instance of the NetBackup Administration 
Console node that was active.

Backup, Archive, and Restore - Starts the NetBackup Client utility.

Print Setup - Displays a Windows print setup dialog.

Print - Prints the topology pane or devices pane (when one of these panes is selected).

Close - Closes the current window.

Exit - Closes all open windows.

Edit Contains Find commands for managing items in the display lists.

New - Displays a dialog box to add an item of the type that is currently selected.

Change - Displays a dialog box for changing the configuration of the selected items.

Delete - Deletes selected items from the configuration.

View Contains commands for specifying your viewing preferences for the device 
management window, including showing and hiding the toolbar or tree, showing and 
hiding robots, and refreshing the display. See “Customizing the Window” on page 21.
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Toolbars
The toolbar buttons of the device management window provide shortcuts for commands 
that are on the menus.

To show or hide the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Click View > ToolBar.

To change the display of the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Click View > Customize > Toolbars.

Also see “Customizing the Window” on page 21.

Actions New - Displays choices for adding robots or drives to a configuration.

Inventory Robot - Displays a dialog box with choices for performing an inventory of 
the selected robot or updating the volume configuration to match the contents of the 
robot.

Stop/Restart Device Manager Service - Stops and restarts the NetBackup Device 
Manager service.

Analyze Device Configuration - Displays a dialog box for starting the configuration 
analyzer. This analyzer verifies that the settings in your device configuration are 
consistent and checks for potential problems.

Help Help Topics - Provides online help information about the NetBackup Console.

VERITAS Web Page - Displays the VERITAS web page, if the host has a browser 
configured.

License Keys - Provides information about your active and registered license keys.

About Administration Console - Displays program information, version number, and 
copyright information. You can click More Info for more detailed information.

Device Management Menus and Commands (continued)

Menu Commands
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Tree Pane
The tree pane for Devices contains nodes for Hosts, Robots, and Standalone Drives. You 
can select items in the tree pane or the Topology pane in conjunction with the tabs of the 
Devices pane to filter the lists that are shown in the Devices pane.

The following figure shows just the tree pane and contains an expanded view of the 
Devices node:

Note Selecting an item in the Tree pane (for example, a specific robot) does not enable the 
Robots tab in the Devices pane.

Global Topology Pane
A description bar is displayed at the top of the topology pane. Tool Tips are provided for 
all of the objects displayed in the topology pane. See “Tool Tips” on page 21.

The topology view shows how devices are configured to the server being administrated, 
by showing images of servers and devices. The topology information is taken from the 
Media Manager global device database and is displayed in this pane.

Topology Images

The following images may appear in the topology pane. Shared drives are a NetBackup 
DataCenter option.

If you select a device host, robot, or Standalone 
Drives, the Topology pane shows the pertinent 
connections highlighted and the Devices pane shows 
information filtered for that specific selection.

Description Topology Image
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Topology Connections

Connections in the topology indicate physical and logical connections of the devices, as 
follows:

� Media server to robotic library and drive relationships are indicated. A line attaches a 
robot arm to the media server that has robot control.

� Drives that are physically located in a robotic library are shown directly below the 
robotic library. Standalone drives are represented as individual drive objects.

� Drive to device host connections are shown only if the drive is being used for a 
request and the drive is in use by NetBackup. A line attaches a drive to the servers 
that are configured to use it. Robot to server connections and robot to volume 
database connections are always shown.

NetBackup media server

Robot 

Robot that is partially configured

Robot media

Drive

Drive that is partially configured

Drive that is shared
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Using the Device Management Window
� Media is represented as in a robotic library. A line attaches the media to the server 
doing media management. 

� The topology also indicates robotic library to volume database host connections.

Selecting Topology Objects

Selecting an object will highlight the connecting lines from the object to all other objects to 
which it is connected, as follows:

� Clicking on a drive will highlight the connection to the server it is attached. 

� Clicking on a shared drive will highlight connections to all servers that are configured 
to use the drive. 

� Clicking on a server will high light connections to all robots, media, and drives that 
are connected or configured to the server.

Selecting objects in the topology pane is also one of the methods to filter the contents of 
the lists shown in the Devices pane. 

Multiple objects of the same type can be selected by pressing the Ctrl key and selecting 
another object. If the Ctrl key is used and an object of a different type is selected, the 
selection is not allowed. If the Ctrl key is not used and an object is selected, the previous 
selection will be unselected.

Devices Pane
The lower right pane contains tabs for Drives, Robots, and Hosts. These tabs allow you to 
select different views of your devices. Information in the devices pane is taken from the 
Media Manager global device database and the local device databases.

You can use the tree pane or the topology pane in conjunction with the tabs to filter the 
lists shown in this pane. Selecting an item in the tree (for example, a specific robot) does not 
enable the Robots tab in the devices pane.

Managing the Devices Pane

The Edit menu has commands for finding items and is useful if you are managing many 
devices. You can use View > Columns > Layout to rearrange or hide the columns in this 
display. Some of the columns are initially hidden by default.

Using the Drives Tab

The drives list allows you to view detailed information about drives configured with 
NetBackup. 
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To update the drives list with more detailed information, a drive must be selected in the 
topology pane. You can select a drive in the topology explicitly or implicitly by selecting a 
robotic library. The drives list will then be updated with the objects selected in the 
topology.

The following table describes the columns in the drives list:

Drives List

Column Description

Drive Name Contains the configured name of the drive.

Device Host Contains the name of the device host where this drive is attached.

Drive Type Contains the type of drive. For example, 4MM.

If the drive is partially configured, PCD is shown. See “Managing 
Partially-Configured Devices” on page 27 for details.

Robot Type Specifies the type of robot that contains this drive. For example, TL4.

NONE in this column means that the drive is a standalone drive.

If the robot is partially configured, PCR is shown. See “Managing 
Partially-Configured Devices” on page 27 for details.

Robot Number Contains the number of the robot. If the robot type is NONE, this column is 
blank.

Robot Drive 
Number

Specifies the number of the drive in the robot. This number is only present for 
robot types that are not ACS, TLH, and TLM.

Vendor Drive 
Name

For TLH robots, this column contains the DAS drive name. 

For TLH robots, this contains the IBM device name.

This column is not applicable for NetBackup BusinesServer.

ACS Contains the index (in ACS library software terms) that identifies the robot that 
has this drive.

This column is not applicable for NetBackup BusinesServer.

LSM Contains the ACS Library Storage Module that has this drive.

This column is not applicable for NetBackup BusinesServer.

Panel Contains the ACS robot panel where this drive is located.

This column is not applicable for NetBackup BusinesServer.
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Drive Contains the physical number of the drive (in ACS library software terms).

This column is not applicable for NetBackup BusinesServer.

Drive Path Contains the path for the drive, for example, Tape5.

Serial Number Contains the drive serial number, if the drive reports one.

World Wide ID Contains a unique identifier that is assigned to each device. Some drives may not 
report this identifier.

Shared This column is used for the shared storage option (SSO) feature. Yes, means this 
drive is configured as a shared drive. No, means the drive is not a shared drive.

For NetBackup BusinesServer this column contains No, since this feature is not 
supported.

Drive Status Contains the current status of the drive.

Port Contains the SCSI port number (if the robot is connected to a Windows server).

Bus Contains the SCSI bus number (if the robot is connected to a Windows server).

Target Contains the SCSI target number (or SCSI ID) (if the robot is connected to a 
Windows server).

Lun Contains the SCSI logical unit number of the robot (if the robot is connected to a 
Windows server).

Time Mounted Contains the time the drive was first mounted.

Total Time Contains the total mount time (in hours).

Cleaning 
Frequency

Contains the cleaning frequency for the drive, in hours.

Last Cleaning 
Time

Contains the date that the drive was last cleaned.

Volume Header 
Device

This column applies only to optical disk drives on certain UNIX hosts and 
specifies the volume header device path for the drive.

This column is not applicable for NetBackup BusinesServer.

Drives List (continued)

Column Description
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Using the Robots Tab

The robots list allows you to view detailed information about robots configured with 
NetBackup. Initially, all robots in the global device database are listed in the robot list. 
However, only information found in the global device database will be displayed in the 
list.

To update the robot list with more detailed information, a robot must be selected in the 
topology pane or in the tree pane. You can select a robot in the topology explicitly or 
implicitly by selecting a drive in the robot or the device host that the robot is connected to. 
The list will then be updated with the objects selected in the topology.

The following table describes the columns in the robots list:

Drive 
Comments

Contains any user comments added for the drive.

Inquiry 
Information

Contains device information returned from the device. This information is used 
to identify the device. For example, vendor ID, product ID, and product revision.

NDMP Host Contains the name of the NDMP control host.

Drive Index Drive index assigned to the drive during configuration.

Robots List

Column Description

Robot Name Contains the type and number of the robot, for example TLM(3). 

If the robot is partially configured, PCR is shown. For example, PCR(3). See 
“Managing Partially-Configured Devices” on page 27 for details.

Device Host Contains the name of the device host where this robot is attached.

Robot Type Contains the type of robot. If the robot is partially-configured, PCR is shown. 
See “Media Manager Robot Types” on page 213 for a list of supported robot 
types.

Robot Number Number of the robot.

Drives List (continued)

Column Description
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Using the Hosts Tab

The hosts list allows you to view detailed information about the hosts that are referenced 
in your Media Manager configuration.

To update the hosts list with more detailed information, a host must be selected in the 
topology pane or in the tree pane. You can select a host in the topology explicitly or 
implicitly by selecting a robot. The hosts list will then be updated with the objects selected 
in the topology.

The following table describes the columns in the hosts list:

Volume 
Database Host

Contains the name of the volume database host that is used to track the volumes 
in this robot 

Serial Number Contains the robot serial number.

Robotic Path Contains the path for the robot, for example, changer0.

Robot Control 
Host

Contains the name of the host that is providing the robotic control.

Port Contains the SCSI port number (if the robot is connected to a Windows server). 

Bus Contains the SCSI bus number (if the robot is connected to a Windows server).

Target Contains the SCSI target number (or SCSI ID) (if the robot is connected to a 
Windows server).

Lun Contains the logical unit number of the robot (if the robot is connected to a 
Windows server).

Inquiry String Contains device information returned from the device. This information is used 
to identify the device. For example, vendor ID, product ID, and product revision.

Hosts List

Column Description

Host Name Contains the name of the device host.

Robots List (continued)

Column Description
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Status Bar
The status bar appears at the bottom of the NetBackup Console window. The status bar

� Shows tool tips (if tool tips are enabled).

� Indicates the name of the master server.

� Indicates if you are connected to the master server.

To show or hide the status bar 

❖ Click View > Status Bar.

Shortcut Menus and Commands
Clicking the right mouse button while the pointer is over a pane or a selection of a pane, 
displays a shortcut menu with commands that apply to that context. These shortcut 
commands are also available on the menus or toolbars.

These shortcut menus work in the context of what device is currently selected in the tree 
pane or topology pane, or which tab is selected in the devices pane.

Connection 
Status

Contains the current NetBackup connection status for this host. This status field 
contains Connected, Not Connected, or the text of a possible connection error 
message.

Standalone 
Volume 
Database Host

Contains the name of the volume database host for all of the standalone drives 
controlled by this device host.

Version Contains the NetBackup software version.

Hosts List (continued)

Column Description
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Short Cut Menu

Tool Tips
Tooltips are helpful information for the toolbar buttons, or items in the topology pane (as 
you position the pointer). 

To enable tool tips 

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Click View > Customize.

3. On the Toolbars tab, select Show ToolTips.

Customizing the Window
The View menu has options for sorting and changing the layout and appearance of the 
panes.
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Showing or Hiding Columns

You can use View > Columns > Layout to show or hide columns in this display.

Rearranging Columns

You can use View > Columns > Layout to rearrange the order of columns in this display.

Changing the View of the Topology Pane

Click View > Options > Devices and select Fit topology to window on startup. This will 
fit the topology diagram to the pane and not use the default size on start up.

Click View > Zoom > Zoom In to enlarge the topology diagrams. This can be done 
multiple times.

Click View > Zoom > Zoom Out to decrease the size of the topology diagrams. This can 
be done multiple times.

Click View > Zoom > Fit Window to size the topology diagram to the size of the current 
pane.

Click View > Zoom > Overview Window to select and focus on a portion of the topology 
diagram.

Allowable Media Manager Characters
The following set of characters can be used in user-defined names, such as drive 
comments and drive names that you enter when creating these entities. These characters 
must be used even when specifying these items in foreign languages.

Do not use a minus as the first character or leave any spaces between characters.

� Alphabetic (A-Z a-z)

� Numeric (0-9)

� Period (.)

� Plus (+)

� Minus (-)

� Underscore (_)
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Performing Initial Device Configuration
The following steps describe a general method for attaching devices to a Windows device 
host. The device applets on the Windows server that you use in these steps may be 
different.

1. Use the appropriate Windows applet to obtain information on any currently attached 
SCSI devices.

2. If you are attaching a new robotic library or drive to a Media Manager device host, 
follow the manufacturer’s instructions for attaching the device.

3. Shut down the device host and physically attach the supported device, ensuring that 
SCSI targets and termination settings are consistent with adapter card and peripheral 
vendor recommendations.

4. Reboot the host and answer the prompts for adapter card peripheral configuration 
options. Watch the display to ensure that the adapter card recognizes the attached 
peripherals.

Note Some devices (for example, Quantum DLT4500) may require that nonzero logical 
unit numbers are enabled in the adapter card configuration.

5. If you are adding drives, install the tape drivers and use the appropriate Windows 
applet to verify that the drive was recognized.

You can download the latest tape drivers and tape installer from 
http://support.veritas.com.

Search on the keywords tape device installer. These drivers support the tape devices 
listed in the compatibility lists on this web site.

NetBackupTapeDeviceDriverInstall.exe will run only if NetBackup has been 
installed.

Note If you are adding Sony AIT drives, the settings for dip switches 1-4 should be left at 
the default setting (all switches off).

6. Add the storage devices to your Media Manager configuration. If this is the first time 
you have configured Media Manager devices, note the following:

a. Depending on what type of device you are adding, proceed to one of the 
following topics:

- “Using the Device Configuration Wizard to Configure Devices” on page 25.
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- “Adding Robots” on page 27.

- “Adding Drives” on page 33.

b. Make your device configuration changes. If you use the Device Configuration 
wizard, the following step is done by the wizard.

Stop and restart the NetBackup Device Manager service using Actions > 
Stop/Restart Device Manager.

Media Manager Security
For Media Manager to access devices on another host, it may be necessary to add a 
SERVER entry to the vm.conf file on the remote host (or you can use the Host properties 
node in the NetBackup Administration Console to add an entry).

SERVER entries are used for security. Without any SERVER entries and authentication not 
enabled, any host can manage the devices on the host. You can add entries allowing only 
specific hosts to remotely access the devices.

vmd is the NetBackup Volume Manager service. Device configuration changes, even those 
made local to a server, may require vmd to be running. It is recommended that vmd be 
running at all times, including when changes are being made to the Media Manager 
device configuration.

vmd Considerations

Media Manager authentication/authorization may affect systems where NetBackup 
authentication/authorization has been enabled.

Connections to vmd will fail if authentication/authorization are enabled, an 
AUTHORIZATION_REQUIRED entry is present in vm.conf, and the caller of vmd does not 
have the required permission to use vmd functions.

If authentication/authorization is needed in NetBackup but not in Media Manager, you 
can do one of the following:

If the vm.conf file on a 
remote host contains Then

No SERVER entries and 
authentication is not enabled

Any host can manage the devices on this host. It is not necessary to 
make any additions to vm.conf.

SERVER entries You must add a SERVER entry for the host where you are running 
the NetBackup Administration Console (if it is not present).
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� Add SERVER entries in vm.conf.

� Have no SERVER and no AUTHORIZATION_REQUIRED entries in vm.conf.

See “vmd Security” on page 236 for more information.

Example SERVER Entries

Assume that we have three hosts, named eel, yak, and shark; and that NetBackup 
authentication is not enabled. 

We want to centralize device management on host shark and also permit each host to 
manage its own devices.

� The vm.conf file on shark contains

SERVER = shark

The vm.conf file on shark does not require any additional SERVER entries, because 
all device management for shark will be performed from shark.

� The vm.conf file on eel contains

SERVER = eel

SERVER = shark

This allows eel to manage its own devices and also permits shark to access them.

� The vm.conf file on yak contains

SERVER = yak

SERVER = shark

This allows yak to manage its own devices and also permits shark to access them.

Using the Device Configuration Wizard to Configure 
Devices

Using the Device Configuration wizard is the recommended method of configuring 
robots and drives. This wizard performs better if the robots and drives that you are 
configuring support complete device serialization. This wizard does not support the 
following devices:

� RSM robots and drives. The wizard can discover RSM changers, but configures them 
as native SCSI devices not as RSM Media Manager robot types.

� Robots and drives for use with NetBackup for NDMP.
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To configure these unsupported devices, see “Adding Robots” on page 27 and “Adding 
Drives” on page 33.

All information required for full auto-configuration may not be available on some 
systems. In this case, the wizard will do as much as possible with the limited device 
information. Later you need to manually configure the remaining devices.

If tape drives are in use or offline, they cannot be discovered.

Starting the Wizard
The Device Configuration wizard is available from the list of wizards displayed in the 
right pane of the Media and Device Management window. 

Click Media and Device Management > Configure Storage Devices.

In some cases the wizard may leave some devices partially configured. See “Managing 
Partially-Configured Devices” on page 27 for more information.

Rerunning the Wizard
Rerunning the Device Configuration wizard updates the Media Manager configuration. 
For example, adding a new SCSI adapter may change the path to a robotic library. A 
similar change to the configuration may occur if you add a new drive.

The Device Configuration wizard updates the Media Manager configuration to match the 
new configuration.

External Device Mapping Files
These text files are used by the Device Configuration wizard to automatically discover 
and configure new devices. External mapping files exist for robots and drives.

This means that in some cases, device discovery support for your new or upgraded 
devices may be accomplished without waiting for a patch from VERITAS. Support for 
some new devices only requires that you download an updated external mapping file 
when any device changes are made to your configuration.

Note These files do not indicate support for any of the devices, only the ability to 
recognize and automatically configure them.
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Obtaining External Device Mapping Files

Visit the VERITAS support web site (http://support.veritas.com) to download 
the latest external device mapping files for your devices.

Refer to the supplied README file for instructions. The files that you download will be 
named similar to the following files: MAPPINGS_4.5_nnnnnn.TAR and 
MAPPINGS_4.5_nnnnnn.ZIP

Managing Partially-Configured Devices
Under certain conditions, for example an unsupported robotic library or drive, the Device 
Configuration wizard may leave some devices as partially configured.

Also if you unselect a discovered device from the tree view of the wizard, will cause the 
device to be configured as partially configured.

Partially-configured drives are designated by PCD and partially-configured robots by 
PCR in the Devices window pane. 

See “Using the Drives Tab” on page 15 and “Using the Robots Tab” on page 18.

If this happens it is best to ensure that you have downloaded the most recent external 
mapping files from the VERITAS support web site (see “External Device Mapping Files” 
on page 26).

Adding Robots

Note Using the Device Configuration wizard is the recommended method of configuring 
robots. See “Using the Device Configuration Wizard to Configure Devices” on 
page 25 for wizard restrictions and more information.

When adding a robotic library and drives, the best method is to add the robotic library 
first, as explained in this procedure and then add the drives (see “Adding Drives” on 
page 33).

Note For NetBackup BusinesServer, only one robot per server is allowed.

1. Perform the steps explained in “Performing Initial Device Configuration” on page 23.

2. In the NetBackup Administration Console, click Media and Device Management > 
Devices.

3. Select Actions > New > Robot.
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A dialog box for adding a robotic library appears. The properties that appear in this 
dialog box vary depending on the host platform type and robot type.

4. Specify the properties for the robotic library as explained in “Dialog Box Entries for 
Adding and Changing Robots” on page 28.

5. Click OK.

A prompt appears asking whether you want to stop and restart the NetBackup Device 
Manager service (this also stops and restarts any robotic processes). If your changes 
are complete, answer yes to this prompt.

Note It is possible that stopping and restarting this service will abort any backups, 
archives, or restores that are in progress.

Dialog Box Entries for Adding and Changing Robots
The following topics describe the properties that you specify when you add a robotic 
library or change a robot configuration. Note that some of these properties apply only to 
specific robots or host platforms.
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Device Host

Note This property does not apply to NetBackup BusinesServer.

Specifies the host to which you are adding the robotic library. To specify a host, click the 
arrow and select a host from the list.

To choose a device host that is not in the list, click the browse button (...). In the dialog box 
that then appears, specify the name of the host you want. 

Robot Type

Specifies the type of robot that you are adding. Click the arrow and select from the list of 
types that Media Manager supports.

Visit the VERITAS support web site (http://www.support.veritas.com) to locate 
the robot type to use for specific vendors and models.

Microsoft Windows 2000 Removable Storage Manager (RSM)

If you want to use the RSM robot type, review the following important points:

� Your device host must be running Windows 2000.

� You want the Microsoft Removable Storage Manager to control the robot, rather than 
Media Manager.

� A robotic library configured as an RSM robot, cannot also be used as a Media 
Manager direct-controlled (SCSI) robot (for example, TLD).

� Shared drives cannot be configured in an RSM robot.

� For more information on configuring and using RSM robots, see the appendix, 
“Microsoft Removable Storage Manager (RSM)” on page 269.

Robot Number

Specifies a unique, logical identification number for the robotic library. This number 
identifies the robotic library in displays (for example, TLD (21)) and also is used when 
adding media for the robot to the Media Manager configuration.

Volume Database Host

Note This property does not apply to NetBackup BusinesServer.
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Specifies the name of the host where Media Manager keeps the volume configuration 
information about the media in the robotic library.

You can specify any host that has Media Manager installed as the volume database host, 
even if the host does not have any drives or robots attached. Click the arrow and select 
from the list of hosts listed.

Robot Control

In the Robot control section, you specify the control for the robot. Depending on the robot 
type you are adding and the type of device host, various combinations of the robot control 
buttons are available in the dialog.

The following table provides an overview of configuring robot control, based on robot 
type and the device host platform type. The third column in the table indicates the robot 
control button that is valid for that particular robot type and platform, as follows:

� Robot is controlled locally by this device host (Local)

� Robot control is handled by a remote host (Remote) 

� Robot control is attached to an NDMP host (NDMP)

For NetBackup BusinesServer, Robot control is handled by a remote host is not 
supported and is not available. See the NetBackup release notes or visit the VERITAS 
support web site for more detailed information on supported platforms and other 
NetBackup product limitations.

Robot Control Configuration Overview

Robot Type Valid Device Host Platform Robot Control
Information Required 
for Configuration

ACS Any (except UNIX Auspex 
and Linux)

Remote ACSLS host

LMF UNIX Solaris Local Library name

LMF UNIX Solaris Remote Robot control host

ODL UNIX (except Linux) Local Robotic device file

RSM Windows 2000 Local Robot device

TL4, TL8, TLD
TS8, TSD, TSH

UNIX Local Robotic device file
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Robot is controlled locally by this device host

For this type of robot control, you have the following possibilities based on the robot type 
and device host platform that you selected.

Robotic Device File

When adding a robot to UNIX device hosts, specify the robotic device file path as follows. 
This file is used for a SCSI connection and is located in the /dev directory tree on the 
device host.

1. Click Browse and then select a robotic device file from the list that appears in the 
Devices dialog box. When you click OK, your selection will be placed in the Robotic 
device file box.

2. If the browse operation fails to find and display all of the attached robots, click Other 
Device to display a dialog box that allows you to enter the path of the device file. Your 
entry will be placed in the Robotic device file box.

TL4, TL8, TLD
TS8, TSD

Windows Local Robot device

TL8 Any (except UNIX NCR) Remote Robot control host

TLD Any Remote Robot control host

TL8, TLD, TSD Windows
UNIX AIX
UNIX Solaris
UNIX HP/UX

NDMP NDMP host name

Robot device

TLH UNIX AIX Local LMCP device file

TLH UNIX (except AIX and Linux) Local Library name

TLH Windows (Intel only) Local Library name

TLH Any (except Linux) Remote Robot control host

TLM Any Remote DAS server

Robot Control Configuration Overview (continued)

Robot Type Valid Device Host Platform Robot Control
Information Required 
for Configuration
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If the browse operation does not find any attached robots, you will see an error dialog 
box.

If the device file entry does not exist, create the entry as explained in the NetBackup 
Media Manager device configuration guide for UNIX.

Robot Device

When adding a robot to Windows device hosts, specify the robot as follows. 

For information on adding RSM robots, see the appendix, “Microsoft Removable Storage 
Manager (RSM)” on page 269.

Click Browse and then select a device from the list that appears in the Devices dialog box. 
If the browse operation does not find any attached robots, you will see an error dialog 
box.

Selecting a robot in the Devices dialog and clicking OK will set different values in the 
Robot Control text box depending on the type of Windows device host. The following 
table shows the settings in the first column for the type of device host listed in the second 
column:

Robot control is attached to an NDMP host

For this type of robot control, you specify the following:

Robot Device

Specify the robot device that is attached to the NDMP host.

Click Browse to select a robot device from the list in the Devices dialog.

NDMP Host Name

Enter the name of the NDMP host where the robot is attached.

Robot Control text box Setting Type of Windows Device Host

SCSI Port, Bus, Target, and LUN numbers Windows NT hosts

SCSI Port, Bus, Target, and LUN numbers Windows 2000 hosts where a changer driver is 
not in control of the robot

Device name (for example, Changer1) Windows 2000 hosts where a changer driver is in 
control of the robot
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Adding Drives

Note Using the Device Configuration wizard is the recommended method of configuring 
drives. See “Using the Device Configuration Wizard to Configure Devices” on 
page 25 for wizard restrictions and more information.

The following procedure explains how to add drives using device management menus:

Note For NetBackup BusinesServer, a maximum of two drives per server is allowed.

1. Perform the steps necessary for the host to recognize the attached drives (see 
“Performing Initial Device Configuration” on page 23).

2. In NetBackup Administration Console, click Media and Device Management > 
Devices.

3. Select Actions > New > Drive.

The properties that appear in this dialog box vary slightly, depending on the type of 
host platform and robot type.

4. Specify the properties of the drive as explained in “Dialog Box Entries for Adding or 
Changing Drives” on page 34.
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5. Click OK.

The display now shows the new drive information.

Note The initial drive status is up, so the drive is available as soon as you add it and 
restart ltid. To change the status of the drive, click Device Monitor.

A prompt appears asking whether you want to stop and restart the NetBackup Device 
Manager service (this also stops and restarts any robotic processes). If your changes 
are complete, answer yes to this prompt.

Note It is possible that stopping and restarting this service will abort any backups, 
archives, or restores that are in progress.

Dialog Box Entries for Adding or Changing Drives
The following are the properties that you can specify when adding a drive or changing the 
properties of a drive. Some of these properties apply only to specific types of drives or 
host platforms.

Device Host Section

Note This property does not apply to NetBackup BusinesServer.

Specifies the host to which you are adding the drive. The host that is shown initially in the 
box is the device host you selected earlier in the tree pane.

Drive Information Section

Drive Type

Specifies the type of drive that you are adding. Click the arrow and select from the list of 
the drive types that Media Manager supports.

See “Media Manager Media Types” on page 214 for more information.

Drive Name

Enter a name that will be used by Media Manager to identify the drive. Descriptive names 
are recommended and the name must be unique.
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Device Name

Note Applies only to Windows servers.

Enter the name of the drive as it is recognized by the Windows server. Enter the name in 
the box, or click the browse button to display the Devices dialog box, where you can select 
from the drives that are currently attached to this host.

You can also get the device name for the drive from the appropriate Windows applet.

No Rewind Device

Note Applies only to UNIX servers.

Enter the no rewind device file path for the drive or click the button to the right to display 
a dialog box from which you can select a device file.

Although both no rewind and rewind device files are usually available, Media Manager 
requires only the no rewind on close device file.

Device files are located in the /dev directory on the UNIX host. If the device files do not 
exist, create them as explained in the NetBackup Media Manager device configuration 
guide for UNIX.

A no rewind device remains at its current position on a close operation. Usually the device 
file name is preceded or followed by the letter n.

If you are using NDMP drives, see the NetBackup for NDMP system administrator’s 
guide for configuration information.

Character Device

Note Applies only to optical disk drives on NetBackup DataCenter UNIX servers, and 
does not apply to NetBackup DataCenter Windows servers or NetBackup 
BusinesServer.

Enter the Character Device file path for the drive.

Character device files are in the /dev directory on the UNIX host. If the entries do not 
exist, you can create them as explained in the NetBackup Media Manager device 
configuration guide for UNIX. Media Manager uses character mode device files.
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Volume Header Device

Note Applies only to optical disk drives on NetBackup DataCenter UNIX servers, and 
does not apply to NetBackup DataCenter Windows servers or NetBackup 
BusinesServer.

Enter the Volume Header Device path for the drive. This file is in the /dev directory on 
the UNIX host. If the entry does not exist, create it as explained in the NetBackup Media 
Manager device configuration guide for UNIX.

Drive Is In A Robotic Library

Select Drive is in a robotic library to specify that the drive is under robotic control and 
then enter information in the Robotic drive information section of the dialog.

Clear Drive is in a robotic library for standalone (nonrobotic) drives.

Robotic Drive Information Section

Robotic Library

This box specifies the robotic library that will control the drive.

Robot Drive Number

Specifies the physical location within the robotic library of the drive. 

Set this to the number that correlates to the location of the drive that you are adding. 
When adding more than one drive to a robot, you can add the physical drives in any 
order. For example, in a TS8 robot you can add drive 2 before drive 1.

If you assign the wrong number Media Manager does not detect it, but an error occurs 
when the robotic control attempts to mount media on the wrong drive. To determine the 
correct number, you must know which physical drive in the robot is identified by the 
logical device name (Windows) or device file (UNIX) that you specify in this dialog box.

See “Correlating Device Files to Physical Drives When Adding Drives” on page 222 for 
more information.

Managing Robots and Drives
The following topics explain how to manage your robots and drives:

� Changing a Robot Configuration
36 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



Managing Robots and Drives
� Changing the Configuration of a Drive

� Deleting Robots

� Deleting Drives

Rerunning the Device Configuration wizard updates the Media Manager configuration. 
For example, adding a new SCSI adapter may change the path to a robotic library. A 
similar change to the configuration may occur if you add a new drive or robotic library.

The Device Configuration wizard updates the Media Manager configuration to match the 
new configuration. See “Using the Device Configuration Wizard to Configure Devices” on 
page 25.

Changing a Robot Configuration

Caution If you install more than two drives in a robot, the robot will not function. This is 
true even if you do not configure the additional drives in Media Manager. Two 
drives in a robot is the maximum for NetBackup BusinesServer.

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Select the Robots tab in the Devices pane.

3. Select the robotic library you want to change.

4. Select Edit > Change.

A dialog box appears, showing the current information for the selected robotic library.

5. Make the desired changes (see “Dialog Box Entries for Adding and Changing Robots” 
on page 28).

6. Click OK.

A prompt asks whether you want to stop and restart the NetBackup Device Manager 
service (this also stops and restarts any robotic processes). If your changes are 
complete, answer yes to this prompt. 

Note It is possible that stopping and restarting this service will abort any backups, 
archives, or restores that are in progress.
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Changing the Configuration of a Drive
To change information for a drive, use the following procedure:

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Select the Drives tab in the Devices pane.

3. Select the drive you want to change.

4. Select Edit > Change.

a. A dialog box appears showing the current information for the selected drive. 
Make the desired changes (see “Dialog Box Entries for Adding or Changing 
Drives” on page 34).

b. Click OK.

A prompt appears asking whether you want to stop and restart the NetBackup 
Device Manager service (this also stops and restarts any robotic processes). If 
your changes are complete, answer yes to this prompt.

Note It is possible that stopping and restarting this service will abort any backups, 
archives, or restores that are in progress.

Deleting Robots
Any drives that were configured as residing in the deleted robot are changed to 
standalone drives.

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Select the Robots tab in the Devices pane.

3. Select the robotic library you want to delete.

4. Select Edit > Delete.

5. Answer the delete confirmation dialog.
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Deleting Drives

1. In NetBackup Administration Console, click Media and Device Management > 
Devices.

2. Select the Drives tab in the Devices pane.

3. Select the drive you want to delete.

4. Select Edit > Delete.

5. Answer the delete confirmation dialog.

Printing Your Device Configuration
To print your current Media Manager device configuration, do the following:

1. In the Devices pane, click on Drives, Robots, or Hosts.

2. Select File > Print.

To print the device configuration topology diagram, do the following:

1. Click in the Topology pane.

2. Select File > Print.

You can also use the tpconfig command (located in install_path\Volmgr\bin\) to 
print the device configuration for a host. The following example lists the device 
configuration and redirects the output to the file devconf.txt, which you can then 
print:

tpconfig -d > devconf.txt
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Robot and Drive Configuration Example

This is a configuration with a tape stacker containing two 8mm tape drives. The robot and 
drives are connected to a host running Windows.

After installing Media Manager software and attaching the drives, run the Device 
Configuration wizard or complete the Add Robot and Add Drive dialog box entries as 
shown in the following tables.

 

Add Robot Dialog Entries

Robot Type TS8 - Tape Stacker 8MM

Robot Number 0

Robot Device Selecting a robot device sets the SCSI Port, 
Bus, Target, and LUN numbers in the dialog 
for Windows NT hosts and for Windows 
2000 hosts where a changer driver is not in 
control of the robot.

On Windows 2000 hosts where a changer 
driver is in control of the robot, selecting a 
robot device sets the changer name in the 
dialog.

Add Drive Dialog Entries (Tape0)

Drive Type 8mm Cartridge (8mm)

Drive Name eel_dr_1

eel  
Windows Server

Robotic Control 
Information

Volume 
Database

Robotic Drive 
Information for 
Drives 1 and 2

Robotic 
Drive 2 
(8mm)

Robotic 
Drive 1 
(8mm)

Robot Number 0

Device 
Name

Drive 
Name

Tape0

Tape1

eel_dr_1

eel_dr_2

TS8
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Device Name Tape0

Drive is in a Robotic Library Yes

Robotic Library TS8(0) - eel

Robot Drive Number 1

Add Drive Dialog Entries (Tape1)

Drive Type 8mm Cartridge (8mm)

Drive Name eel_dr_2

Device Name Tape1

Drive is in a Robotic Library Yes

Robotic Library TS8(0) - eel

Robot Drive Number 2

Add Drive Dialog Entries (Tape0) (continued)
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Managing Media
 3

The media management window provides the tools required to add and manage the 
removable media that Media Manager controls. These media are referred to as volumes.

This chapter explains how to add and manage the removable media that Media Manager 
controls. These media are referred to as volumes, and are assigned media IDs and other 
attributes that are required to track and manage them.

The chapter, “Managing Media in Robots” on page 91 explains how to manage media in 
robots.

If you have Backup Exec volumes to manage, see the Backup Exec tape reader option 
appendix of the NetBackup system administrator’s guide for Windows for more 
information.

Starting Media Management
In NetBackup Administration Console, click Media and Device Management > Media.

The media management window appears.
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Media Management Window

In addition to the tree pane displayed on the left, a volume pane is displayed on the right 
when you start media management.

Using the Media Management Window
The following topics describe the media management window:

� Menus and Commands

� Toolbars

� Tree Pane

� Volumes Pane

� Status Bar

� Shortcut Menus and Commands

� Tool Tips

� Customizing the Window

� Allowable Media Manager Characters
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Menus and Commands
The media management window has available the menus and commands shown in the 
following table.

The menu items are enabled based on the items that are currently selected in the tree pane 
or volumes pane. For example, if a volume group is selected in the tree pane, Delete is 
enabled on the Edit menu.

Media Management Menus and Commands

Menu Commands

File Change Server - Displays a dialog box that allows you to change to a different host that 
is running NetBackup.

New Console - Starts another instance of NetBackup Administration Console.

New Window from Here - Starts another instance of the NetBackup Administration 
Console node that was active.

Backup, Archive, and Restore - Starts the NetBackup backup, archive, and restore 
interface.

Print Setup - Displays the standard Windows print setup dialog.

Print - Prints the volumes pane (when the pane is selected).

Close - Closes the current window.

Exit - Closes all open windows.

Edit Contains Find commands for managing items in the volume lists.

New - Displays a dialog box to add an item of the type that is currently selected.

Change - Displays a dialog box for changing the configuration of the selected items. 

Delete - Deletes selected items from the configuration. 

View Contains commands for specifying your viewing preferences for the media 
management window, including showing and hiding the toolbar or tree, and refreshing 
the display. See “Customizing the Window” on page 54.
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Toolbars
The toolbar buttons of the Media window provide shortcuts for commands that are on the 
menus. 

To show or hide the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Click View > ToolBar.

To change the display of the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Click View > Customize > Toolbars.

Also see “Customizing the Window” on page 54.

Actions New - Displays a dialog box for adding volumes or volume pools to a configuration.

Change Volume Group - Displays a dialog box for changing the volume group for 
selected volumes.

Move - Displays a dialog box for moving volumes.

Rescan/Update Barcodes - Rescans the barcodes in the selected robotic library and 
updates the barcodes for the selected volumes, as necessary.

Eject Volume(s) From Robot - Ejects selected single or multiple volumes to the robot’s 
media access port.

Inventory Robot - Displays a dialog box with choices for performing an inventory of 
the selected robot or updating the volume configuration to match the contents of the 
robot.

Help Help Topics - Provides online help information about the NetBackup Console.

VERITAS Web Page - Displays the VERITAS web page, if the host has a browser 
configured.

License Keys - Provides information about your active and registered license keys.

About Administration Console - Displays program information, version number, and 
copyright information. You can click More Info for more detailed information.

Media Management Menus and Commands (continued)

Menu Commands
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Tree Pane
The tree pane for Media contains nodes for Volume Pools, Volume Groups, Robots, and 
Standalone.

The display in the Volumes pane (on the right) shows the volumes that are in the volume 
database on this server. If you add any volumes, they are added to this volume database. 

If there are no volumes configured in the volume database, the Volumes pane will be 
blank. Selecting different items in the tree pane filters the lists that are shown in the 
Volumes pane. 

To view or configure volumes on another server, change your connection to that host by 
using File > Change Server. See “Administering Media on Other Hosts” on page 54 for 
more information.

The following figure shows an expanded view of the Media tree pane:

All the volume groups in the volume database on the current 
server. If you select Volume Groups, the Volumes pane 
contains information for all the volumes in all groups. 
Selecting an individual group, displays only the volumes in 
that group.

All the volume pools in the volume database on the current 
server. If you select Volume Pools, the Volumes pane 
contains information for all the volumes in all pools. Selecting 
an individual pool, displays only the volumes in that pool.

If you select Robots, the Volumes pane contains information 
for all the volumes that are in all robots and in the volume 
database on this server. Selecting an individual robot, 
displays only the volumes in that robot.

If you select Standalone, the Volumes 
pane contains information for all the 
volumes that are in standalone drives 
(or in standalone status) and in the 
volume database on this server.

The current Media Manager server. You 
are currently connected to this host. 
Volumes that appear in the Volumes 
pane are in the volume database on 
this server.
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Volumes Pane
This pane lists the volumes in the volume database. The following tables describe the 
columns in the various volume lists that can be displayed.

Managing the Volumes Pane

The Edit menu has commands for finding items and is useful if you are managing many 
volumes. You can use View > Columns > Layout to rearrange or hide specific columns in 
the Volumes pane. Some of the columns are hidden initially by default.

Volume Pools List

If you select Media > Volume Pools in the tree pane, the following list is displayed in the 
Volumes Pane showing information for all of the volume pools.

Volume Pools List

Column Description

Volume Pool Name of the volume pool. A volume pool defines the usage for the volume. 
Volumes in a pool are grouped together for use by a single application and are 
protected from access by other applications and users.

None is the default pool for users of applications, other than NetBackup.

NetBackup is the default pool name for NetBackup.

DataStore is the default pool name for DataStore.

Number Number assigned to the volume pool. This number is assigned by NetBackup. 
The following numbers are reserved:

0 is the None (default) pool.

1 is the NetBackup pool.

The DataStore pool is assigned the next available number.

User Contains the value ANY or the user ID (for example, root(0)).

Host Name of the host that is allowed to request and use the volumes in this volume 
pool or the value ANYHOST.

Group Identifies the UNIX user group for this volume pool or contains NONE.

Description Description for the volume pool. You create the description when you configure 
a volume pool.
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Volume Groups List

If you select Media > Volume Groups in the tree pane, the following list is displayed in 
the Volumes Pane showing information for all of the volume groups.

Robots List

If you select Media > Robots in the tree pane, the following list is displayed in the 
Volumes Pane showing information for all of the robots.

Volume Groups List

Column Description

Volume Group Name of the volume group. A volume group defines the volume by location and 
is a logical group of volumes that are at the same physical location.

Volume groups are a convenience for administrating multiple volumes. By using 
a volume group, you can logically move a set of volumes between a robotic 
library and a standalone location, or delete them by specifying the group name 
rather than each individual media ID.

More than one volume group can share the same location. For example, a robotic 
library can contain volumes from more than one volume group and there can be 
more than one standalone volume group. All volumes in a volume group must 
have a compatible media type.

Media Type Media Manager media type of the volume group.

Robot Number Number of the robot that contains this volume group. If the robot type is NONE, 
this column contains a hyphen (-).

Robot Type Type of robot that contains this volume group. NONE in this column means a 
standalone volume group.

Robot Control 
Host

This is the robot control host for the volumes in this volume group. If the robot 
type is NONE, this column contains a hyphen (-).

Volume Count Number of volumes in this volume group.

Robots List

Column Description

Robot Name Contains the name of the robot (comprised of the robot type and robot number), 
for example TLM(3).
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Volumes List

If you select an item under Volume Pools, Volume Groups, Robots, or Standalone in the 
tree pane, the volumes list is filtered based on the selected item and that information is 
displayed in the Volumes pane.

Device Host Contains the name of the device host where this robot is defined.

Robot Type Type of robot. See the Reference Topics appendix of this guide for a list of 
supported robot types.

Robot Number Number of the robot.

Volume 
Database Host

Contains the name of the volume database host for the volumes in this robot.

Serial Number Contains the robot serial number.

Robotic Path Contains the path of the robot or is blank for remote robots.

Robot Control 
Host

Name of the host that is providing the robotic control. This column contains a 
host name only for robots where the robot control is handled by a different host 
than the host where the robot is attached.

This column is not applicable for NetBackup BusinesServer and is blank.

Volumes List

Column Description

Media ID Identifies the volume in six or less alphanumeric characters. This value is usually 
assumed to be the same as the external media ID and should be the same as the 
recorded media ID for non-scratch, labeled media.

You specify the media ID when you add volumes to Media Manager.

Barcode Uniquely identifies the barcode of a volume in 13 alphanumeric characters or 
less.

Media Type Media type of the volume. See “Media Manager Media Types” on page 214 for a 
list of the supported media types.

Robots List (continued)

Column Description
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Robot Type Type of robot that contains this volume. See “Media Manager Robot Types” on 
page 213 for a list of supported robot types.

NONE in this column means a standalone volume.

Robot Number Number of the robot that contains this volume. If the volume is for a standalone 
drive or the volume is part of a group that was moved out of a robot (with the 
intent of being moved back into a robot), this column contains a hyphen (-).

Robot Control 
Host

Name of the host that controls the robot that contains this volume. This host is 
providing the robotic control. 

If this column is blank, the volume is for a standalone drive.

Slot Slot in the robot that contains the volume.

This column is blank for RSM robots, since Media Manager does not track slot 
information for these robots. For RSM robots, the operating system software 
tracks the slot information.

Volume Group Name of the volume group for this volume. 

Volume Pool The volume pool defines the usage for the volume. Volumes in a pool are 
grouped together for use by a single application and are protected from access by 
other applications and users.

None is the default pool name for users of applications, other than NetBackup, 
DataStore, and Storage Migrator.

NetBackup is the default pool name for NetBackup.

DataStore is the default pool name for DataStore.

HSM is the default pool name for Storage Migrator.

Mounts Number of times that the volume has been mounted (does not apply to cleaning 
media types).

Time Assigned Shows the date when the volume was assigned for use. You cannot delete a 
volume or change its volume pool while it is assigned to an application.

Volumes List (continued)

Column Description
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Status Applies only to volumes that are assigned to NetBackup or Storage Migrator for 
Microsoft Exchange.

There is also a date in the Time Assigned column for assigned volumes.

- 0 - NetBackup

The volume is assigned to NetBackup regular backups.

- 1 - Catalog

The volume is assigned to NetBackup catalog (database) backups.

- 3 - Storage Migrator

The volume is assigned to Storage Migrator for Microsoft Exchange or 
Storage Migrator for Windows 2000.

Side/Face Location of the volume.

If the media type is an 8mm tape and the robot type is TL8, this column shows 
the xy coordinates for the slot number.

For any other media type, this column contains a hyphen (-).

Partner For optical disks, this column shows the media ID of the volume on the other 
side of the optical platter. For all other media types, the column contains a 
hyphen (-). You define this value as Partner ID when you add the volume.

For NetBackup BusinesServer, this column contains a hyphen (-), since optical 
media is not supported.

Max Mounts Number of times the volume can be mounted. If maximum mounts is reached, a 
message is logged to the system application log and Media Manager allows no 
further mounts in write mode. Further mounts in read mode are allowed.

First Mount Date and time that the volume was first mounted through Media Manager.

Last Mount Date and time that the volume was last mounted.

Expiration Date Refers to the age of the volume. If the expiration date is reached, the volume is 
considered too old to be reliable and Media Manager allows no further mounts in 
write mode. Further mounts in read mode are allowed, but a message is logged 
to the system application log indicating that the expiration date has been 
reached. If the column is blank, the volume has no expiration date.

Cleanings 
Remaining

For a cleaning tape, this column shows how many more times the tape can be 
used. To use a cleaning tape, the value in this column must be greater than zero. 
You can change this count by selecting the volume and using Change on the Edit 
menu.

Volumes List (continued)

Column Description
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Status Bar
The status bar appears at the bottom of the NetBackup Console window. The status bar

� Shows tool tips (if tool tips are enabled).

� Indicates the name of the master server.

� Indicates if you are connected to the master server.

To show or hide the status bar 

❖ Click View > Status Bar.

Shortcut Menus and Commands
Clicking the right mouse button while the pointer is over either pane or a selection of a 
pane, displays a shortcut menu with commands that apply to that context. These 
commands are also usually available on the menus or toolbars.

Tool Tips
Tool tips are helpful information for the toolbar and menu buttons (as you position the 
pointer over a button). To enable tool tips 

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Click View > Customize.

3. On the Toolbars tab, select Show ToolTips.

Created Date and time that the volume was added. 

Description Describes the media in 25 or less alphanumeric characters. You create the 
description when you add volumes.

Volumes List (continued)

Column Description
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Customizing the Window
The View menu has options for sorting and changing the layout and appearance of the 
panes.

Showing or Hiding Columns

You can use View > Columns > Layout to show or hide columns in this display.

Rearranging Columns

You can use View > Columns > Layout to rearrange the order of columns in this display.

Allowable Media Manager Characters
The following set of characters can be used in user-defined names, such as volume 
groups, volume pool names, and media IDs that you enter when creating these entities. 
These characters must be used even when specifying these items in foreign languages.

Do not use a minus as the first character or leave any spaces between characters.

� Alphabetic (A-Z a-z)

� Numeric (0-9)

� Period (.)

� Plus (+)

� Minus (-)

� Underscore (_)

Administering Media on Other Hosts
Initially, you can manage media on the server where you are running NetBackup. The 
name of this server and its connection status is shown in the status bar (on the right side) 
of the window, for example Master Server: spain4.

If you change from a NetBackup DataCenter server to a NetBackup BusinesServer server, 
the functionality available on the new server is limited to the functionality supported by 
NetBackup BusinesServer.

If you change from a NetBackup BusinesServer server to a NetBackup DataCenter server, 
complete functionality is available on the new server.

To change to a different server, use the following procedure:
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1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Click File > Change Server.

In the dialog box for File > Change Server, do one of the following to specify the host:

- Enter the name of the host.

- Select a host from one of the hosts shown in the list.

- Click Browse and select a host.

You can also click Remove to delete a host from the list of available hosts.

Click OK.

Note You can also click the arrow to the right of the Change Server icon and select a host 
from one of the hosts shown in the list.

3. The name of the new host appears in the status bar and the volumes pane shows the 
volume information for the new server.

Configuring Volume Pools
A volume pool identifies a logical set of volumes by usage. Associating volumes with a 
volume pool protects them from access by unauthorized users, groups, or applications.

With the exception of the volume pools automatically created by NetBackup, you must 
create a volume pool before you can add volumes to a volume pool. The following 
volume pools are automatically created (see “Volume Pools List” on page 48):

� Media Manager creates a pool, named NetBackup, for NetBackup use.

� NetBackup creates a pool, named DataStore, for DataStore use.

During initial configuration, it is easiest to create all of your volume pools first. Then as 
you add volumes, you can assign them to volume pools.

It is also possible to configure a scratch pool from which Media Manager can transfer 
volumes, when another volume pool has no volumes available.

For background information, see “Volume Pools” on page 228 and “Scratch Volume 
Pools” on page 230.

The following topics explain volume pool configuration:

� Adding a New Volume Pool or Scratch Volume Pool

� Changing the Attributes of a Volume Pool
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� Changing the Volume Pool Assignment for a Volume

� Deleting a Volume Pool

Adding a New Volume Pool or Scratch Volume Pool

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Click Actions > New > Volume Pool.

To add a scratch volume pool, see “Adding a Scratch Volume Pool” on page 56.

3. In the Pool name text box, enter a name for the new volume pool.

The name can be 20 characters or less, and cannot contain any spaces or special 
characters. See “Allowable Media Manager Characters” on page 54.

4. In the Description text box, enter a brief description for the pool.

Adding a Scratch Volume Pool

A scratch pool is a special volume pool that you can optionally configure. If a scratch pool 
is configured, Media Manager moves volumes from the scratch pool to any other pools 
that do not have volumes available.

If you want this pool to be a scratch volume pool, do the following:
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1. Specify attributes for the scratch pool as shown in the following table:

2. Add volumes to the scratch volume pool for each robotic or standalone device that 
may require them.

Follow the steps for adding other volumes to pools (see “Adding New Volumes” on 
page 63). In this case, select the pool name of the scratch pool you created as the 
volume pool.

Changing the Attributes of a Volume Pool

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Select the desired pool from the pools shown under Volume Pools in the tree pane.

3. Click Edit > Change.

For Enter

Pool Name Any name, except NetBackup or None. It is recommended to use 
scratchpool as the pool name.

Description It is recommended to use scratch pool in the description.

Scratch Pool Select this check box.
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4. In the Description text box, enter a new description for the pool.

To change this pool to a scratch volume pool, see “Changing a Volume Pool To a 
Scratch Volume Pool” on page 58.

Changing a Volume Pool To a Scratch Volume Pool

A scratch pool is a special volume pool that you can optionally configure. If a scratch pool 
is configured, Media Manager moves volumes from the scratch pool to any other pools 
that do not have volumes available. 

If you want to change this pool to be a scratch volume pool:

1. Specify attributes for the scratch pool as follows.

2. Add volumes to the scratch volume pool for each robotic or standalone device that 
may require them.

Follow the steps for adding other volumes to pools (see “Adding New Volumes” on 
page 63). In this case, select the name of the scratch pool as the volume pool.

Changing the Volume Pool Assignment for a Volume
Volumes are grouped in a specific volume pool. The Volume Pool column in the Volumes 
list shows the name of the volume pool to which the volumes belong. Change the volume 
pool assignment as follows:

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Select a volume or volumes from the volumes pane.

Note You are unable to change the volume pool for any assigned volumes until the 
application deassigns them (see “Deassigning Volumes” on page 82).

3. Click Edit > Change.

For Action 

Description It is recommended to enter scratch pool as the description.

Scratch Pool Select this check box.
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In the dialog box that appears, the volumes you selected are listed in the top section of 
the dialog.

4. In the Volume Pool section, click New Pool and click the arrow to view a list of the 
available volume pools.

Select a volume pool from the list.

5. Click OK.

Deleting a Volume Pool
Note that you cannot delete any of the following pools:

� A volume pool that contains volumes

� Scratch pools

� The NetBackup volume pool

� The None volume pool

� The HSM volume pool (for VSM)

� The DataStore volume pool

Delete a volume pool as follows:
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1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. Choose the volume pool and ensure that the volume pool is empty.

If necessary, change the volume pool name for any volumes in the pool. Or if the 
volumes are not needed, delete them.

3. Click Edit > Delete.

Methods Available for Injecting and Ejecting Volumes
Some robotic libraries implement different functionality for their media access ports. For 
example, some libraries have front-panel inject and eject features that conflict with the use 
of the media access port in NetBackup. Other robotic libraries require front-panel 
interaction when using the media access port.

Read the operator manual for your robotic library to understand the media access port 
functionality. Libraries such as the ones noted may not be fully compatible with the inject 
and eject features of NetBackup if not properly handled. Other libraries may not be 
compatible at all.

Methods for Injecting Volumes into a Robot
The following methods are available to inject a single volume into a robotic library.

When Adding New Volumes

When specifying dialog box entries for adding new volumes, select Inject volume into 
robot via the media access port to inject a volume into a robotic library.

Inject volume into robot via the media access port is available only for the robot types 
listed in the matrix shown in “Inject and Eject Functions Available by Robot Type” on 
page 63.

Inject volume into robot via the media access port may be enabled for some robots that 
do not have media access ports, since the robot type for the robotic library only indicates 
that media access ports are possible.

See “Adding Volumes - Using the Actions Menu” on page 66 for complete instructions.
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When Moving Volumes

When specifying dialog box entries for moving volumes, select Inject volume into robot 
via the media access port to inject this volume into a robotic library.

Inject volume into robot via the media access port is available only if the following are 
true:

� You are moving a single volume from standalone to a robotic library.

� Media Manager supports inject for the robot type involved (see “Inject and Eject 
Functions Available by Robot Type” on page 63).

Inject volume into robot via the media access port may be enabled for some robots that 
do not have media access ports, since the robot type for the robot only indicates that 
media access ports are possible.

See “Moving Volumes” on page 73 for complete instructions.

When Performing a Volume Configuration Update Using Robot 
Inventory

When performing a volume configuration update for a robot, select Empty media access 
port prior to update to inject a volume into a robot. 

Any volumes to be injected must be in the media access port before the operation begins. 
If Empty media access port prior to update is selected and there are no volumes in the 
port, you are not prompted to place volumes in the media access port and the update 
operation continues.

Each volume located in the media access port is moved into the robotic library. If the 
robotic library has a port that can hold multiple volumes, volumes are moved to empty 
slots in the robotic library until the media access port is empty or all the slots are full. 

After the volume or volumes have been moved, the configuration update proceeds as 
usual.

Empty media access port prior to update is available only for the robot types listed in the 
matrix shown in “Inject and Eject Functions Available by Robot Type” on page 63.

Empty media access port prior to update may be available for some robots that do not 
have media access ports, since these robot types only indicate that media access ports are 
possible.

See “Updating the Volume Configuration for a Robot” on page 97 for complete 
instructions.
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Methods for Ejecting Volumes From a Robot
The following methods are available to eject single or multiple volumes.

When Moving Volumes

When specifying dialog box entries for moving volumes, select Eject volume from robot 
via the media access port to eject one or more selected volumes using the robot’s media 
access port.

You can eject volumes that reside in multiple robots. In this case, multiple eject dialogs 
will appear for each robot type.

Eject volume from robot via the media access port is available only if the following are 
true:

� You are moving a volume from a robotic library to standalone.

� Media Manager supports eject for the robot type involved (see “Inject and Eject 
Functions Available by Robot Type” on page 63).

Eject volume from robot via the media access port may be enabled for some robots that 
do not have media access ports, since the robot type for the robotic library only indicates 
that media access ports are possible.

For the robot types shown in the 4th column of the matrix, selecting multiple volumes to 
eject requires operator intervention. The selected volumes will be ejected one volume at a 
time. Operator intervention is required to remove the ejected volume and answer the 
prompts.

For the robot types shown in the 3rd column of the matrix, operator intervention is only 
required if the robotic library does not have a media access port large enough to eject all of 
the selected volumes. For these robot types, you are prompted to remove the media from 
the media access port so the eject can continue with the remaining volumes.

See “Moving Volumes” on page 73 for complete instructions.

Using the Eject Volumes From Robot Command

Select Actions > Eject Volume(s) From Robot to eject one or more selected volumes from 
a robotic library.

Eject Volume(s) From Robot is only available for the robot types shown in the matrix in 
“Inject and Eject Functions Available by Robot Type” on page 63.

You can eject volumes that reside in multiple robots. In this case, multiple eject dialogs 
will appear for each robot type.
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For the robot types shown in the 4th column of the matrix, selecting multiple volumes to 
eject requires operator action. The selected volumes will be ejected one volume at a time. 
Operator intervention is required to remove the ejected volume and answer the prompts.

For the robot types shown in the 3rd column of the matrix, operator intervention is only 
required if the robotic library does not have a media access port large enough to eject all of 
the selected volumes. For these robot types, you are prompted to remove the media from 
the media access port so the eject can continue with the remaining volumes.

See “Ejecting Volumes From Robots (Actions Menu Command)” on page 79 for complete 
instructions.

Inject and Eject Functions Available by Robot Type
The following matrix shows the availability of inject and eject functions provided with the 
Media Manager functions listed in the 1st column. The availability of the inject and eject 
functions listed in the column headings depends on the robot type being used. NA in a 
cell means not applicable.

Adding New Volumes
Media Manager volumes are logical units of data storage or cleaning capability on media 
that have been assigned media IDs and other attributes, which are recorded in the Media 
Manager volume database. The attributes in the volume database include information to 
show the robotic location, and includes the robot host, robot type, robot number, and slot 
location. This type of information for the volume is referred to as residence information or 
residence. 

When you add a new volume, there is no default expiration date.

Inject / Eject Functions Available by Robot Type

Media Manager
Function

Inject Single
Volume

Eject Single or
Multiple Volumes 
(Dialog Type 1)

Eject Single or
Multiple Volumes 
(Dialog Type 2))

New Volumes TL8, TLD NA NA

Move Volumes TL8, TLD TL8, TLD RSM

Robot Inventory TL8, TLD NA NA

Eject Volumes NA TL8, TLD RSM
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Methods Available for Adding Volumes
The methods available to add volumes depend on how the volume will be used, as 
follows.

If your devices are supported by the Volume Configuration wizard, using this wizard is 
an easy method for adding volumes. See “Using the Volume Configuration Wizard” on 
page 72 for more details.

Robotic Volumes (Volumes Located in a Robot)

� The easiest way to add robotic volumes is to use the Volume Configuration wizard. 
See “Using the Volume Configuration Wizard” on page 72 for more details.

� To use robot inventory to add robotic volumes, perform the Update Volume 
Configuration procedure. During the update, Media Manager assigns the media IDs 
and other attributes.

See “Adding Volumes - Using the Robot Inventory Update Option” on page 66.

� To add volumes using the menu, see “Adding Volumes - Using the Actions Menu” on 
page 66.

Standalone Volumes (Volumes To Be Used in Standalone Drives)

� The easiest way to add standalone volumes is to use the Volume Configuration 
wizard. See “Using the Volume Configuration Wizard” on page 72 for more details.

� You can also configure volumes automatically by inserting the media into a 
standalone drive. For an unused volume, NetBackup assigns a media ID, labels the 
volume, and uses it (if it needs a volume of that type for a backup). Media Manager 
adds the media ID (designated by NetBackup) and other attributes for the volume.

The DISABLE_STANDALONE_DRIVE_EXTENSIONS NetBackup configuration option 
turns off NetBackup’s automatic use of standalone volumes. See the NetBackup 
system administrator’s guide for Windows servers for more information.

� To manually choose the media IDs, label the volume with the NetBackup bplabel 
command and follow the instructions in “Adding Volumes - Using the Actions Menu” 
on page 66. See the NetBackup system administrator’s guide for Windows servers for 
more information on this command.

Even if you normally use NetBackup’s assignment capabilities for standalone 
volumes, manually adding extra standalone volumes prevents "out of media" errors 
in some situations.
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For example, if a volume in a standalone drive is full or unusable because of errors, 
NetBackup requests that Media Manager eject the volume. NetBackup then searches 
for another unused volume. If another appropriate volume is not defined, NetBackup 
exits with an error.

Labeling a volume (using the NetBackup bplabel command) and adding it prevents 
this problem, because Media Manager displays a mount request for that volume 
rather than returning an error to NetBackup.

NetBackup Catalog Backup Volumes

� Prior to using volumes for NetBackup catalog backups, you must add them. You can 
also use the NetBackup bplabel command to label the volume.

See “Adding Volumes - Using the Actions Menu” on page 66.

Notes on Labeling NetBackup Volumes

Labeling volumes is controlled by the application. For more information, refer to the 
NetBackup BusinesServer system administrator’s guide for Windows servers.

NetBackup controls the labeling of its volumes and in most cases performs this operation 
automatically.

� If a volume in a robotic library has not been labeled, NetBackup labels it with the 
media ID assigned by Media Manager the first time that it uses the volumes for a 
backup. This is done unless those volumes

- Were last used for NetBackup catalog backups. You do not want to label the 
volumes unless they are no longer being used for catalog backups.

- Contain data from a recognized non-NetBackup application. The NetBackup 
configuration option, ALLOW_MEDIA_OVERWRITE can be set to allow the volume 
to be overwritten.

� If you prefer to assign specific media IDs to NetBackup volumes, label them with the 
NetBackup bplabel command and add them using the manual update procedure.

� NetBackup uses a default prefix of A when assigning media IDs (for example, 
A00001). To change this default, use the NetBackup MEDIA_ID_PREFIX 
configuration option.

� If the robotic library supports barcodes, by default NetBackup generates media IDs 
for new volumes based on the last six characters of the barcode. To change this 
default, you can specify and select specific characters using Media ID generation rules 
(see “Configuring Media ID Generation Rules” on page 128).
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Adding Volumes - Using the Robot Inventory Update Option
To update the volume database to match the contents of the robotic library, use the 
following procedure:

1. Insert the volume into the robotic library.

2. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

3. Select the robotic library where you inserted the volume.

4. Click Actions > Inventory Robot.

5. In the Inventory Type section, select Update Volume Configuration.

The update includes the generation of media IDs for new volumes as follows. 

If the robot

� Supports barcodes and the volumes have readable barcode labels, the update part of 
the operation generates media IDs for new volumes based on the last six characters of 
the barcodes as the default or the specific characters that you specify if you are using 
Media ID generation rules.

� Does not support barcodes or the volumes do not have readable barcodes, the new 
media IDs are based on a media ID prefix that you specify.

See “Updating the Volume Configuration for a Robot” on page 97 for more 
information on robot inventory and media ID generation rules.

When you use barcode rules, new volumes that are added through a barcode rule are 
assigned a media type, volume pool, maximum number of mounts (or maximum 
cleanings), and description.

Adding Volumes - Using the Actions Menu

1. If you are adding new volumes to a robotic library, insert them into the proper slots.

2. In NetBackup Administration Console, click Media and Device Management > 
Media.

3. Click Actions > New > Volumes.
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4. Specify the properties for the volumes as explained in “Dialog Box Entries for New 
Volumes” on page 68. 

Caution Be careful when specifying properties, since you cannot later change properties 
such as the media ID or media type. To change these properties you need to 
delete the volumes and add them again.

5. Click OK to execute the add. If you selected Inject volume into robot via the media 
access port, an inject prompt appears.

The volumes pane now shows the new volume information. If the robot has a barcode 
reader, Media Manager does the following:

- Adds an entry in the volume database, using the specified media ID.

- Reads the barcode of each new volume.

- Adds the barcodes as attributes in the volume database.

Note If you are making multiple additions, clicking Apply updates the configuration 
without closing the dialog box or refreshing the display. This allows you to add 
another volume by modifying the dialog box contents and then clicking Apply or 
OK.
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Dialog Box Entries for New Volumes

Media Type

Specifies the media type for the volume that you are going to add. Click the arrow to open 
a list of the available media types and select from the list.

If you are adding a cleaning tape, choose one of the cleaning tape media types.

Robot

Specifies the robotic library to which you are adding the volumes.

Select from the list as follows:

� Select the robot in the list to add the volumes to that robot.

� Select Standalone to designate the volumes as not currently associated with a robotic 
library (such as those cases when using a standalone drive).

To add volumes to a robot that does not appear in the list (for example, a new robot), click 
Find Robots.

Find Robots

Displays a dialog box where you can select the robot. Select Find Robots if the desired 
robot does not appear in the Robot box.

After clicking OK, the name of the selected robot appears in the Robot box, and is also the 
robot name that will be in the volume database, for the volumes you are moving.

Note For NetBackup BusinesServer, you are restricted to one robot configured on a 
server.

Number of Volumes

Specify the number of volumes. For a robotic library, this refers to the number of slots that 
must be reserved for the new volumes. Depending on the number of volumes you are 
adding, you must also specify additional information as shown in the following table:

If you are adding You must also specify

One volume Media ID.
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Media ID Naming Style

If you are adding more than one volume, click the arrow in the Media ID Naming Style 
box to open a list of possible combinations of alphanumeric characters and digits. Then 
select a style to use in creating the media IDs for this range of new volumes.

Media IDs for an RSM robot must always match the barcodes. This means that you must 
get a list of the barcodes prior to adding the volumes. You can obtain this information 
through a robotic inventory or from the robot vendor’s software. For RSM robots, Media 
Manager supports barcodes with six or less characters.

Media ID or First Media ID

In the text box, enter a 1 to 6-character ID for the new volume.

If you are adding one volume, Media ID is the ID for the volume.

If you are adding more than one volume, First Media ID is the ID for the first volume in 
the range of volumes. Use the same pattern that you chose in the Media ID Naming Style 
box. Media Manager names the remaining volumes by incrementing the digits.

Media IDs for an RSM robot must always match the barcodes. This means that you must 
get a list of the barcodes prior to adding the volumes. You can obtain this information 
through a robotic inventory or from the robot vendor’s software. For RSM robots, Media 
Manager supports barcodes with six or less characters.

Description

Enter a 1 to 25 ASCII character description of the media that you are adding.

First Slot Number

Note You cannot enter slot information for volumes in a RSM robot. Windows 2000 tracks 
the slot locations for RSM robot types.

For volumes in a robot, specify the first slot number to be used by the range of volumes 
that you are adding. Media Manager assigns the remainder of the slot numbers 
sequentially.

More than one volume First Media ID and Media ID naming style.

If you are adding You must also specify
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The appendix “Robot Drive and Slot Layouts” on page 251 shows the slot layout for many 
of the robots that Media Manager supports.

Maximum Mounts

For volumes intended for backups, specify the maximum number of times that Media 
Manager is able to mount the volumes. When a volume reaches this mount limit, the 
volume can be read, but not written.

To help determine the maximum mount limit to use, consult your vendor documentation 
for information on the expected life of the volume.

Note Specify the number 0 to permit an unlimited number of mounts.

Maximum Cleanings

For a cleaning tape, specify the number of cleanings that can be performed. The number 
must be greater than zero.

See “Drive Cleaning” on page 225 for information on manual cleaning and cleaning tapes.

Volume Group

Enter the name of the volume group for the volumes you are adding, or click the arrow to 
select from a list of previously configured volume groups. The following table shows the 
results if you leave the volume group blank:

Note Do not confuse volume groups with volume pools. Refer to “Volume Pools and 
Volume Groups” on page 227 for an explanation of the differences.

Rules for Assigning Volume Groups

� All volumes in a group must be the same media type.

If you leave the Volume 
group blank for Media Manager 

Standalone volumes Does not assign a volume group.

Robotic volumes Generates a name using the robot number and type.
For example, if the robot is a TS8 and has a robot number of 50, the group 
name will be 00_050_TS8.
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However, a media type and its corresponding cleaning media type are allowed in the 
same volume group (for example, DLT and DLT_CLN).

� All volumes in a robotic library must belong to a volume group. You cannot add 
volumes to a robotic library without specifying a group or having Media Manager 
generate a name.

� The only way to clear a volume group name is to move the volume to standalone and 
not specify a volume group.

� More than one volume group can share the same location. For example, a robotic 
library can contain volumes from more than one volume group and you can have 
more than one standalone volume group.

� All members of a group must be in the same robotic library or be standalone. 

Volume Pool

Click the arrow and select from the list of volume pools as follows.

Inject Volume Into Robot via the Media Access Port

Select Inject volume into robot via the media access port to insert a single volume into 
the media access port, so it can be injected into the correct slot in the robot. When you 
select Inject volume into robot via the media access port, insert the volume in the robotic 
library and Media Manager will add it to its volume configuration.

See “Methods for Injecting Volumes into a Robot” on page 60 for a list of the robot types 
that determine when Inject volume into robot via the media access port is available and 
more information on using this function.

Select To Make

None The volume available to any user or application (cleaning tapes must be in 
the None pool).

NetBackup The volume available only to NetBackup.

DataStore The volume available only to DataStore.

One of the other 
volume pools in the 
list

The volume available to a specific volume pool. Other volume pools appear 
only if you created them earlier as explained in “Configuring Volume Pools” 
on page 55.
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Using the Volume Configuration Wizard
Use the Volume Configuration wizard to do the following:

� Inventory your robots.

� Identify cleaning media in your robots.

� Add volumes for standalone drives.

� Update the Media Manager volume database.

After running this wizard to configure media, each media will have a unique media ID in 
the volume database that is used in NetBackup and Media Manager to track the media.

Wizard Limitations
The Volume Configuration wizard is only available in NetBackup releases 3.4 or later.

This wizard configures volumes for all standalone drives and robots that are supported in 
NetBackup BusinesServer.

To configure volumes for unsupported devices or RSM robots on Windows 2000 device 
hosts, see “Adding Volumes - Using the Robot Inventory Update Option” on page 66 or 
“Adding Volumes - Using the Actions Menu” on page 66.

What To Expect In This Wizard
The following table shows the screens of the wizard and what to expect in each:

Wizard Screen What to Expect

Welcome With this wizard you can

- Inventory the volumes in a robotic library.

- Create new volumes for use in standalone drives.

Select Device You select one of the following:

- The robot that you want to inventory.

- The type of standalone drive where you want to configure 
volumes.

Robots that have more than one type of drive are not supported. 
In some cases the wizard is unable to determine if more than one 
type of drive exists in the robot. In this case, you must specify 
whether or not the robot has multiple drive types.
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Before You Start This Wizard
Make sure that you have all media that you want to use in the robotic library before 
starting the wizard.

To Start This Wizard
This wizard is available from the list of wizards displayed in the right pane of the Media 
and Device Management window of the NetBackup Administration Console. 

Click Media and Device Management > Configure Volumes.

Moving Volumes
When you move volumes in or out of a robotic library, you must physically and logically 
move the volume.

For important background information, see “Moving Volumes” on page 232.

You can move volumes using one of the following methods:

� Moving Volumes - Using the Robot Inventory Update Option

� Moving Volumes - Using the Actions Menu

Robot Inventory
(Only if a robot was selected)

You start the inventory which updates the Media Manager 
volume database.

Robot Inventory
(Only if a robot was selected)

You can view the results of the inventory.

Identify Cleaning Media
(Only if a robot was selected)

To avoid any potential problems in the Media Manager volume 
database, you select the slots in the robotic library that are known 
to contain cleaning media.

Volumes for Standalone Drives
(Only if a standalone drive was 
selected)

You specify the number of volumes to configure for the selected 
drive type. The Media Manager volume database is updated 
when you click Next.

Completion You can choose to go back and configure more volumes if 
necessary, or exit the wizard.

Wizard Screen What to Expect
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Moving Volumes - Using the Robot Inventory Update Option
The robot must have a barcode reader and the volumes must have readable barcodes to 
use the following procedure. But you can also use this procedure to just move volumes out 
of a robot, even if the volumes do not have barcodes or if the robot does not have a reader.

1. Physically move the volumes to their new location.

2. Click Actions > Inventory Robot to update the volume database to agree with the 
contents of the robot.

See “Updating the Volume Configuration for a Robot” on page 97 for more 
information.

Moving Volumes - Using the Actions Menu
If you move a volume to a robotic library that has a barcode reader, Media Manager 
updates the media database to show the correct barcode for the volume.

1. Physically move the volumes to their new location.

You can also use the inject and eject options when moving volumes to or from a 
robotic library that has an media access port. Inject can be used for single volumes and 
eject can be used for multiple volumes.

2. In NetBackup Administration Console, click Media and Device Management > 
Media.

3. In the volumes pane, select the volumes you want to move. 

4. Click Actions > Move.
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If you selected volumes of different media types or volume residences, a Move 
Volumes dialog appears for each residence and media type.

For example, if you selected two volumes to move out of a robotic library and two 
standalone volumes to move in as replacements for these volumes, a dialog box 
appears for the two full volumes and another dialog box for the two replacement 
volumes. In this example, you must complete both move dialog boxes to execute the 
move (complete the move for the volumes that are full first).

Note These multiple Move Volumes dialog boxes may appear on top of each other and 
need to be repositioned.

The following is an example of a move involving multiple types or residences:

5. Specify the properties for the move as explained in “Dialog Box Entries for Move 
Volumes” on page 76.

6. Click OK to execute the move.

Step 1. Move volumes to Standalone

Step 2. Move volumes to the robot
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If you selected Eject volume from robot via the media access port, an eject dialog 
appears. See “Ejecting Volumes From Robots (Actions Menu Command)” on page 79 
for more information on the eject dialogs.

Dialog Box Entries for Move Volumes

Volumes to Move

Shows the Media IDs of the volumes that you selected to move.

Robot

Click the arrow to specify the robot where you are moving the volumes. 

Select from the list as follows.

To move volumes to a robotic library that does not appear in the list (for example, a new 
robotic library), click Find Robots.

Find Robots

Displays a dialog box where you can select the robotic library. Use Find Robots if a robotic 
library does not appear in the Robot box.

The name of the selected robotic library appears in the Robot box, and is also the robotic 
library name that will be in the volume database, for the volumes you are moving.

Note For NetBackup BusinesServer, you are restricted to one robotic library configured 
on a server.

Select If You Are Moving 

Standalone Volumes to standalone.

The robot in the list Volumes to that robot.

The list shows the robot type and number.
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Volume Group

Enter the name of the volume group for the volumes that you are moving, or click the 
arrow to select from a list of previously configured volume groups. The following table 
shows the results if you leave the volume group blank:

Rules for Moving Volumes Between Groups

� You must move volumes to a new volume group or to an existing volume group that 
has the same type of volumes as you are moving.

� All volumes in a robotic library must belong to a volume group. You cannot move 
volumes into a robotic library without specifying a group or having Media Manager 
generate a name.

� More than one volume group can share the same location. For example, a robotic 
library can contain volumes from more than one volume group and you can have 
more than one standalone volume group.

� All members of a group must be in the same robotic library or be standalone. 

First Slot Number

Note You cannot enter slot information for volumes in a RSM robot. Windows 2000 tracks 
the slot locations for RSM robot types.

For volumes in a robotic library, specify the first slot number to be used in the destination 
robotic library.

By default, this box shows the slot number that the volume is coming from. Media 
Manager assigns the remainder of the slot numbers sequentially.

The appendix, “Robot Drive and Slot Layouts” on page 251 shows the slot layout for 
many of the robots that Media Manager supports.

If you leave Volume 
group blank for Media Manager 

Standalone volumes Does not assign a volume group.

Robotic volumes Generates a name by using the robot number and type. For example, if the 
robot is a TS8 and has a robot number of 50, the group name will be 
00_050_TS8.
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Eject Volume From Robot via the Media Access Port

Select Eject volume from robot via the media access port to eject one or more selected 
volumes using the robot’s media access port.

See “Methods for Ejecting Volumes From a Robot” on page 62 for a list of the robot types 
and cases that determine when Eject volume from robot via the media access port is 
available and more information on using this function.

Inject Volume Into Robot via the Media Access Port

Select Inject volume into robot via the media access port to insert a single selected 
volume in the robot’s media access port. The robotic library will then move the volume to 
the correct slot.

See “Methods for Injecting Volumes into a Robot” on page 60 for a list of the robot types 
and cases that determine when Inject volume into robot via the media access port is 
available and more information on using this function.

When to Delete Volumes
There may be times when you want to delete volumes. For example, if any of the 
following situations apply. The volume is

� No longer used and you want to recycle it by relabeling it with a different media ID.

� Unusable because of repeated media errors.

� Past its expiration date or has too many mounts, and you want to replace it with a 
new volume.

� Lost and you want to clean up the volume database.

Once a volume is deleted, you can discard it or add it back under the same or a different 
media ID.

 See “Deassigning Volumes” on page 82.

Before deleting and reusing or discarding a volume, ensure that it does not have any 
important data. NetBackup volumes have an extra safeguard against accidental deletion. 
Volumes assigned to NetBackup cannot be deleted while they are still assigned. See 
“Deassigning Volumes” on page 82.
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Deleting Volumes

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. In the volumes pane, select the volumes that you want to delete.

Note You cannot delete any assigned volumes until any application using them deassigns 
them (see “Deassigning Volumes” on page 82).

3. Click Edit > Delete.

A dialog box appears asking you to confirm the action.

4. Remove the deleted volumes from the storage device.

Deleting a Volume Group

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. In the volumes list, look at the Time Assigned column to check if any of the volumes 
in the group you want to delete are currently assigned.

If any of the volumes are assigned, you cannot delete the group until these volumes 
are deassigned by the application (see “Deassigning Volumes” on page 82). Use the 
“Deleting Volumes” procedure to delete individual volumes that are unassigned.

3. Select a volume group in the tree pane.

4. Click Edit > Delete.

A dialog box appears asking you to confirm the deletion.

5. Remove the deleted volumes from the storage device.

Ejecting Volumes From Robots (Actions Menu Command)
You can eject single or multiple volumes. See “Methods for Ejecting Volumes From a 
Robot” on page 62 for a list of robot types that determine when this command is available 
and more information on using this command.

To eject volumes, use the following procedure:
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1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. In the volumes pane, select one or more volumes that you want to eject.

3. Click Actions > Eject Volume(s) From Robot.

Eject Volumes Dialog Type 1

For some robot types, the following dialog is displayed showing the volumes you 
selected. See “Inject and Eject Functions Available by Robot Type” on page 63 for an 
explanation of the robot types where this dialog type applies.

1. In normal cases, the Media tab shows the volumes that you selected to eject and the 
Errors tab is empty.

The eject may not be possible because of an error. If an error occurs, the Errors tab is 
opened. The following two classes of errors can occur: 

- For more serious errors, Eject will not be available and the error situation must be 
corrected (see the sample dialog that follows).

- For other errors, the Errors tab shows an explanation of the error. You may 
continue the eject action (select Eject) or cancel (select Cancel) depending on the 
type of error.
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2. Click Eject to execute the eject.

The robotic library may not have a media access port large enough to eject all of the 
selected volumes. For most robot types, you are prompted to remove the media from 
the media access port so the eject can continue with the remaining volumes.

Eject Volumes Dialog Type 2

For some robot types, the following dialog is displayed showing the volumes you 
selected. See “Inject and Eject Functions Available by Robot Type” on page 63 for an 
explanation of the robot types where this dialog type applies.

If you selected multiple volumes, operator action is required to remove each volume after 
each eject (prompt dialogs are used). Click OK to execute the eject.
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Deassigning Volumes
An assigned volume is currently assigned for exclusive use by NetBackup. A volume is 
set to the assigned state when NetBackup first starts using it to store data. The time of the 
assignment appears in the Time Assigned column for the volume in the volumes pane. 
When a volume is assigned, you cannot delete it or change its volume pool.

A volume remains assigned until NetBackup deassigns it. NetBackup deassigns a volume 
only when it no longer needs the data.

In the case of a NetBackup volume:

� A regular backup volume is deassigned when the retention period has expired for all 
the backups on the volume. 

� A catalog backup volume is deassigned when you stop using it for catalog backups.

Determining Which Application is Using a Volume
To determine which application is using the volume, look at the Status column of the 
Volumes list (see “Volumes Pane” on page 48).

Deassigning NetBackup Volumes

Caution It is recommended that you do not manually deassign NetBackup volumes. If 
you do, be certain that the volumes do not have any important data. If you are 
uncertain, duplicate the images to another volume.

The procedure is different depending on whether the volume is currently being used for 
regular backups or for backing up the NetBackup catalogs. See the following two topics 
for instructions.
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Deassigning NetBackup Regular Backup Volumes

NetBackup deassigns a regular backup volume when the retention periods have expired 
for all backups on the volume. If you do not need the data and do not want to wait for 
normal expiration to occur, you can expire the backup by using the bpexpdate command 
on the master server.

This command is located in the install_path\NetBackup\bin\admincmd directory and 
has the following format. install_path is the directory where NetBackup is installed.

bpexpdate -d 0 -m media id

Where:

media id is the media ID to be expired.

The following example assumes there is only one NetBackup server and expires all the 
backups on media ID ABC001:

install_path\NetBackup\bin\admincmd\bpexpdate -d 0 -m ABC001

If you use this command to expire the volume, NetBackup stops tracking the backups that 
are on it and deassigns it. This makes the volume available to be reused, deleted, or its 
volume pool to be changed. You can manually expire the backups regardless of the 
volume’s prior state (frozen, suspended, and so on).

Expiring the volume does not change anything on the volume itself. When a media is 
expired, however, you must use the NetBackup import feature before restoring the 
backups it contains (a restore is possible only if the volume has not been overwritten).

Deassigning NetBackup Catalog Backup Volumes

Volumes used for backing up the NetBackup catalogs are tracked separately from regular 
backup volumes. To deassign these volumes (assuming they do not contain any important 
data), specify None or a different media ID for catalog backups (see the NetBackup system 
administrator’s guide for Windows). Then the media is available to be reassigned or 
deleted; or its volume pool can be changed.

Changing the Attributes for a Volume

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. In the volumes pane, select a volume or volumes.

3. Click Edit > Change.
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A dialog box appears and shows the media ID and other attributes for each selected 
volume. 

4. In the dialog box, change the attributes as explained in “Dialog Box Entries for 
Change Volumes” on page 84.

5. Click OK to apply the changes to the selected volumes.

Dialog Box Entries for Change Volumes

Maximum Mounts

Note Does not apply to cleaning tapes.
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Controls the number of times that the selected volumes can be mounted. The choices for 
this entry are as follows.

To help determine the maximum mount limit to use, consult your vendor documentation 
for information on the expected life of the volume.

Expiration Date

Note Expiration date does not apply to cleaning tapes. When you add a new volume, 
there is no default expiration date.

Changes the expiration date for the selected volumes. This date refers to the age of the 
volume and is the time at which the volume is considered too old to be reliable. When the 
expiration date has passed, a volume can still be read but will not be mounted for a write.

Do not confuse the expiration date with the retention period for the backup data on the 
volume. The expiration date that you can set in this dialog box refers only to the physical 
expiration of the volume and is independent of the backup data written on the volume.

The backup data expiration date is separately managed by the application that is using the 
volume. In the case of NetBackup, the expiration date for the data is set as the retention 
level during schedule configuration. The choices for this entry are as follows.

Select Result 

Do Not Change No changes will be made to Maximum Mounts.

Unlimited Allows an unlimited number of mounts. Unlimited is the default.

Number Sets a specific limit for the number of mounts. When the limit is passed the 
volume can still be read, but it will not be mounted for a write. Entering 0 (the 
default) is the same as selecting Unlimited.

Select Result 

Do Not Change No changes will be made to Expiration Date.

Never Sets the expiration date to infinity.

Number Sets a specific date and time when you want Media Manager to stop using the 
volumes.
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Description

Specifies the media description for the selected volumes. The choices for this entry are as 
follows.

Volume Pool

Note Does not apply to cleaning tapes.

Specifies the desired volume pool. The choices for this entry are as follows.

Number of Cleanings Remaining

Note Applies to cleaning tapes only.

Specifies the number of cleanings that are allowed for the cleaning tape. This number is 
decremented with each cleaning and when it is zero, Media Manager stops using the tape. 
At this point, you can change the cleaning tape or increase the number of cleanings 
allowed. The choices for this entry are as follows.

Select Result 

Do Not Change No changes will be made to the media description.

New Description Allows you to enter a short description of how the volumes are being used.

Select Result

Do Not Change No changes will be made to Volume Pool.

New Pool Specify a volume pool. Click the arrow for a list of all previously configured 
volume pools.

Select Result

Do Not Change No changes will be made to Number of Cleanings Remaining.

New Count Allows you to change the number of cleanings.
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Changing the Volume Group of a Volume

1. In NetBackup Administration Console, click Media and Device Management > 
Media.

2. In the volume list, select the volumes that you want to change the volume group.

3. Click Actions > Change Volume Group.

4. Enter a name in the New volume group name box or click the arrow to select a name 
from the list of volume groups.

5. Click OK.

The name change is reflected in the volume list entry for the selected volumes. If you 
specified a new volume group, the group appears under Volume Groups in the tree 
pane.

Replacing Volumes
In general, you should replace volumes that are any of the following:

� Full

� Past their maximum allowable number of mounts

� Too old (past their expiration date)

� Unusable, for example, because of repeated media errors

The following are two possible procedures for replacing volumes, depending on whether 
you want to reuse the old media ID.
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Replacing a Volume Without Reusing the Media ID
Use this procedure when the volume you are replacing has unexpired images. For 
example, the volume may be full.

1. Move the volume to another location (see “Moving Volumes” on page 73). 

If the volume is in a robotic library, you may want to take it out of the robotic library 
and move it to a standalone group. 

2. Add a new volume or move an existing volume in as a replacement.

If you are adding a new volume, specify the same attributes as the old volume, except 
for media ID. See “Adding New Volumes” on page 63. 

3. Physically replace the old volume, but do not delete the volume entry for that Media 
ID.

Replacing a Volume and Reusing the Media ID
This procedure lets you reuse the same set of media IDs, which may be convenient in 
some instances.

Caution Reuse a media ID only if all data on the old volume is no longer needed and 
you are going to recycle it later, or if the volume is damaged and you are going 
to discard it. Otherwise, you may encounter serious operational problems and 
possible loss of data.

1. Delete the volume entry and physically remove the old volume from the storage 
device. See “When to Delete Volumes” on page 78.

2. Physically add the new volume to the storage device.

3. Logically add the new volume to the configuration and specify the same attributes, 
including the media ID. See “Adding New Volumes” on page 63. 

4. Set a new Expiration Date for this volume. See “Changing the Attributes for a 
Volume” on page 83.
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Recycling Volumes

Caution Recycle a volume only if all data on the volume is no longer needed, or if the 
volume is damaged and unusable. Otherwise, you may encounter serious 
operational problems and possible loss of data.

Recycling Volumes Under the Same Media ID
Reusing a NetBackup volume without changing its media ID is usually done when the 
last image expires. If the volume has unexpired NetBackup images, see “Deassigning 
Volumes” on page 82.

Recycling Volumes Under a New Media ID
Before changing the media ID and reusing a volume, be certain that it does not have any 
required data.

1. Physically remove the volume from the storage device.

2. If the volume is in a robotic library, move it to standalone. See “Moving Volumes” on 
page 73.

3. Record the number of mounts and expiration date for the volume.

4. Delete the volume entry. See “When to Delete Volumes” on page 78.

5. Add the new volume entry, and physically add the volume to the storage device. See 
“Adding New Volumes” on page 63.

6. Set the expiration date to the value you recorded in step 3.
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Managing Media in Robots
 4

See “Starting Media Management” on page 43 for an explanation of the Media window 
that you use in the procedures of this chapter.

If you have Backup Exec volumes to manage, see the Backup Exec tape reader option 
appendix of the NetBackup system administrator’s guide for Windows for more 
information.

Robot Management Overview
The following topics explain the available Media Manager features for managing volumes 
in a robotic library.

� “Robot Inventory Operations (Inventory Robot Dialog)”

� “Checking Barcodes (Rescan/Update Barcodes Dialog)”

Robot Inventory Operations (Inventory Robot Dialog)
To access the Media Manager robot inventory operations, use the following initial 
procedure:

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robot you want to inventory.

3. Click Actions > Inventory Robot.

The following operations are performed using the functions of the Robot Inventory 
dialog:

� Show Contents

Inventories the selected robotic library and generates a report showing which volume 
(media ID) is in each slot. This operation does not check or change the volume 
database, but is useful for determining the contents of a robot.
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For detailed instructions, see “Showing the Contents of a Robot” on page 93.

� Compare Contents with Volume Configuration

Compares the contents of a robotic library with the contents of the Media Manager 
volume database. Regardless of the result the volume database is not changed. This is 
useful for determining if volumes have been physically moved within a robot.

For detailed instructions, see “Comparing Robot Contents with the Volume 
Configuration” on page 94.

� Update Volume Configuration

Inventories the selected robotic library and compares the results with the contents of 
the Media Manager volume database. If there are differences, Media Manager updates 
the volume database to match the contents of the robot.

For detailed instructions, see “Updating the Volume Configuration for a Robot” on 
page 97.

When you select Update Volume Configuration, you also have the following 
capabilities available from the Update section of the dialog:

- Interactive

An interactive session allows you to confirm whether to proceed with the update 
or stop. For instructions, see “Updating the Volume Configuration for a Robot” on 
page 97.

- Empty media access port prior to update

Allows you to move volumes in the robot’s media access port into the robot. For 
instructions, see “Updating the Volume Configuration for a Robot” on page 97.

- Options

You can specify options for the update. For example, you can assign media-type 
mappings if the robot type supports these mappings.

For detailed instructions, see “Changing the Update Options” on page 101.

- Barcode Rules

A barcode rule specifies criteria for assigning attributes to new robotic volumes. 
The attributes are assigned according to the actual barcode that is detected by the 
robotic library. 

For detailed instructions, see “Configuring Barcode Rules” on page 122.

- Media ID Generation
92 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



Showing the Contents of a Robot
Using media ID generation rules allows you to manage your barcodes when you 
do not want to use the default rule for media ID generation. You control how 
Media Manager media IDs are created by defining rules that specify which 
characters of a barcode on tape will be used in the media ID.

For detailed instructions, see “Configuring Media ID Generation Rules” on 
page 128.

Checking Barcodes (Rescan/Update Barcodes Dialog)
In addition to the functions available in the Robot Inventory dialog, you can check the 
barcodes of volumes in certain robot types and update the volume database to agree with 
the contents of the robotic library.

For detailed instructions, see “Rescaning and Updating Barcodes for a Robot” on 
page 132.

Showing the Contents of a Robot

1. In the dialog box, the Device host box contains the name of the host that controls the 
robot and the Robot box contains the robot you selected.

To select a different robotic library on the host, click the arrow and select from the list 
of robots shown.

2. In the Inventory Type section, select Show Contents.

To clear any previous display in the Results section, click Clear.

3. Click Start to start the inventory.

The inventory report appears in the Results section.

Note For NetBackup BusinesServer the dialog box is similar, but you cannot change the 
device host.
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Show Contents Report

For robots (other than RSM robots) that have a barcode reader, Media Manager 
obtains the barcode and includes it in the report.

See “Robot Attributes” on page 215 for information on the robots that support 
barcode readers. These robots can have up to eight characters in the barcodes.

For RSM robots, Media Manager reports what it receives from the Windows 2000 
Removable Storage service. The resulting report shows a list of volumes obtained 
from the service along with their RSM and Media Manager media types.

Comparing Robot Contents with the Volume Configuration

1. In the dialog box, the Device host box contains the name of the host that controls the 
robot and the Robot box contains the robot you selected.

To select a different robot on the host, click the arrow and select from the list of robots 
shown.

2. In the Inventory Type section, select Compare Contents with Volume Configuration.
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To clear any previous display in the Results section, click Clear.

3. Click Start to start the compare.

Media Manager requests an inventory from the selected robotic library and compares 
the results with the contents of the volume database. 

Note For NetBackup BusinesServer the dialog box is similar, but you cannot change the 
device host.

The Results section of the dialog box shows any discrepancies as follows:

- If the robot can read barcodes (see “Robot Attributes” on page 215), the report 
includes barcode information. Media Manager determines if the barcodes in the 
robot match those in the volume database. 

The following figure shows an example report. For NetBackup BusinesServer the 
dialog box is similar, but you cannot change the device host.
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Compare Contents Report (Non-RSM Robot That Can Read Barcodes)

- For RSM robots, Media Manager determines whether the media ID and media 
type in the Media Manager volume database matches what it receives from the 
Windows 2000 Removable Storage service.

- If the robotic library cannot read barcodes, Media Manager verifies only whether 
the volume database correctly shows whether a slot contains a volume.

4. If the report shows that the volume database does not match the contents of the 
robotic library, do one of the following:

- Physically move the volume.

- Correct the condition by using Actions > Move or by updating the volume 
configuration as explained in “Updating the Volume Configuration for a Robot” 
on page 97.
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Updating the Volume Configuration for a Robot
The following topics explain how to use the Update Volume Configuration feature:

� When to Use Update Volume Configuration

� When Not to Use Update Volume Configuration

� To Update the Volume Configuration for a Robot

� Changing the Update Options

� Update Options

� Examples of Updating a Volume Configuration

These topics explain how to inventory a robotic library, and optionally update the volume 
database to match the contents of the robotic library. In these topics, insert means the 
volume is placed physically in the robot without using an add or move option to update 
the volume database, and remove means to take a volume out of a robot without using a 
move or eject command.

If you have inserted new volumes, the configuration update includes creation of media 
IDs (based on barcodes or a prefix that you specify).

When you use barcode rules, a new volume that is added by using a barcode rule is also 
assigned a media type, volume pool, maximum number of mounts (or maximum number 
of cleanings), and description. For instructions on setting up barcode rules see 
“Configuring Barcode Rules” on page 122.

When to Use Update Volume Configuration
You can use this operation on robots that Media Manager supports, regardless of whether 
they can read barcodes or not. The Update Volume Configuration operation is useful for 
updating the volume’s configuration information that is stored in the Media Manager 
volume database, after performing one of the following tasks:

� Removing existing volumes from a robotic library.

The operation updates the residence information in the volume database, to show the 
new standalone location. You specify the volume group to use.

� Inserting new volumes into a robotic library.

If the robotic library supports barcodes and the volume has readable barcode labels, 
the operation creates new volume entries in the volume database with media IDs that 
are based on the last six characters of the barcodes as the default or the specific 
characters that you specify, if you are using media ID generation rules (see 
“Configuring Media ID Generation Rules” on page 128).
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If the robotic library does not support barcodes or the volumes do not have readable 
barcodes, the new media IDs are based on a media ID prefix that you specify.

For more information, see “Adding New Volumes” on page 63.

If the robotic library supports barcodes and the volume has a readable barcode, you can 
use this operation in the following cases. If you are

� Inserting existing volumes into a robotic library.

The operation updates the residence information in the volume database, to show the 
new robotic location. This includes the robot host, robot type, robot number, and slot 
location. You specify the volume group to use.

� Physically moving existing volumes within a robotic library.

The operation updates the residence information in the volume database, to show the 
new slot location.

� Physically moving volumes between robotic and standalone.

The operation updates the residence information in the volume database, to show the 
new robotic or standalone location.

When Not to Use Update Volume Configuration
The following situations require a move operation, rather than using Update Volume 
Configuration:

� After inserting existing volumes into a robotic library, and the volume does not have 
readable barcodes or the robotic library does not support barcodes.

Without barcodes, Media Manager cannot identify the volume and assigns a new 
media ID that uses the media ID prefix you select for the update. A volume entry for 
the old media ID remains in the volume database. An error may occur later, if an 
application attempts to use the new or old volume.

� After physically moving existing volumes that do not have readable barcodes or if the 
volumes are in a robot that does not support barcodes.

If you swap volumes between two different locations, Media Manager is unable to 
detect the change and cannot update the volume database.

If you remove a volume from a slot and place it in an empty slot, Media Manager 
assumes it is a new volume. Media Manager then adds a new logical volume entry 
with a generated media ID at its new robotic location. The volume entry for the old 
media ID is moved to standalone. An error may occur if an application attempts to 
use the volume entry with the new or old media ID.
98 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



Updating the Volume Configuration for a Robot
To Update the Volume Configuration for a Robot

1. In the dialog box, the Device host box contains the name of the host that controls the 
robot and the Robot box contains the robot you selected.

To select a different robot on the host, click the arrow and select from the list of robots.

2. Check the barcode capabilities of the robotic library and the volume by performing 
the procedure “Comparing Robot Contents with the Volume Configuration” on 
page 94.

Determine if the following are true:

- The robotic library supports barcodes.

- Any new volume that was inserted has readable barcodes.

3. If the robotic library does not support barcodes or the volume does not have readable 
barcodes, consider the following important points:

- Save the results of the verify, as it may be useful in deciding on a media ID prefix 
if you use Update Options to assign a prefix later in this procedure.

- For RSM robot types, assign media-type mappings. If you do not, default media 
types are used.

See “Media Type Mappings (for RSM robots)” on page 110 for instructions.

For RSM robots, media-type mappings are explained in the appendix, “Microsoft 
Removable Storage Manager (RSM)” on page 269.

4. Create barcode rules (optional).

Barcode rules are used for updating the volume database for a volume that has been 
inserted into the robotic library.

See “Configuring Barcode Rules” on page 122 for more information.

5. Create media ID generation rules (optional).

Media ID generation rules allow you to manage your barcodes when you do not want 
to use the default rules for media ID generation. You control how Media Manager 
media IDs are created by defining rules that specify which characters of a barcode on 
tape will be used in the media ID.

See “Configuring Media ID Generation Rules” on page 128 for more information.

6. In the Inventory Type section, select Update Volume Configuration.

To clear any previous display in the Results section, click Clear.
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7. If you want the session to be interactive, select Interactive (Interactive set is the 
default). If you do not want the session to be interactive, clear Interactive.

During an interactive session, Media Manager lists the recommended changes and 
lets you confirm whether to proceed with the update. 

If the session is not interactive, the changes are made without prompting you for 
confirmation. This allows you to preview and ensure that all new media have 
barcodes before they are added to the Media Manager volume database.

8. Select Empty media access port prior to update to move (inject) one or more volumes 
in the robot’s media access port into the robotic library before initiating the update.

Any volumes to be injected must be in the media access port before the operation 
begins. If Empty media access port prior to update is selected and there are no 
volumes in the port, you are not prompted to place volumes in the media access port 
and the update operation continues.

Check “Methods for Injecting Volumes into a Robot” on page 60 for a list of robot 
types that determine when Empty media access port prior to update is available and 
more information on using this function.

Note If you have recently ejected volumes from the robot with the eject or move volume 
Media Manager commands, remove the volumes from the media access ports 
before performing an inject with Empty media access port prior to update selected. 
Otherwise, if the entry and exit ports are the same, the volumes that you ejected 
could be injected back into the robotic library.

9. To view or change the settings for the update, click Options. See “Changing the 
Update Options” on page 101 for instructions.

10. Click Start to start the update.

The following figure shows example results.

Note For NetBackup BusinesServer the dialog is similar, but you cannot change the 
device host.
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Update Volume Configuration Report

Changing the Update Options
For most configurations, the default update options work well. You should only change 
the defaults if your configuration has special hardware or usage requirements.

1. In the Robot Inventory dialog box, click Update Volume Configuration > Options.

See “To Update the Volume Configuration for a Robot” on page 99 for the complete 
procedure.

The Update Options dialog box appears.
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2. Specify update options properties, as explained in “Update Options” on page 102.

3. When you are satisfied with your settings, click OK to return to the Robot Inventory 
dialog box.

4. Click Start to initiate the update.

Update Options

Media Which Have Been Removed From the Robot Assign to Volume 
Group

Specifies the volume group that Media Manager assigns to volumes that you have 
removed from the robot.
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If you leave the volume group at DEFAULT and there is an existing group with a 
compatible residence for the volume, the volume is added to that group. A compatible 
residence means the same robot type, robot number, robot host, and media type (DLT and 
DLT_CLN are considered equivalent in this regard). If a suitable volume group does not 
currently exist, Media Manager generates a new volume group name.

To change from DEFAULT, do one of the following:

� Enter a volume group name in the box.

� Click the arrow and select from the list of choices for the volume group. This opens a 
list of choices for the volume group that Media Manager can assign to volumes that 
you have removed from the robotic library. The list always has the following choices.

The other available volume group choices in the list depend on the Media Type 
selection (see “Media Type (for robots that are not RSM robots)” on page 106).

Media Which Have Been Moved Into or Within the Robot Assign to 
Volume Group

Specifies the volume group that Media Manager assigns to volumes that you have 
inserted into the robot (or moved to a new location within the robot).

If you leave the volume group at DEFAULT and there is an existing group with a 
compatible residence for the volume, the volume is added to that group. A compatible 
residence means the same robot type, robot number, robot host, and media type (DLT and 
DLT_CLN are considered equivalent in this regard). If a suitable volume group does not 
currently exist, Media Manager generates a new volume group name.

Select To 

DEFAULT Let Media Manager choose the volume group.

AUTO-GENERATE Automatically generate a new volume group.

NO VOLUME GROUP Not assign a volume group.

If Media Type is The list shows existing volume groups that are valid for 

DEFAULT The robot’s default media type (see “Media Type When Not 
Using Barcode Rules” on page 107).

Not DEFAULT The specified media type.
Chapter 4, Managing Media in Robots 103



Updating the Volume Configuration for a Robot
To change from DEFAULT, do one of the following:

� Enter a group name in the box.

� Click the arrow and select from the list of choices for the volume group. This opens a 
list of choices for the volume group that Media Manager can assign to volumes that 
you have moved into the robotic library. The list always has the following choices.

The other available volume group choices depend on the Media Type selection (see 
“Media Type (for robots that are not RSM robots)” on page 106).

Media ID Prefix

Specify a Media ID prefix, if either of the following conditions exist:

� The robotic library does not support barcodes.

� The volume that was inserted does not have readable barcodes.

If the robotic library supports barcodes and the volume has readable barcodes, a prefix is 
not required because Media Manager creates the media ID in one of the following ways. 
This is true whether or not a barcode rule is used.

� As the default, Media Manager assigns the last six characters of the barcode as the 
media ID.

� You specify specific characters for the media ID using Media ID generation rules. See 
“Configuring Media ID Generation Rules” on page 128.

If you want media IDs for media generated based on a specific prefix, you can specify a 
media ID prefix by entering a prefix or picking a prefix from a list as follows.

Select To 

DEFAULT Let Media Manager choose the volume group.

AUTO-GENERATE Automatically generate a new volume group.

If Media Type is The list shows existing volume groups that are valid for 

DEFAULT The robot’s default media type (see “Media Type When Not 
Using Barcode Rules” on page 107).

Not DEFAULT The specified media type.
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Entering a New Value For a Prefix

The prefix is used only for the current operation. It is not added to the vm.conf file.

Enter a new value for the prefix in the text box. You can specify a prefix having from one 
to five alpha-numeric characters. Media Manager assigns the remaining numeric 
characters. For example, if the prefix is NETB, the media IDs are: NETB00, NETB01, and 
so on.

Picking A Prefix From the List

Click the arrow and select a choice for the prefix. 

The list will be similar to the following example list. The first two items in this example 
list are configured media ID prefixes. These prefixes are based on MEDIA_ID_PREFIX 
entries that were added to the vm.conf file on the host where you are running 
NetBackup administration.

NV

NETB

DEFAULT

NOT USED

See “Media Manager Configuration File (vm.conf)” on page 243 for an overview of the 
vm.conf file.

DEFAULT always appears in the selection list. If you select DEFAULT, Media Manager 
checks the vm.conf file for MEDIA_ID_PREFIX entries, as shown in the following table:

NOT USED also always appears in the selection list. If you select NOT USED, the operation 
succeeds only if the robotic library supports barcodes and the volume has readable 
barcodes. Otherwise, Media Manager is unable to assign new media IDs and the 
operation fails. NOT USED may be useful if you are using barcoded volumes and want 
updates to fail when unreadable or missing barcodes are encountered.

If vm.conf Media Manager 

Contains prefix entries Assigns the last one as the default prefix.

Does not contain prefix entries Uses the letter A, as the default prefix.
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Use Barcode Rules

This check box specifies whether you are using barcode rules or not. The resulting actions 
are shown in the following table:

Media Type (for robots that are not RSM robots)

Note See “Media Type Mappings (for RSM robots)” on page 110 for instructions for 
specifying Media Type for RSM robot types.

Specifies the media type for the volume that is being added. Click the arrow to select from 
the list of media types that are valid for this robotic library. 

The following is an sample list for a TLD robotic library:

DEFAULT
1/2” cartridge tape
8MM cartridge tape
DLT cartridge tape
1/2” cleaning tape
8MM cleaning tape
DLT cleaning tape

The procedure you follow to select a media type depends on whether you are using 
barcode rules, as follows:

Note Media Type Mappings applies to RSM robot types, but does not apply to any other 
robot types that are supported on NetBackup BusinesServer hosts.

If you Media Manager 

Select Use barcode rules Searches existing barcode rules and applies the rules to new volumes that 
have been inserted into a robot.

Clear Use barcode rules Ignores barcode rules.

If you are See the instructions in 

Not using barcode rules “Media Type When Not Using Barcode Rules” on page 107.

Using barcode rules “Media Type When Using Barcode Rules” on page 107.
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Media Type When Not Using Barcode Rules

If you are not using barcode rules and you want to use the media type shown in first 
column of the following table, select the type as shown in the second column.

The following table shows the default media types for robots when drives are not 
configured on the robot control host:

Media Type When Using Barcode Rules

If you are using barcode rules and you want to

� Let the barcode rule determine the media type that is assigned, select DEFAULT as the 
media type.

Media Type Select 

The default media type DEFAULT.

If all of the drives in the robotic library (configured on this 
robot host) are

- The same type and at least one drive is configured on the 
robot control host, then Media Manager uses the media 
type for the drives.

- Not the same type, then Media Manager uses the default 
media type for the robotic library.

A media type other than the default 
media type

A media type from the list.

Default Media Types for Robots

Robot Type Default Media Type

Tape Library 4MM (TL4) 4MM cartridge tape

Tape Library 8MM (TL8) 8MM cartridge tape

Tape Library DLT (TLD) DLT cartridge tape

Tape Stacker 8MM (TS8) 8MM cartridge tape

Tape Stacker DLT (TSD) DLT cartridge tape

Tape Stacker Half-inch (TSH) 1/2-inch cartridge
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Note If you choose DEFAULT here and in the barcode rule, Media Manager assigns the 
default media type for the robotic library. 

� Use a media type other than the default, select a media type from the list.

The update media type always overrides the rule. If you specify any value other than 
DEFAULT in Update Options, the media type for the rule must be the same type or be 
DEFAULT in order to obtain a match (except for cleaning media).

The following table shows the results for various combinations of update and barcode 
rule media types:

The fourth barcode rule in the table shows Media Manager’s ability to add cleaning 
cartridges with regular volumes when you execute an update for a robotic library.

If the volumes that you insert include a cleaning tape, Media Manager adds the 
volumes correctly, if the following are true:

- The update options media type is for the regular media (DLT in this example).

Update Options
Media Type

Barcode Rule
Media Type Rule Used

Media Type in
Volume Configuration

DLT DEFAULT Yes DLT

HCART DEFAULT Yes HCART

DLT DLT Yes DLT

DLT DLT_CLN Yes DLT_CLN

DLT_CLN DLT No DLT_CLN

DLT_CLN DLT_CLN Yes DLT_CLN

DLT_CLN DEFAULT Yes DLT_CLN

DLT 8MM, 4MM, and so on No DLT

DEFAULT DEFAULT Yes DLT

DEFAULT DLT Yes DLT

DEFAULT DLT_CLN Yes DLT_CLN

DEFAULT 8MM, 4MM, and so on No Depends on robot type.
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- The barcode on the volume matches a barcode tag and the barcode rule media 
type is the cleaning media (DLT_CLN in this example).

Also see “Example 5: Add cleaning tapes to a robot” on page 119.

The sixth and seventh rules in the table illustrate how to add only a cleaning tape. In 
the sixth rule, you specify the cleaning media type in Update Options and in the 
barcode rule. In the seventh rule, you specify the cleaning media in Update Options 
and choose default when you configure the barcode rule.

Volume Pool

Specifies the volume pool. Click the arrow and select from the list of volume pools to 
which you can assign new volumes. 

The list will be similar to the following example:

DEFAULT
None
NetBackup
DataStore
a_pool
b_pool

If you are using barcode rules and you want to Select 

Let the barcode rule determine the volume pool that is 
assigned to new volumes.

DEFAULT.

Use a volume pool other than the default. That pool name in the list. The 
Update Options volume pool 
always overrides the rule.

If you are not using barcode rules and you want to use Select

The NetBackup volume pool for data volumes and no 
volume pool for cleaning tapes.

DEFAULT.

A volume pool other than the default. That pool name in the list.
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Media Type Mappings (for RSM robots)

For RSM robot types, the Media type setting is always DEFAULT. Media Manager uses the 
mappings in the Media Type Mappings dialog box to set the media type for new volumes.

Click Media type mappings to access this dialog box (Media type mappings is available 
only for this robot type).

In Media Type Mappings, map the media type specified by the robot vendor or operating 
system software to a corresponding Media Manager type as follows. Your mappings 
apply only to the current update.

1. Find the appropriate robot vendor media type in the dialog.

2. Click the arrow and select a Media Manager type from the list.

You can set the defaults that appear in Media Type Mappings by adding media mappings 
to the Media Manager configuration file, vm.conf.

For information on adding RSM media mapping entries, see “vm.conf Map Entries For 
RSM Robots” on page 274.

If either of the following are true, Media Manager uses the default media type mappings 
shown in the following table:

� The vm.conf file does not exist.
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� The vm.conf file does not contain media mapping entries for that robot type.

Default Media Types for RSM Robots

RSM Media Type Default Media Manager Media Type

DDS_4MM 4mm cartridge (4MM)

MINI_QIC 1/4-inch cartridge (QCART)

TRAVAN 1/4-inch cartridge (QCART)

QIC 1/4-inch cartridge (QCART)

MP_8MM 8mm cartridge (8MM)

AME_8MM 8mm cartridge (8MM)

AIT1_8MM 8mm cartridge (8MM)

DLT Digital Linear Tape (DLT)

IBM_MAGSTAR_3590 1/2-inch cartridge (HCART)

IBM_MAGSTAR_MP 1/2-inch cartridge (HCART)

STK_DATA_D3 1/2-inch cartridge (HCART)

MP2_8MM 8mm cartridge (8MM)

CLEANER_CARTRIDGE 1/2-inch cartridge (HC_CLN)

STK_EAGLE 1/2-inch cartridge (HCART)

LTO_ULTRIUM 1/2-inch cartridge (HCART)

LTO_ACCELIS 1/2-inch cartridge (HCART)

UNKNOWN 1/2-inch cartridge tape 3 (HCART3)
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Examples of Updating a Volume Configuration

Note The following examples show only the relevant dialog box and volume attributes.

Example 1: Remove a volume from a robot

The following is an example of removing a volume from a robotic library. It does not 
matter whether the robot supports barcodes.

1. The following are the attributes for media ID 800001. 

2. Assume that you remove the volume from the robotic library, specify the following in 
the Update Options dialog box, and then execute the update.

3. The resulting volume attributes for media ID 800001 are as follows:

media ID 800001

media type 8MM cartridge tape

barcode TL800001

media description tl8 backup volume

volume pool NetBackup

robot type TL8 - Tape Library 8MM

volume group EXB220

max mounts allowed 0 (unlimited)

media type DEFAULT

volume group NONROB_8MM

volume pool DEFAULT

media ID 800001
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The new residence information in the volume database shows a standalone location in 
the volume group, specified by the volume group on the Update Options dialog. The 
media type and volume pool remain unchanged.

The results are the same for a volume that does not have a barcode.

Example 2: Add existing standalone volumes to a robot

The following is an example of adding a standalone volume, that has a barcode, to a 
robotic library that supports barcodes (TL8).

media type 8MM cartridge tape

barcode TL800001

media description tl8 backup volume

volume pool NetBackup

robot type NONE - Not Robotic

volume group NONROB_8MM

max mounts allowed 0 (unlimited)
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1. The following are the volume attributes for media ID 800021, which has a readable 
barcode and already exists as a standalone volume. 

2. Assume that you insert the volume into a TL8 robot, specify the following in the 
Update Options dialog box, and then execute the update.

The barcode rules shown in the following table exist:

media ID 800021

media type 8MM cartridge tape

barcode TL800021

media description 8MM standalone

volume pool None

robot type None (Standalone)

volume group NONROB_8MM

max mounts allowed 0 (unlimited)

media type DEFAULT

volume group EXB220

use barcode rules YES

volume pool NetBackup

Barcode Tag Media Type Volume Pool Max Mounts/ 
Cleanings

Description

CLND DLT_CLN None 30 dlt cleaning

CLN8 8MM_CLN None 20 8mm cleaning

TL8 8MM NetBackup 0 tl8 backup

DLT DLT d_pool 200 dlt backup
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3. Media Manager recognizes that the media ID exists and changes the volume database 
to reflect the new robotic location, rather than creating a new media ID. The resulting 
volume attributes for media ID 800021 are as follows:

Because the last six characters of the barcode match the media ID of an existing 
standalone volume in the configuration, the residence information in the volume 
database is updated to reflect the new robotic location. Since the volume is not new, 
barcode rules are ignored. 

The only option used in the Update Options dialog box is the volume group for added 
or moved volumes. The media type option was not used because this example was for 
a single existing volume that already had a media type.

TS 8MM None 0 8mm no pool

<NONE> DEFAULT None 0 no barcode

<DEFAULT> DEFAULT NetBackup 0 other barcodes

media ID 800021

media type 8MM cartridge tape

barcode TL800021

media description 8MM standalone

volume pool NONE

robot type TL8 - Tape Library 8MM

robot number 0

robot slot 1

robot host shark

volume group EXB220

max mounts allowed 0 (unlimited)

Barcode Tag Media Type Volume Pool Max Mounts/ 
Cleanings

Description
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Example 3: Move existing volumes within a robot

The following is an example of moving a volume from one slot to another within the same 
robot. The robot supports barcodes and the volume has a readable barcode.

Caution For volumes moved within a robotic library, use Update Volume Configuration 
only if the robotic library supports barcodes and the volumes have readable 
barcodes. Otherwise, Media Manager is unable to properly recognize the move 
(see “When Not to Use Update Volume Configuration” on page 98).

1. The following are the attributes for media ID 800002, which currently resides in slot 1 
of the robotic library.

2. Assume that you move the volume to empty slot 10, specify the following in the 
Update Options dialog box, and then execute the update.

media ID 800002

media type 8MM cartridge tape

barcode TL800002

media description tl8 backup

volume pool NetBackup

robot type TL8 - Tape Library 8MM

robot number 0

robot slot 1

robot host shark

volume group EXB220

max mounts allowed 0 (unlimited)

media type DEFAULT

volume group EXB220

use barcode rules NO
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3. The resulting volume attributes are:

The updated volume attributes show the new slot number, but all other information is 
unchanged.

Example 4: Add new volumes to a robot

The following is an example of adding new volumes with barcodes to a robot that 
supports barcodes. Assume the following:

� The new volume is an 8MM tape with a readable barcode of TL800002.

� There are no media generation rules defined.

� The drives in the robot all have a drive type of 8MM or there are no drives configured 
on the robot control host.

volume pool DEFAULT

media ID 800002

media type 8MM cartridge tape

barcode TL800002

media description tl8 backup

volume pool NetBackup

robot type TL8 - Tape Library 8MM

robot number 0

robot slot 10

robot host shark

volume group EXB220

max mounts allowed 0 (unlimited)
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1. You specify the following in the Update Options dialog box and execute the update.

The barcode rules shown in the following table exist:

2. The barcode on the media matches the barcode rule named TL8 and the resulting 
volume attributes for the new volume are as follows:

media type DEFAULT

volume group EXB2220

use barcode rules YES

volume pool DEFAULT

Barcode Tag Media Type Volume Pool Max Mounts/ 
Cleanings

Description

CLND DLT_CLN None 30 dlt cleaning

CLN8 8MM_CLN None 20 8mm cleaning

TL8 8MM NetBackup 0 tl8 backup

DLT DLT d_pool 200 dlt backup

TS 8MM None 0 8mm no pool

<NONE> DEFAULT None 0 no barcode

media ID 800002

media type 8MM cartridge tape

barcode TL800002

media description tl8 backup

volume pool NetBackup

robot type TL8 - Tape Library 8MM
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The media ID is from the last six characters of the barcode since there are no media ID 
generation rules. The new residence information in the volume database, shows the 
robot host, robot type, robot number, slot, and host. The volume group is from the 
Update Options dialog. The volume pool and max mounts allowed are from the 
barcode rule.

If barcode rules (or barcodes) had not been used, the media description, volume pool, 
and max mounts allowed would be set to the following defaults:

- Media description: added by Media Manager

- Volume pool: NetBackup for data tapes or None for cleaning tapes

- Max mounts: 0 (unlimited)

Note If the robot does not support barcodes or the barcode is unreadable, you must 
specify a Media ID prefix (or DEFAULT) in the Update Options dialog box or Media 
Manager will not add new media IDs.

Example 5: Add cleaning tapes to a robot

A special case exists when adding cleaning tapes. For example, assume you are doing an 
update for a TLD robot.

1. The tapes you inserted include regular tapes with barcodes ranging from DLT00000 to 
DLT00010 and a cleaning tape with a barcode of CLN001.

The barcode rules shown in the following table exist:

robot number 0

robot slot 1

robot host shark

volume group EXB220

max mounts allowed 0 (unlimited)

Barcode Tag Media Type Volume Pool Max Mounts/ 
Cleanings

Description

CLN DLT_CLN None 30 dlt cleaning

DL DLT d_pool 200 dlt backup
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2. You specify the following in the Update Options dialog box and then execute the 
update.

3. The barcodes on the regular tapes match the DL barcode rule and the media type of 
the DL barcode rule matches the Media type in the Update Options dialog box. These 
tapes are added as DLT.

The cleaning tape matches the CLN barcode rule and Media Manager recognizes that 
DLT_CLN is the cleaning tape for DLT. The cleaning tape CLN001 is added as 
DLT_CLN type media along with the regular volumes.

This illustrates Media Manager’s ability to add cleaning cartridges along with regular 
volumes when you use Update Volume Configuration.

If the volumes you insert include a cleaning tape, Media Manager adds the volumes 
correctly if the following are true:

- The Media type in the Update Options dialog box is the regular media (DLT in 
this example).

- The barcode on the volume matches a barcode tag (CLN in this example) and the 
media type for the barcode rule is the correct cleaning media (DLT_CLN in this 
example).

To add only cleaning media, specify the cleaning media type in the Update Options 
dialog box and in the barcode rule (DLT_CLN in this example).

Example 7: Adding existing volumes when barcodes are not used

Caution This example is NOT recommended and is shown only to illustrate the results.

The following is an example of adding an existing standalone volume to a TL4 robot. A 
TL4 robot supports inventory (detects media presence), but not barcodes.

<NONE> DEFAULT None 0 no barcode

media type DLT

volume group STK7430

use barcode rules YES

Barcode Tag Media Type Volume Pool Max Mounts/ 
Cleanings

Description
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1. The following are the attributes for media ID 400021, which already exists as a 
standalone volume.

2. Assume that you insert the volume into the robot, specify the following in the Update 
Options dialog box, and then execute the update.

3. The resulting volume attributes are:

media ID 400021

media type 4MM cartridge tape

barcode -----------

media description 4MM standalone

volume pool None

robot type NONE - Not Robotic

volume group NONROB_4MM

max mounts allowed 0 (unlimited)

media type DEFAULT

volume group 00_000_TL4

media ID prefix C4

volume pool DEFAULT

media ID C40000

media type 4MM cartridge tape

barcode -----------

media description Added by Media Manager

volume pool NetBackup
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It is important to note that Media Manager assigned a new media ID to the volume 
(C40000). This undesired result occurs if you use Update Volume Configuration to 
add volumes that do not have readable barcodes or if the robot does not support 
barcodes. Without a barcode, Media Manager cannot identify the volume and 
assumes it is new. The media ID C40000 is generated from the media ID prefix on the 
Update Options dialog.

The old media ID (400021) remains in the configuration unchanged. The information 
for the new media ID (C40000) shows the robotic location, including the robot host, 
robot type, number, slot, and host. The volume group and volume pool are according 
to the Update Options dialog box selections. The max mounts allowed is set to the 
default (0).

Configuring Barcode Rules
A barcode rule specifies criteria for assigning attributes to new robotic volumes. The 
attributes are assigned according to the barcode that is detected by the robotic library. You 
choose whether to use barcode rules when you set up the update operation.

For background information, see “Barcode Rules” on page 234.

The following topics explain how to use barcode rules:

� Adding a New Barcode Rule

� Dialog Box Entries for Adding and Changing Barcode Rules

� Changing a Barcode Rule

� Deleting a Barcode Rule

robot type TL4 - Tape Library 4MM

robot number 0

robot slot 1

robot host shark

volume group 00_000_TL4

max mounts allowed 0 (unlimited)
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Adding a New Barcode Rule

1. In the Robot Inventory dialog box, click Update Volume Configuration > Barcode 
Rules.

2. In the Barcode Rules dialog box, click New. A dialog box appears.
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3. Specify the properties for the new barcode rule and click OK.

See “Dialog Box Entries for Adding and Changing Barcode Rules” for help on 
specifying these properties.

Dialog Box Entries for Adding and Changing Barcode Rules

Barcode Tag

Enter a barcode tag for the rule. The tag can have from 1 to 16 characters, but cannot 
contain any spaces (or special characters that appear as spaces). 

In the barcode rule database and in the volume database a barcode tag can have a 
maximum of 16 characters, but Media Manager only supports the following maximum 
barcode lengths (in the volume database not all 16 characters are used for all robot types).

� Eight characters in robots that are not API robots (and the robot also supports 
barcodes). 

� Six characters in RSM robots.

The following rules can have special characters in the barcode tags:

� <NONE > - Matches when rules are used and the volume has an unreadable barcode 
or the robotic library does not support barcodes.

� <DEFAULT> - For volumes with barcodes, this tag matches when none of the other 
barcode tags match, providing the media type in the <DEFAULT> rule and the media 
type in the Update Options dialog box are compatible.

Use Update Options to set up the criteria for a robot update (see “Updating the Volume 
Configuration for a Robot” on page 97).
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Media Type

Click the arrow to select the media type for which this rule will be used, as shown in the 
following table:

Note Always select DEFAULT for RSM robots.

The following table shows various combinations of update selections and barcode rule 
media types for a TLD robot.

If you want the rule match Select 

Any media type that you select in Update Options DEFAULT.

If you also select DEFAULT in Update 
Options, Media Manager uses the default 
media type for the robotic library (see “Media 
Type (for robots that are not RSM robots)” on 
page 106).

Only when you select that specific media type or 
DEFAULT in Update Options

A specific media type from the list.

If you select DEFAULT for the update, Media 
Manager assigns the rule’s media type.

Update
Media Type 

Barcode Rule
Media Type Rule Used

Media Type Added To
Volume Configuration

DLT DEFAULT Yes DLT

HCART DEFAULT Yes HCART

DLT DLT Yes DLT

DLT DLT_CLN Yes DLT_CLN

DLT_CLN DLT No DLT_CLN

DLT_CLN DLT_CLN Yes DLT_CLN

DLT_CLN DEFAULT Yes DLT_CLN

DLT ,4MM No DLT

DEFAULT DEFAULT Yes DLT
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When setting up the update operation, a rule is not used if the media type in the rule is not 
compatible with the media type you select in Update Options. See “Updating the Volume 
Configuration for a Robot” on page 97.

For an RSM robot, Media Manager determines whether the media type is compatible by 
mapping it according to the setting in the media mappings dialog box. See “Media Type 
Mappings (for RSM robots)” on page 110 for more information.

Volume Pool

Click the arrow to select a volume pool for the volume. This is the pool that the volume 
will be added to, when a barcode matches the rule.

Whenever the barcode rule is used and the Update Options dialog shows

� DEFAULT for the volume pool, then the volume is assigned to the pool you specified 
in the barcode rule.

� A specific volume pool, then that selection overrides the pool you specified in the 
barcode rule.

Maximum Mounts

Specify the maximum number of mounts or cleanings that are allowed for this volume, as 
follows:

DEFAULT DLT Yes DLT

DEFAULT DLT_CLN Yes DLT_CLN

DEFAULT  4MM No DLT (unless drives in the 
robot are configured on the 
robot control host with a 
different type)

For Select 

Media other than cleaning tapes The maximum number of mounts to allow.

Cleaning tapes The number of cleanings to allow.

Update
Media Type 

Barcode Rule
Media Type Rule Used

Media Type Added To
Volume Configuration
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When a barcode rule is used, Media Manager adds the number you specify to the volume 
database for the media ID. 

Note When you specify 0 (unlimited), a cleaning tape whose barcode happens to match 
the rule will be assigned a 0 for Cleanings. This means it will not be used unless you 
subsequently change Cleanings to another value. You can avoid this situation by 
carefully selecting the barcodes for your cleaning media.

Description

Enter description. This can be a description of how the barcode rule will be used or any 
useful description determined by your site. You can enter from 1 to 25 characters.

Changing a Barcode Rule

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volume database where you want to change 
barcode rules.

3. Click Actions > Inventory Robot.

4. In the dialog box, click Update Volume Configuration > Barcode Rules.

5. In the dialog box, select a rule that you want to change from the rules listed.

6. Click Change.

A dialog box appears.

7. Specify your changes.

See “Dialog Box Entries for Adding and Changing Barcode Rules” on page 124 for 
help in changing the properties of the rule.

Note You cannot change the barcode tag. To change a barcode tag, you must delete the 
rule and then add a rule with a new tag.
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Deleting a Barcode Rule

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volume database where you want to change 
barcode rules.

3. Click Actions > Inventory Robot.

4. In the dialog box, click Update Volume Configuration > Barcode Rules.

5. In the dialog box, select the rule you want to delete from the list of rules.

6. Click Delete.

In the confirmation dialog box, confirm or cancel the delete.

Configuring Media ID Generation Rules

Note To use media ID generation rules, the robotic library must support barcodes and the 
robot type cannot be RSM.

For background information see “Media ID Generation Rules” on page 236.

The following topics explain how to use media ID generation rules:

� Adding a New Media ID Generation Rule

� Changing a Media ID Generation Rule

� Deleting a Media ID Generation Rule

� Dialog Box Entries for Adding and Changing Media ID Generation Rules

Adding a New Media ID Generation Rule

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volume database where you want to change a 
media ID generation rule.

3. Click Actions > Inventory Robot.
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4. In the dialog box, click Update Volume Configuration > Media ID Generation.

5. In the Media ID Generation dialog box, click New. A dialog box appears.
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6. Specify the properties for the new media ID generation rule and click OK.

See “Dialog Box Entries for Adding and Changing Media ID Generation Rules” on 
page 131 for help on specifying the rule.

Changing a Media ID Generation Rule

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volume database where you want to change a 
media ID generation rule.

3. Click Actions > Inventory Robot.

4. In the dialog box, click Update Volume Configuration > Media ID Generation.

5. In the Media ID Generation dialog, select a rule from list.

6. Click Change.

7. In the dialog box, specify your changes for the rule. You cannot change the Robot 
Number or Barcode Length fields.

See “Dialog Box Entries for Adding and Changing Media ID Generation Rules” on 
page 131 for help in changing the rule.

Deleting a Media ID Generation Rule

1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volume database where you want to delete 
media ID generation rules.

3. Click Actions > Inventory Robot.

4. In the dialog box, click Update Volume Configuration > Media ID Generation.

5. In the Media ID Generation dialog, select a rule or rules from list and click Delete. 

6. In the dialog box, confirm or cancel the delete action.
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Dialog Box Entries for Adding and Changing Media ID 
Generation Rules

Robot Number

Specify a robot number where this rule will apply.

Barcode Length

Specify the length of the barcode for tapes in this robotic library and for this rule.

Media ID Generation Rule

A rule consists of a maximum of six fields that must be delimited by colons. Numbers in 
the fields of the rule define the positions of the characters in the barcode that are to be 
extracted. For example, 2 in a field extracts the second character from the barcode 
(numbering is from the left). The numbers can be specified in any order.

Characters prefixed by # in a field result in that character being inserted in that position in 
the generated ID. Any alphanumeric characters that are specified must be valid for a 
media ID.

The following table shows some examples of rules and the resulting media IDs. You can 
use rules to create media IDs of many varied formats, but keep in mind that the difference 
in the label on the media and the generated media ID may make it difficult to keep track 
of your media.

Eight-character 
Tape Barcode Media ID Generation Rule

Generated
 Media Manager Media ID

032945L1 1:2:3:4:5:6 032945

032945L1 3:4:5:6:7 2945L

032945L1 #N:2:3:4:5:6 N32945

543106L1 #9:2:3:4 9431

543106L1 1:2:3:4:#P 5431P
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Rescaning and Updating Barcodes for a Robot
Use the Rescan/Update Barcodes command to check the barcodes of volumes in a robotic 
library and update the volume database to agree with the contents of the robotic library.

Note The Rescan/Update Barcodes command does not apply to volumes in RSM robot 
types.

“Robot Attributes” on page 215 lists the robots that support barcodes.

When to Use Rescan/Update
Use Rescan/Update Barcodes only to fill in barcodes that are missing from the volume 
database.

For example, if you added a new volume to your configuration but did not physically 
insert the volume into the robotic library when the logical volume entry was added, the 
Media Manager volume database will not include the barcode. In this case, you can use 
this command to fill in the missing barcode, provided that the media has since been 
physically inserted in the robotic library.

When Not to Use Rescan/Update
Do not use this command to correct reports that show a media ID in the wrong slot. In this 
case, you must do one of the following:

� Logically move the volume using Actions > Move.

� Logically move the volume using Inventory Robot. See “Updating the Volume 
Configuration for a Robot” on page 97.

� Physically move the volume into the correct slot to agree with the volume database.

To obtain an inventory of the robotic library without updating the barcode information in 
the volume database, select Show Contents in the Robot Inventory dialog box. 

See “Comparing Robot Contents with the Volume Configuration” on page 94 for more 
information.

To Rescan/Update Barcodes
To check barcodes and update the volume database:
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1. In NetBackup Administration Console, click Media and Device Management > 
Media > Robots.

2. Select the robotic library that has the volumes that you want to check and update.

3. In the volume pane, select the volumes.

4. Click Actions > Rescan/Update Barcodes.

A dialog box appears with the results of the update.
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Monitoring Storage Devices
 5

The Device Monitor provides the tools needed to manage drives and operator service 
requests.

This chapter explains the Device Monitor and contains the following topics:

� Starting Device Monitor

� Using the Device Monitor Window

� Controlling the NetBackup Device Manager Service

� Administering Devices on Other Hosts

� Changing the Operating Mode of a Drive

� Resetting a Drive

� Adding or Changing a Drive Comment

� Handling Pending Requests and Pending Actions

� Assigning a Drive to a Pending Request

� Resolving Pending Actions

� Resubmitting Requests

� Denying Requests

Starting Device Monitor
In the NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

The Device Monitor window appears.
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Device Monitor Window

In addition to the tree pane on the left, two panes are initially displayed on the right when 
you start the Device Monitor:

� A pane showing global device topology.

� A pane showing drive information.

� In addition, a third pane for pending requests (or pending actions) is displayed if 
there is a pending request or pending action active.

Using the Device Monitor Window
The following topics describe various portions of the Device Monitor window:

� Menus and Commands

� Toolbars

� Global Topology Pane

� Drives Status Pane

� Pending Requests Pane

� Status Bar

� Shortcut Menus and Commands

� Tool Tips

� Customizing the Window

� Allowable Media Manager Characters
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Menus and Commands
The Device Monitor window has available the menus and commands shown in the 
following table.

The menu items are enabled based on what items are currently selected in the topology, 
drive status, or pending requests panes. For example, if a drive is selected in the topology 
pane Up Drive is enabled on the Actions menu.

Device Monitor Menus and Commands

Menu Commands

File Change Server - Displays a dialog box that allows you to change to a different 
NetBackup media server.

New Console - Starts another instance of NetBackup Administration Console.

New Window from Here - Starts another instance of the NetBackup Administration 
Console node that was active.

Backup, Archive, and Restore - Starts the NetBackup backup, archive, and restore GUI.

Print Setup - Displays the standard Windows print setup dialog.

Print - Prints the topology, drive status, or pending requests pane (when one of these 
panes is selected).

Close - Closes the current window.

Exit - Closes all open windows.

Edit Find - Displays a dialog to help you find specific data in the columns of the displays.

View Contains commands for specifying your viewing preferences for the Device Monitor, 
including showing and hiding the toolbar or tree, and refreshing the display. See 
“Customizing the Window” on page 148.
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Actions Note For NetBackup Datacenter SSO configurations, also see “Changing the Operating 
Mode of a Drive” on page 150.

Up Drive - Sets the drive to up in automatic volume recognition (AVR) mode. This is the 
normal and default mode for drives. In AVR mode, a robotic library automatically 
retrieves, mounts, unmounts, and stores volumes. Manual intervention is necessary 
only when a request causes an error.

For standalone drives using labeled volumes, when the volume is mounted and the tape 
drive is ready, Media Manager automatically reads the recorded media ID and assigns 
the tape drive.

For standalone drives using unlabeled volumes, you assign tape drives to requests 
using Actions > Assign Request.

Up Drive, Operator Control - Sets the drive to up in operator control mode (OPR). This 
mode is normally used only for security reasons. Do not use this mode for drives that 
are being used by NetBackup.

This command appears on the menu only if it has been enabled. Click View > Options > 
Device Monitor and select Allow Drive Up, Operator Controlled.

By default, all operations are similar as if in AVR mode. If standalone drive extensions 
have been disabled by using the DISABLE_STANDALONE_ DRIVE_EXTENSIONS 
entry in the NetBackup bp.conf file, all operations are similar as if in AVR mode 
except that labeled volumes are not automatically assigned to standalone drives. You 
must assign a standalone drive to a request using Actions > Assign Request.

Down Drive - Sets the selected drive to the DOWN mode, so it is not available to Media 
Manager. In this mode, drives are not under control of Media Manager and cannot be 
assigned to requests.

Reset Drive - Resets the specified drive, terminating the drive assignment and taking 
control away from the assigned user. For more information, see “Resetting a Drive” on 
page 152.

Change Drive Comment - Displays a dialog box for changing the comment for the 
selected drive. For NetBackup Datacenter SSO configurations, also see “Adding or 
Changing a Drive Comment” on page 153.

Drive Details - Displays a dialog with information about the selected drive, including 
drive properties, drive status, and robotic library information.

Assign Request - Assigns a drive to a pending request.

Deny Request - Denies a pending request.

Resubmit Request - Resubmits a pending request.

Display Pending Action - Displays information about the pending action.

Stop/Restart Device Manager Service - Controls the Media Manager device service.

Device Monitor Menus and Commands (continued)

Menu Commands
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Toolbars
The toolbar buttons of the Device Monitor window provide shortcuts for commands that 
are on the menus. 

To show or hide the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. Click View > ToolBar.

To change the display of the toolbar buttons:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. Click View > Customize > Toolbars.

Also see “Customizing the Window” on page 148.

Global Topology Pane
The Device Monitor topology view shows the state of all devices in the global database It 
is different from the NetBackup activity monitor topology in that it is a device centric 
view. It may show multiple NetBackup servers that are sharing the same devices 
(NetBackup DataCenter SSO option).

A description bar is displayed at the top of this pane. Tool Tips are provided for all of the 
objects displayed in the topology pane. See “Tool Tips” on page 147.

Your view of the topology pane can be customized, see “Changing the View of the 
Topology Pane” on page 148.

Help Help Topics - Provides online help information about the NetBackup Console.

VERITAS Web Page - Displays the VERITAS web page, if the host has a browser 
configured.

License Keys - Provides information about your active and registered license keys.

About NetBackup Administration Console - Displays program information, version 
number, and copyright information. You can click More Info for more detailed 
information.

Device Monitor Menus and Commands (continued)

Menu Commands
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Device hosts that are shown can not be filtered by modifying the Media Manager 
vm.conf file. The topology information that is displayed is taken from the Media 
Manager global device database.

Topology Images

The following images may appear in the topology pane. Shared drives are a NetBackup 
DataCenter option.

Description Topology Image

NetBackup master server

NetBackup media server

Robot 

Robot media

Drive

Drive that is shared
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There are also a number of state indicators for drives and shared drives. The images are 
similar, with the shared drive images having a hand at the bottom of the image.

Topology Connections

Connections in the topology indicate physical and logical connections of the devices, as 
follows:

� Master server and media server relationships are indicated and each has a different 
icon. Robots and drives are connected to a media server. 

� Drives that are physically located in a robotic library are shown directly below the 
robotic library. Standalone drives are represented as individual drive objects.

Drive State Indicator Drive Shared Drive

Empty

Tape loaded

Down

Reading

Writing

Active (reading or writing)

The control mode for a shared 
drive is not the same on all 
hosts sharing the drive.
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� Drive to device host connections are shown only if the drive is being used for a 
request and the drive is in use by NetBackup. Robot to server connections and robotic 
library to volume database connections are always shown.

� Media is represented as in a robotic library. 

� The topology also indicates a connection to its volume database host. 

Selecting Topology Objects

If you use the Show only items in list selected in topology option (see “Customizing the 
Window” on page 148) and select objects in the topology pane you can filter the contents 
of the lists in the Drives status pane. This action also highlights the connection lines in the 
topology.

If you do not use the Show only items in list selected in topology option and select an 
object, the object is highlighted in the other panes.

Multiple objects of the same type can be selected by pressing the Ctrl key and selecting 
another object. If the Ctrl key is pressed and an object of a different type is selected, the 
selection is not allowed. If the Ctrl key is not pressed and an object is selected, the 
previous selection will be unselected.

Drives Status Pane
This pane shows the status of the drives that Media Manager controls on this server. 
Information in the drive status pane is taken from the Media Manager global device 
database. The following table describes the columns displayed in this pane.

Managing the Drives Status Pane

The Edit menu has commands for finding items and is useful if you are managing many 
devices. You can use View > Columns > Layout to rearrange or hide specific columns in 
this display. Some of the columns are hidden initially by default.

Drives Status Pane

Column Description

Drive Name Drive name assigned to the drive during configuration.
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Type Drive type. Use this column to find a drive that supports the density required by 
the request. The drive type to use for each density is as follows:

4mm: 4mm cartridge

8mm: 8mm cartridge

dlt: DLT cartridge

hcart: 1/2-inch cartridge

qscsi: 1/4-inch cartridge

Control Control mode for the drive. Control mode can be any of the following:

- robot_designation. For drives in a robot. For example, TLD.

- DOWN-robot_designation. For drives in a robot. For example, DOWN-TLD.

- DOWN. For standalone drives only. In this mode, the drive is not available to 
Media Manager. 

A drive can be in a DOWN mode because of problems or because it was set to 
that mode using Actions > Down Drive.

- PEND-robot_designation. For drives in a robot. For example, PEND-TLD.

- PEND. For standalone drives only. 

If the drive reports a SCSI RESERVATION CONFLICT status, this column will 
show PEND. This status means that the drive is reserved when it should not 
be.

Several operating systems (Windows, Tru64, and HP-UX) also may report 
PEND if the drive reports Busy when opened. This reporting is likely caused 
by errors in the configuration. See the SCSI Reserve/Release section of the 
NetBackup Shared Storage Option guide for details.

- AVR (up in Automatic Volume Recognition mode). For standalone drives only. 
This is the normal operating mode.

- OPR (up in operator control mode). For standalone drives only.

- <Mixed> The control mode for a shared drive is not the same on all hosts 
sharing the drive (NetBackup DataCenter SSO option only). For shared drives 
each host can have a different status for the drive. If the control modes are all 
the same, that mode is displayed.

If the drive is a shared drive (NetBackup DataCenter SSO option only), click 
Actions > Drive Details to view the drive control mode for each host that is 
sharing this drive.

 Shared This column is used for the NetBackup Datacenter SSO feature. Yes, means this 
drive is configured as a shared drive. No, means the drive is not a shared drive.

For NetBackup BusinesServer this column contains the value No, since this 
feature is not supported.

Drives Status Pane

Column Description
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Assigned Host This column shows the device host that currently has the drive assigned. If the 
selected drive is not assigned, this column is blank.

User User ID of the person or application whose request is currently assigned to this 
drive. If the selected drive is not assigned, this column is blank.

Media Label Shows whether a labeled or unlabeled volume is mounted on this drive. Yes, 
means labeled. No, means unlabeled. Labeled volumes can also be Backup Exec 
volumes. A dash means there is no volume mounted on the drive.

Recorded 
Media ID

ID recorded on the volume mounted on this drive. This identifier is the same as 
the media ID and should match the external media ID. If no volume or a Backup 
Exec volume is mounted, this column is blank.

External
Media ID

External ID of the volume mounted on this drive. This identifier should match the 
recorded media ID. If no volume is mounted, this column is blank.

Ready Status of the drive, indicating if it is ready to perform an operation on the loaded 
volume. Yes, means ready. No, means not ready. 

See the vendor’s manual for the drive for instructions to make it ready, if it does 
not become ready automatically.

Writable Shows whether the volume currently mounted on this drive is write-enabled. Yes, 
in this column means the volume is write-enabled. No, means the volume is 
write-protected. A - in this column means there is no volume in the drive.

Drive Use 
History

Shows a graph of relative drive usage. The data for the graph is obtained from the 
Windows performance monitor. The graph is shown only if the following are true:

- The drive is connected to a Windows media server.

- A NetBackup job is active (the drive is in use).

- The user has permissions to read the Windows registry.

- The NetBackup bp.conf file has the entry for collecting drive usage enabled.

Host Name The name of the device host that has the drive. 

If the drive is a shared drive (NetBackup DataCenter SSO option only), use 
Actions > Drive Details to view a list of hosts that are sharing this drive.

Drive Index Drive index assigned to the drive during configuration.

If the drive is a shared drive (NetBackup DataCenter SSO option only), use 
Actions > Drive Details to view the drive index for each host that is sharing this 
drive.

Drives Status Pane

Column Description
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Pending Requests Pane
This pane shows pending requests (or pending actions) for volumes. These usually 
originate from NetBackup, but can come from a user.

This pane is not displayed until a pending request or pending action appears. After all 
requests have been resolved by Media Manager (automatically) or by operator 
intervention, the Pending Requests pane is again hidden. See “Handling Pending 
Requests and Pending Actions” on page 153 for more information.

The following table describes the columns that are displayed in this pane for a pending 
request or action.

Managing the Pending Requests Pane

The Edit menu has commands for finding items and is useful if you are managing many 
devices. You can use View > Columns > Layout to rearrange or hide specific columns in 
this display. Many of the columns are hidden by default.

Request ID If this drive is assigned to a request, this column contains the ID of the request.

Comment Comments that the administrator has added about this drive. See “Adding or 
Changing a Drive Comment” on page 153.

Drives Status Pane

Column Description

Pending Requests Pane

Column Description

Host Name The name of the device host that has the pending request.

Request ID Identification number for the request or action. This is a system-assigned number 
that identifies the request.

NOTE: A pending action is indicated by an asterisk to the left of the request ID.
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Recorded 
Media ID

Media ID of the volume requested by the user. It is the same media ID that is 
recorded in the volume database. The ID consists of up to six alphanumeric 
characters that are recorded at the beginning of the volume to identify the 
volume.

A volume with a recorded media ID is termed a labeled volume (that is, the volume 
was labeled by NetBackup or Backup Exec). Unlabeled volumes do not have 
recorded media IDs.

When a user requests an unlabeled volume and does not specify a recorded 
media ID, the external media ID appears in this column by default. This occurs 
because Media Manager assumes that the recorded and external media IDs are 
the same.

External
Media ID

External media ID of the volume requested by the user. The ID consists of up to 
six alphanumeric characters and is usually written on an external label attached 
to the volume. The external media ID is not recorded on the volume and is used to 
identify the volume before it is inserted in a robotic library.

User User ID of the person or application making the request.

Density Density of the volume required by the user. You must mount the volume on a 
drive that supports the required density. 

Densities correspond to the following drive types (to find a drive of the correct 
type, check the drive status list.):

4mm: 4mm cartridge tape

8mm: 8mm cartridge tape

dlt: DLT cartridge tape

hcart: 1/2-inch cartridge tape

qscsi: 1/4-inch cartridge tape

Mode Specifies whether the volume should be write-enabled. W in this column means 
you must write-enable the volume. R in this column means you do not have to 
write-enable the volume, unless specified by site policy. To write-enable a 
cartridge volume, move the tab off the safe position.

Time Time of day the user made the request for access.

Media 
Description

Describes the media in 25 or less alphanumeric characters. You create the 
description when you configure volumes.

Barcode Alphanumeric representation of the barcode label on the volume that was 
requested by the user. The barcode can contain up to 13 characters.

Pending Requests Pane

Column Description
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Status Bar
The status bar appears at the bottom of the NetBackup Console window. The status bar

� Shows tool tips (if tool tips are enabled). 

� Indicates the name of the media server.

� Indicates if you are connected to the device host you are trying to monitor.

To show or hide the status bar 

❖ Click View > Status Bar.

Shortcut Menus and Commands
Clicking the right mouse button while the pointer is over a pane or a selection in a pane, 
displays a shortcut menu with commands that apply to that context. These shortcut 
commands are also available on the menus or toolbars.

Tool Tips
Tooltips are helpful information for the toolbar buttons, or items in the topology pane (as 
you position the pointer). 

To enable tool tips 

1. In NetBackup Administration Console, click Device Monitor.

2. Click View > Customize.

3. On the Toolbars tab, select Show ToolTips.

Volume Group Volume group to which this volume belongs. A volume group defines the volume 
by location and is a logical group of volumes that are at the same physical 
location.

Pending Requests Pane

Column Description
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Customizing the Window
The View menu has options for sorting and changing the layout and appearance of the 
panes. 

Showing or Hiding Columns

You can use View > Columns > Layout to show or hide columns in the panes of the 
Device Monitor window.

Rearranging Columns

You can use View > Columns > Layout to rearrange the order of columns in the panes of 
the Device Monitor window.

Changing the View of the Topology Pane

Click View > Options > Device Monitor and select Fit topology to window on startup. 
This will fit the topology diagram to the pane and not use the default startup size.

Click View > Options > Device Monitor and select Show only items in list selected in 
topology. This allows you to filter the Drives status pane, showing drives based on your 
selections in the topology diagram.

Click View > Zoom > Zoom In to enlarge the topology diagrams. This can be done 
multiple times.

Click View > Zoom > Zoom Out to decrease the size of the topology diagrams. This can 
be done multiple times.

Click View > Zoom > Overview Window to select and focus on a portion of the topology 
diagram.

Click View > Zoom > Fit Window to size the topology diagram to the size of the current 
pane.

Changing the Screen Display Refresh Rate

The refresh rate specifies how often the Device Monitor will query the device host for new 
display data. 

Click View > Options > Device Monitor and set the desired refresh rate.
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Allowable Media Manager Characters
The following set of characters can be used in user-defined names, such as drive 
comments and drive names that you enter when creating these entities. These characters 
must be used even when specifying these items in foreign languages.

Do not use a minus as the first character or leave any spaces between characters.

� Alphabetic (A-Z a-z)

� Numeric (0-9)

� Period (.)

� Plus (+)

� Minus (-)

� Underscore (_)

Controlling the NetBackup Device Manager Service
The NetBackup Device Manager service must be running on the host being monitored or 
the lists in the Device Monitor detail panes will be blank. You can manage this service as 
follows:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. Click Actions > Stop/Restart Device Manager Service.

3. In the dialog box that appears, click the arrow to select a different device host.

The current status field shows the status of this service. The dialog allows you to start, 
stop, or stop/restart the service.

4. Select the action you want to perform.

5. Click OK or Apply when done.

Note You may find it useful to select Stop and click Apply, and then select Start and click 
Apply.
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Administering Devices on Other Hosts
Initially, you can monitor devices on the server where you are running the Device 
Monitor. The name of this server and its connection status is shown in the status bar (on 
the right side) of the Device Monitor window, for example Master Server: spain.

If you change from a NetBackup DataCenter server to a NetBackup BusinesServer server, 
the functionality available on the new server is limited to the functionality supported by 
NetBackup BusinesServer.

If you change from a NetBackup BusinesServer server to a NetBackup DataCenter server, 
complete functionality is available on the new server.

To change to a different server, use the following procedure:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. Click File > Change Server or click the arrow next to the change server icon.

In the dialog box for File > Change Server, do one of the following to specify the host 
to monitor:

- Enter the name of the host.

- Select a host from one of the hosts shown in the list.

- Click Browse and select a host.

You can also click Remove to delete a host from the list of hosts.

Click OK.

3. The name of the new device host appears in the status bar and the lists in the Device 
Monitor window change to show device information for the new device host.

The NetBackup Device Manager service must be running on the host that you are 
going to monitor, or the lists in the detail panes will be blank. If it is not running when 
you attempt to connect, a message box prompts you to start the service. Click Yes in 
this box.

Changing the Operating Mode of a Drive
It is usually not necessary to change the operating mode of a drive. Drives are set to the 
UP in AVR mode (the default mode) when you add drives to your configuration, and 
usually can be left at that setting. Other operating mode settings are used for special 
purposes. 
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For RSM robots, Media Manager does not scan the RSM library to update the status for 
devices. Therefore any physical device status changes done in the Microsoft RSM applet 
should also be updated in the Device Monitor. 

For example, if drive 2 is down in the RSM library, you must deactivate the drive on both 
the RSM applet and in Device Monitor. However if drive 2 is functional but you do not 
want NetBackup to assign it, then only the RSM applet interface need be updated.

To change the mode of a drive, do the following:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Drives status pane, select a drive or drives.

3. From the Actions menu, choose the command for the new operating mode you want 
(for example, Down Drive).

See the Actions menu in “Menus and Commands” on page 137 for an explanation of 
the operating mode commands.

Changing Mode Example
The following example shows the results of changing the operating mode of Drive2 from 
AVR to DOWN.

Note Some columns of the drive status list are not shown in this example.

The following example display shows the Drives status pane before changing the drive 
mode. Notice that the Control column shows AVR and the Ready column shows Yes.

                             Recorded External
Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drive1 qscsi OPR   chg  No    TST401  TST401  Yes   No         0
Drive2 4mm   AVR                              Yes

The following display shows the Drives status pane after using Actions > Down Drive to 
change the operating mode of Drive2 to DOWN. Notice that the Control column shows 
DOWN and the Ready column now shows No.

                             Recorded External
Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drive1 qscsi OPR   chg  No    TST401  TST401  Yes   No         0
Drive2 4mm   DOWN                             No
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Resetting a Drive

Caution Do not reset an assigned drive unless directed by site policy or the system 
administrator. Terminating an active job can destroy user data.

The actions that result from resetting a drive, depend on the state of the drive as follows:

Use the reset capability with caution. A situation where resetting a drive might be 
necessary is if a system problem causes the drive to remain assigned after a job is 
complete. In this case, the drive cannot be used for another request and the only way to 
regain control of the drive is to reset it.

Note Resetting a drive does not perform any SCSI bus or SCSI device resets.

To reset a drive:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Drives status pane, select a drive or drives.

3. Click Actions > Reset Drive.

4. Verify that the assignment was terminated by checking that the User and Request ID 
columns are empty for the drive number.

Drive State Reset Action

DOWN Media Manager attempts to unload the drive. This occurs for 
standalone drives, as well as drives in a robot.

UP state, not assigned to a user 
or application and in a ready 
state

Media Manager attempts to unload the drive. If the drive is not 
ready, no action occurs.

UP state and assigned to a user 
or application

Removes the tape. This takes control away from the user.
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Adding or Changing a Drive Comment

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Drives status pane, select the drive.

3. Click Actions > Change Drive Comment.

The dialog box shows the current comment (if any).

4. Enter a comment or change the comment and click OK.

Handling Pending Requests and Pending Actions
In the following topics, the operator is the person responsible for performing the manual 
intervention. A user is a person or application (for example, NetBackup) that initiates 
requests.

When NetBackup needs a volume to complete a tape mount, it displays a request in the 
Pending Requests pane. The following is an example request:

Note Some columns of the pending requests pane are not shown in this example.

              Recorded External
RequestID User MediaID MediaID Density Mode  Time Barcode Volume Group
0         ldr  LDR001  LDR001  4mm     Write 7:22 LDR001  rack_1

See the table in “Pending Requests Pane” on page 145 for an explanation of the columns in 
a pending request display.

Media Manager is able to resolve most requests automatically. For example, if the required 
volume is labeled and in a robotic library, Media Manager assigns the request as soon as 
the volume and a drive are available, and then removes the request and also the Pending 
Requests pane.

Pending Requests
Media Manager sometimes needs operator assistance to complete a tape mount request. 
In the following cases, Media Manager is unable to automatically assign the request and 
the request remains in the Pending Requests pane. In any of these cases, proceed as 
explained in “Assigning a Drive to a Pending Request” on page 154.
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� The required drive is in the Up Under Operator Control mode (OPR mode) and 
standalone drive extensions were disabled by using the 
DISABLE_STANDALONE_DRIVE_EXTENSIONS entry in the NetBackup bp.conf 
file.

� The volume in a drive is unlabeled (and the volume being mounted is not a known 
Backup Exec tape).

� NetBackup issues a write request for an unlabeled volume in a standalone drive and 
the standalone drive extensions were disabled.

A request for a volume that is displayed in the Pending Requests pane is sometimes called 
a mount request. This term means to make the volume available for reading or writing by 
placing it in an appropriate drive and then assigning the associated request to that drive.

Pending Actions
Media Manager also needs operator assistance to complete a tape mount request when the 
request causes an error. These special requests are called pending actions.

A pending action is indicated by an asterisk to the left of the request ID column.

In these cases, the problem must be resolved before proceeding. See “Resolving Pending 
Actions” on page 157.

Assigning a Drive to a Pending Request
Use the following procedure to assign a drive to a pending request.

Note You can also assign drives to a request by using the mouse to select and drag and 
drop items between the drive status and pending requests panes. 

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Pending Requests pane, select the request. Also, note the contents of the 
following columns of the request:

See Column To Determine 

Density The recording density that is required.

External Media ID The ID of the media that is required.
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3. In the Drives status pane:

a. Find a drive type that matches the density for the request. 

See the table in “Drives Status Pane” on page 142 for a list of the densities that 
each drive type supports.

b. Ensure that the drive is in the Up mode and not assigned to another request.

c. Select the drive.

4. If necessary, get the media, write-enable it, and insert it into the drive.

5. Wait for the drive to become ready, as explained in the drive equipment manual.

6. Click Actions > Assign Request.

Verify that the request disappears from the Pending Requests pane.

7. In the Drives status pane, verify that

- The assigned request ID appears in the Request ID column for the drive.

- The User column is filled in.

Assigning a Drive Example 1

Note Some columns of the drive status and pending requests panes are not shown in this 
example.

In this example, a pending request is assigned to a drive using Actions > Assign Request. 
The following sample display shows the Pending Requests pane before assigning the 
request.

              Recorded External
RequestID User MediaID MediaID Density Mode  Time Barcode Volume Group
2         cas  CAS135  CAS135  4mm     Read  7:30 CAS135  offsite

The following display shows the Drives status pane before assigning the request. Notice 
that Drv2 is available (the User and Request ID columns are empty) and is in OPR mode.

                             Recorded External

Mode Whether the volume should be write-enabled.

See Column To Determine 
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Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drv1  qscsi OPR    rhs  No    TST401  TST401  Yes   No         0
Drv2  4mm   OPR                               Yes

The following display shows the Drives status pane after the request is assigned to Drv2. 
Notice that for Drv2, the Request ID column now shows request 2 and the User column 
shows cas as the user.

                             Recorded External
Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drv1  qscsi OPR    rhs  No    TST401  TST401  Yes   No         0
Drv2  4mm   OPR    cas        CAS135  CAS135  Yes   Yes        2

The Pending Requests pane shows that the request has been cleared.

              Recorded External
RequestID User MediaID MediaID Density Mode  Time Barcode Volume Group

Assigning a Drive Example 2
This example shows how to satisfy a typical request where drives are up under Automatic 
Volume Recognition control (AVR mode).

Note Some columns of the drive status and pending requests panes are not shown in this 
example.

1. Assume that you have the following pending request. The contents of the pending 
request line determine how to proceed.

              Recorded External
RequestId User MediaID MediaID Density Mode  Time Barcode Volume Group
4         NBU  TV101   TV101   4mm     Write 1:35 TV101  nonrob

The first step is to find an available tape drive. The request specifies a recording 
density of 4mm. This means you need a 4mm cartridge tape drive. The volume is 
labeled so you do not have to assign the drive using Actions > Assign Request.

2. Check the Drives status pane to see if an appropriate tape drive is available.

                             Recorded External
Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drive1 dlt AVR                                No
Drive2 4mm AVR                                No

Drive2 is a 4mm cartridge tape drive and is available, since it is not down and there is 
not a request number in the Request ID column. See the table in “Drives Status Pane” 
on page 142 for an explanation of each column in the drives status list.
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3. Get the volume with the external media ID of TV101 and barcode of TV101. 
Depending on your site’s use of the Volume Group column, the volume group may 
give an indication of where the media ID is located.

4. Insert the volume into the drive. Assume that the tape drive is powered on and ready 
to receive the volume. Also, assume that when you insert the volume, the tape drive 
loads and positions it to the beginning.

5. Check the Drives status pane to verify that the drive is automatically assigned to 
request ID 4.

The following display shows that the assignment was successful. Drive2 is assigned 
to request 4, which is a request to write information on labeled volume TV101.

                             Recorded External
Drive Type Control User Label MediaID MediaID Ready Writable RequestID
Drive1 dlt AVR                                No
Drive2 4mm AVR     NBU  Yes   TV101   TV101   Yes Yes        4

In this example, the drive is up in AVR mode as indicated by AVR in the Control 
column. This means Media Manager assigned it automatically (which it does in AVR 
mode, providing the recorded media ID on the volume header matches the media ID 
for the request).

The write operation proceeds. When complete, NetBackup or the tpunmount 
command requests Media Manager to release the drive and Drive2 is available for 
other requests.

Resolving Pending Actions
A pending action is indicated by an asterisk to the left of the request ID column.

The procedure for resolving a pending action follows:

1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Pending Requests pane, select the pending action.

3. Click Actions > Display Pending Action.

This opens a message box with a description of the problem and a list of possible 
actions to correct it. The message box also shows other information, such as user 
name, recorded media ID, external media IDs, and drive number.

4. Click OK after viewing the information.
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5. In most cases, you can do one of the following to resolve the action:

- Correct the error condition and resubmit the request.

See “Resubmitting Requests” on page 158

- Click Actions > Deny Request to deny the request.

See “Denying Requests” on page 158.

Resubmitting Requests
The procedure to resubmit a request follows:

1. Correct the problem identified by the pending action message.

2. In the Pending Requests pane, select the request.

3. Click Actions > Resubmit Request.

The pending action message disappears from the Pending Requests pane and the 
operation proceeds.

If a pending action message involves a robotic library, after correcting the problem you 
may need to resubmit the request that caused the message before the operation can 
proceed. For example, if a volume is requested after being removed from a robotic library, 
do the following:

1. Insert the volume in the robotic library.

2. Perform an Update Volume Configuration.

See “Updating the Volume Configuration for a Robot” on page 97 for complete 
instructions.

3. Resubmit the request.

Denying Requests
Some situations may require you to deny requests for service (for example, when drives 
are not available, you cannot find the volume, or the user is not authorized to use it). 
Denying a request returns an error message to the user.
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1. In NetBackup Administration Console, click Media and Device Management > 
Device Monitor.

2. In the Pending Requests pane, select the request.

3. Click Actions > Deny Request.

The request is removed from the Pending Requests pane.
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Media Manager Commands and Processes
 A

This appendix describes Media Manager commands and Media Manager processes. These 
commands can be executed from a Windows command prompt.

The remaining commands in this appendix are for device management and are started or 
stopped by the NetBackup Device Manager service (ltid) as needed.

� tpreq and tpunmount are user commands for requesting tape mounts and 
unmounts for configured drives. 

� tpautoconf (for NetBackup DataCenter only), tpclean, tpconfig, and 
vmoprcmd are administrative commands for device management.

� vmadd, vmchange, vmcheckxxx, vmdelete, vmpool, vmquery, vmrule, and 
vmupdate are administrative commands for media management. 

The following conventions are used in the command descriptions:

� Brackets [ ] indicate that the enclosed component of the command line is optional.

� A vertical bar (or the pipe symbol) | separates optional arguments.

For example, if a command has the following format, you can choose arg1 or arg2 
(but not both):

command [arg1 | arg2]

� Italics indicate that the information is user supplied.
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rsmd
rsmd

NAME

rsmd - Removable Storage Manager (RSM) process

SYNOPSIS

install_path\Volmgr\bin\rsmd

DESCRIPTION

rsmd interfaces with Media Manager to automatically mount and unmount tapes that are 
under Microsoft Windows 2000 Removable Storage Manager (RSM) control. 

rsmd is initiated by the NetBackup Device Manager service (ltid), if the Media Manager 
device configuration shows drives in a robot controlled by RSM (the Media Manager 
robot type is rsm). Use the Windows Services applet to stop the NetBackup Device 
Manager service.

rsmd performs its tasks by sending requests to the Microsoft RSM service which 
communicates with the driver that controls the robot.

When the connection is established, rsmd puts the RSM robot is in the UP state and can 
mount and unmount tapes. If the connection cannot be established or robot errors exist, 
rsmd changes the robot to the DOWN state. In this state, rsmd is still running and returns 
the robot to the UP state when the problem no longer exists.

The Internet service number for rsmd must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\rsmd with a line that contains 
the service number for rsmd. The default service number is 13719.

ERRORS

Media Manager logs any RSM and network errors to the Windows 2000 application event 
log. Log entries are also made when the state changes between UP and DOWN.
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NAME

tl4d - Tape Library 4MM (TL4) process 

SYNOPSIS

install_path\Volmgr\bin\tl4d

DESCRIPTION

tl4d interfaces with Media Manager to mount and unmount tapes in a Tape Library 
4MM (TL4) robot. It is initiated by the NetBackup Device Manager service (ltid), if the 
Media Manager device configuration shows drives in the robot. Stopping ltid stops 
tl4d.

tl4d communicates with the robotics through a SCSI interface. When the connection is 
established (the path for robotics can be opened), tl4d puts the TL4 robot in the UP state 
and can mount and unmount tapes. If the robotics are inaccessible, tl4d changes the 
robot to the DOWN state. In this state, tl4d is still running and returns the robot to the 
UP state if it is able to make a connection.

The media ID and slot number information for 4 mm tapes in a robot must be defined in 
the Media Manager volume database before any tapes can be accessed through the 
NetBackup Device Manager service and tl4d.

If a cleaning volume is used, it must be defined in the volume configuration. See tpclean 
for information on setting the frequency for automatic drive cleaning.

The Internet service number for tl4d must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\tl4d with a single line that 
contains the service number for tl4d. The default service number is 13713.

ERRORS

Media Manager logs any Tape Library 4MM and robotic errors to the Windows 
application event log. Log entries are also made when the state changes between UP and 
DOWN.
Appendix A, Media Manager Commands and Processes 163



tl8d
tl8d

NAME

tl8d, tl8cd - Tape Library 8MM (TL8) process and control process

SYNOPSIS

install_path\Volmgr\bin\tl8d

install_path\Volmgr\bin\tl8cd

DESCRIPTION

tl8d and tl8cd interface with Media Manager to mount and unmount volumes in a 
Tape Library 8MM robot.

tl8d directly interfaces with the NetBackup Device Manager service (ltid). A tl8d 
process runs on each host with a drive connection and sends mount and unmount 
requests to the control process (tl8cd). tl8cd communicates with the robotics through 
a SCSI interface.

For NetBackup DataCenter, Tape Library 8MM robotic control software permits drives in 
the same robot to be configured on different hosts. tl8cd may be running on a different 
host than tl8d, depending on where the SCSI connection resides (see EXAMPLES). When 
the connection is established (that is, the path for robotics can be opened), tl8d puts the 
TL8 robot in the UP state and can mount and unmount volumes. If the robotics are 
inaccessible, tl8d changes the robot to the DOWN state. In this state, tl8d is still 
running and returns the robot to the UP state if tl8cd is able to make a connection.

Note If drives are on different NetBackup DataCenter hosts, the robotic information must 
be entered in the Media Manager configuration on all machines and the robot 
number must be the same on all machines.

tl8d and tl8cd are started when the NetBackup Device Manager service is started and 
stopped when this service is stopped. 

The control process, tl8cd, is on the host that has the robotic control and is 
automatically started by tl8d on that host (see EXAMPLES). tl8cd is stopped when you 
stop the NetBackup Device Manager service.

The media ID and slot number information for volumes in a robot must be defined in the 
volume database before any volumes can be accessed through the NetBackup Device 
Manager service, tl8d, and tl8cd.

If a cleaning volume is used, it must be defined in the volume configuration. See tpclean 
for information on setting the frequency for automatic drive cleaning.
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If the vm.conf configuration option PREVENT_MEDIA_REMOVAL is enabled when tl8cd 
is active, tl8cd disables access to the volumes and media access port by issuing a 
command to the TL8 robot. If it is necessary to open the door of the cabinet, you must 
terminate tl8cd first. By default, access to the library is allowed.

The drives are logically numbered 1 through n, where n is the number of drives in the 
robotic library. Use one or more of the following to determine the correct robot drive 
numbers:

� The Device Configuration wizard (if the robotic library and drives support 
serialization).

� The Robot Drive and Slot Layout appendix in the NetBackup Media Manager system 
administrator’s guide.

� The robotic library vendor’s documentation on drive indexing.

� The robotic test utility, or experiment by mounting media and watching the operator 
display.

The Internet service number for tl8cd must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\tl8cd with a single line that 
contains the service number for tl8cd. The default service number is 13705.

ERRORS

Media Manager logs any Tape Library 8MM and robotic errors to the Windows 
application event log. Log entries are also made when the state changes between UP and 
DOWN.

EXAMPLES

In the following diagram, the drives and the robotics are connected to a single host. ltid 
initiates tl8d, which in turn initiates tl8cd.

        host A                 TL8 Robot

     ------------            ------------- 

     |          |            |           | 

     |  ltid    |            |           | 

     |  tl8d    |            |           | 

     |  tl8cd   |            |-----------| 

     |          |         |--| Robotics  | 

     |          |         |  |-----------| 

     |          |         |--|  drive 1  | 

     |----------|         |  |-----------| 
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     |   SCSI   |------------|  drive 2  | 

     ------------            ------------- 

Note The following diagram applies only to NetBackup DataCenter.

In the following diagram, each host is connected to one drive in the robot and the robotics 
are connected to host A. ltid on each host initiates tl8d. The tl8d on host A also 
initiates tl8cd, since that is where the robotic control is defined. Requests to mount tapes 
from host B go to tl8d on host B, which sends the robotic command to tl8cd on host A.

    host A            TL8 Robot               host B 

------------        -------------         ------------ 

|          |        |           |         |          | 

|  ltid    |        |           |         |  ltid    | 

|  tl8d    |        |           |         |  tl8d    | 

|  tl8cd   |        |-----------|         |          | 

|          |   |----| Robotics  |         |          | 

|          |   |    |-----------|         |----------| 

|          |   |    |  drive 1  |---------|   SCSI   | 

|----------|   |    |-----------|         |----------| 

|   SCSI   |--------|  drive 2  |         |          | 

------------        -------------         ------------
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NAME

tldd, tldcd - Tape Library DLT (TLD) process and control process 

SYNOPSIS

install_path\Volmgr\bin\tldd

install_path\Volmgr\bin\tldcd

DESCRIPTION

tldd and tldcd interface with Media Manager to mount and unmount volumes in a 
Tape Library DLT (TLD) robot.

tldd directly interfaces with the NetBackup Device Manager service (ltid). tldd runs 
on each host with a drive connection and sends mount and unmount requests to the 
control process (tldcd). tldcd communicates directly with the robotics through a SCSI 
interface.

For NetBackup DataCenter, TLD robotic control software permits drives in the same robot 
to be configured on different hosts. tldcd may be running on a different host than tldd, 
depending on where the interface connection resides (see EXAMPLES). When the 
connection is established (that is, the path for robotics can be opened), tldd puts the TLD 
robot in the UP state and can mount and unmount volumes. If the robotics are 
inaccessible, tldd changes the robot to the DOWN state. In this state, tldd is still 
running and returns the robot to the UP state if tldcd is able to make a connection.

Note If drives are on different NetBackup DataCenter hosts, the robotic information must 
be entered in the Media Manager device configuration on all machines and the 
robot number must be the same on all machines.

tldd and tldcd are started when ltid is started and stopped when this service is 
stopped. 

tldcd is on the host that has the robotic control and is automatically started by tldd on 
that host. tldcd is stopped when you stop the NetBackup Device Manager service.

The media ID and slot number information for volumes in the robot must be defined in 
the volume database before any volumes can be accessed through the NetBackup Device 
Manager service, tldd, and tldcd.

If a cleaning volume is used, it must be defined in the volume configuration. See tpclean 
for information on setting the frequency for automatic drive cleaning.
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The drives are logically numbered 1 through n, where n is the number of drives in the 
robotic library. Use one or more of the following to determine the correct robot drive 
numbers:

� The Device Configuration wizard (if the robotic library and drives support 
serialization).

� The Robot Drive and Slot Layout appendix in the NetBackup Media Manager system 
administrator’s guide.

� The robotic library vendor’s documentation on drive indexing.

� The robotic test utility, or experiment by mounting media and watching the operator 
display.

The Internet service number for tldcd must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\tldcd with a single line that 
contains the service number for tldcd. The default service number is 13711.

ERRORS

Media Manager logs any Tape Library DLT and robotic errors to the Windows application 
event log. Log entries are also made when the state changes between UP and DOWN.

EXAMPLES

In the following diagram, the two drives and the robotics connect to Host A. ltid 
initiates tldd, which in turn initiates tldcd.

        Host A              TLD Robot

      __________          ___________

     |          |        |           |

     |  ltid    |        |           |

     |  tldd    |        |           |

     |  tldcd   |        |-----------|

     |          |     |--| Robotics  |

     |          |     |  |-----------|

     |          |     |  |           |

     |----------|     |  |-----------|

     |   SCSI   |-----|--|  drive 2  |

     |__________|     |  |-----------|

                      |--|  drive 1  |

                         |___________|
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Note The following diagram applies only to NetBackup DataCenter.

In the following diagram, each host connects to one drive and the robotics connect to host 
A. ltid on each machine initiates tldd. The tldd on host A also initiates tldcd, since 
that is where the robotic control is defined. Requests to mount tapes from host B go to 
tldd on host B, which sends the robotic command to tldcd on host A.

        host A             TLD Robot             host B

      __________          ___________           __________

     |  ltid    |        |           |         |  ltid    |

     |  tldd    |        |           |         |  tldd    |

     |  tldcd   |        |-----------|         |          |

     |          |   |----| Robotics  |         |          |

     |          |   |    |-----------|         |----------|

     |          |   |    |  drive 3  |---------|   SCSI   |

     |----------|   |    |-----------|         |----------|

     |   SCSI   |---|----|  drive 2  |         |          |

     |__________|   |    |-----------|         |__________|

                    |----|  drive 1  |

                         |___________|
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NAME

tpclean - manages tape drive cleaning

SYNOPSIS

install_path\Volmgr\bin\tpclean -L

install_path\Volmgr\bin\tpclean -C drive_name

install_path\Volmgr\bin\tpclean -M drive_name

install_path\Volmgr\bin\tpclean -F drive_name cleaning_frequency

DESCRIPTION

tpclean allows you to monitor Media Manager tape drive usage and optionally 
configure tape drives to be automatically cleaned (except drives in ACS, LMF, ODL, RSM, 
or TLH robots; or shared (SSO) drives).

Media Manager tracks the total amount of time that volumes have been mounted in the 
drives. You can use tpclean to specify a cleaning frequency (in hours) for a drive.

Drive cleaning occurs, if the following are true:

� The mount time exceeds the cleaning frequency.

� The drive is in a robot.

� The Media Manager volume configuration shows a cleaning tape in the robot.

The Comment field in the tpclean -L output will contain the message, NEEDS 
CLEANING, if the following are true. You can then manually clean the drive and reset the 
mount time using the -M option.

� The mount time exceeds the cleaning frequency.

� The drive is a standalone drive or does not have a cleaning tape defined.

For the -C, -M, and -F options, the NetBackup Device Manager service must be running. 
You must also have administrator privileges to execute this command.

See the reference topics appendix of the Media Manager system administrator’s guide for 
information about the TapeAlert feature that is available with most tape drives, and other 
related drive cleaning topics.
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OPTIONS

-C drive_name
Initiates the cleaning of a drive in a robot. The drive must be defined in a 
robot and a cleaning tape defined in the Media Manager volume 
configuration. The mount time is reset to zero. The drive name is the 
name that was assigned to the drive, when it was added.

-L
Prints cleaning statistics.

-M drive_name
Use this option to indicate that the drive has been manually cleaned. The 
mount time is reset to zero. The drive name is the name that was assigned 
to the drive, when it was added to the device configuration.

-F drive_name cleaning_frequency
Sets cleaning frequency for the specified drive to cleaning_frequency 
hours. The drive name is the name that was assigned to the drive when it 
was added. The value of cleaning_frequency must be between 0 and 
10,000 hours.
For NetBackup DataCenter, frequency-based cleaning is not supported 
for shared drives.

EXAMPLES

The following example displays cleaning statistics. An asterisk next to the drive type 
means the device is defined as robotic.

#tpclean -L

Drive Name   Type   Mount Time  Frequency   Last Cleaned   Comment

**********   ****   **********  **********  ************   *******

qsci_drv0    qscsi      0.0         0           N/A

rob_A_drv1   8mm*      11.4        30       14:33 05/29/92

4mm_drv5     4mm        5.6        10       13:01 06/02/92

dlt_drv6     dlt        3.0         0           N/A

The following example sets the cleaning frequency for the drive named qsci_drv0 to 25 
hours. The drive will be flagged as needing cleaning after 25 hours of mount time has 
occurred.

tpclean -F qsci_drv0 25

The following example resets the mount time for the drive named rob_A_drv1 to zero. 
You would normally use this command after you had manually cleaned the drive.

tpclean -M rob_A_drv1
Appendix A, Media Manager Commands and Processes 171



tpclean
The following example initiates the cleaning of drive rob_A_drv1. This example 
assumes the drive is a robotic drive, with a cleaning tape defined. The mount time is reset 
to zero.

You can use the -C option to force the cleaning of a drive prior to reaching 
cleaning_frequency. Normally, robotic drives are cleaned automatically when their mount 
time exceeds the cleaning frequency.

tpclean -C rob_A_drv1

Note To use a cleaning tape, the Cleanings Remaining for that tape (as shown in the 
volume list of the Media node in the NetBackup Administration Console or from 
the vmquery command) must be greater than zero. This cleaning count refers to 
how many more times the cleaning tape can be used. You can change this count 
using the Media node or the vmchange command.
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NAME

tpconfig - Tape configuration utility

SYNOPSIS

install_path\Volmgr\bin\tpconfig -d

install_path\Volmgr\bin\tpconfig -l

install_path\Volmgr\bin\tpconfig -dl

install_path\Volmgr\bin\tpconfig -lsavdbhost

install_path\Volmgr\bin\tpconfig -add -drive -type drvtype -path 
drivepath [-asciiname asciidrivename] [-index drvindex] 
[-shared [yes|no]] [-cleanfreq hours] [-comment 
comment] [-drstatus [UP|DOWN]] [-robot robnum -robtype 
robtype] [-noverify] [-robdrnum robdrvnum | 
-VendorDrvName venddrvname | -ACS acsnum -LSM lsmnum 
-PANEL panelnum -DRIVE drivenum]

install_path\Volmgr\bin\tpconfig -update -drive drvindex [-type 
drvtype] [-path drivepath] [-newasciiname asciidrivename] 
[-shared [yes|no]] [-cleanfreq hours] [-comment 
comment] [-drstatus [UP|DOWN]] [-robot robnum -robtype 
robtype] [-noverify] [-robdrnum robdrvnum | 
-VendorDrvName venddrvname | -ACS acsnum -LSM lsmnum 
-PANEL panelnum -DRIVE drivenum]

install_path\Volmgr\bin\tpconfig -delete -drive drvindex

install_path\Volmgr\bin\tpconfig -multiple_delete -drive 
drvindex1:drvindex2: ... drvindexN

install_path\Volmgr\bin\tpconfig -add -robot robnum -robtype robtype 
-robpath robpath [-vdbhost volume_database_host]

install_path\Volmgr\bin\tpconfig -add -robot robnum -robtype robtype 
-port portnum -bus busnum -target targetnum -lun lun 
[-vdbhost volume_database_host]

install_path\Volmgr\bin\tpconfig -add -robot robnum -robtype robtype 
-cntlhost cntlhost [-vdbhost volume_database_host]

install_path\Volmgr\bin\tpconfig -update -robot robnum [-robtype 
robtype] [-robpath robpath | -port portnum -bus busnum 
-target targetnum -lun lun | -cntlhost cntlhost] [-vdbhost 
volume_database_host]
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install_path\Volmgr\bin\tpconfig -delete -robot robnum

install_path\Volmgr\bin\tpconfig -multiple_delete -robot 
robnum1:robnum2: ... robnumN

install_path\Volmgr\bin\tpconfig -savdbhost 
standalone_volume_database_host

DESCRIPTION

The tpconfig command can be used to configure drives and robots for use with 
NetBackup. The default for install_path is C:\Program Files\VERITAS.

When your device configuration changes are complete, stop and restart the NetBackup 
Device Manager service.

OPTIONS

-l
Lists the current device configuration, without volume database host 
names.

-d
Lists the current configuration information, including volume database 
host names.

Note The following option is only applicable for NetBackup DataCenter.

-lsavdbhost
Lists the volume database host for standalone drives. This is the host 
where the NetBackup Volume Manager Service maintains the volume 
configuration for standalone drives.

-add
Adds a drive or a robot, depending on the accompanying options.

-update
Changes the configuration information for a drive or robot. For example, 
you can add a drive to a robot. 

-delete
Deletes a drive or robot, depending on the accompanying options.

-multiple_delete
Deletes multiple drives or robots, depending on the accompanying 
options.

Note The following option is applicable only for NetBackup DataCenter.
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-savdbhost standalone_volume_database_host
Sets the volume database host for standalone drives that attach to this 
host.

-drive
Use this option with the -add option to specify that the action is for a 
drive.

-drive drvindex
Use this option with the -update, -delete,or -multiple_delete 
options to specify the drive index and that the action is for a drive.

-type drvtype
Specifies the type of drive that you are configuring. 
This can be any of the following for NetBackup DataCenter:
4mm for 4mm tape drive, 8mm for 8mm tape drive, 8mm2 for 8mm tape 
drive 2, 8mm3 for 8mm tape drive 3, dlt for DLT tape drive, dlt2 for 
DLT tape drive 2, dlt3 for DLT tape drive 3, hcart for Half-inch 
cartridge drive, hcart2 for Half-inch cartridge drive 2, hcart3 for 
Half-inch cartridge drive 3, qscsi for Quarter-inch cartridge drive.
This can be any of the following for NetBackup BusinesServer:
4mm for 4mm tape drive, 8mm for 8mm tape drive, dlt for DLT tape drive, 
hcart for Half-inch cartridge drive, qscsi for Quarter-inch cartridge 
drive.

-path drivepath
Specifies the Windows system name for the drive. For example, TAPE0.

-comment comment
Adds a comment about the drive. This field is useful for storing SCSI 
inquiry data so you can easily check the drive type and firmware level.

-index drvindex
A drive index is a unique number that is used to identify the drive. When 
you add a drive you are not required to supply a drive index, since the 
next available drive index is used by Media Manager. Each drive on a 
particular host must have a unique index number.

-drstatus UP|DOWN
Sets the initial status of the drive to the Up or Down state. You can also 
perform this action with options in the Device Management window.

-cleanfreq hours

Note Not used with shared drives.
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Specifies the number of hours between drive cleanings. When you add a 
drive, NetBackup starts recording the amount of time that volumes are 
mounted in that drive.
If the drive is in a robot and a cleaning volume is defined in the robot, 
cleaning occurs when the accumulated mount time exceeds the time that 
you specify for cleaning frequency. NetBackup resets the mount time 
when the drive is cleaned.
If the drive is standalone or if a cleaning tape is not defined, the message 
NEEDS CLEANING appears in the comment field of the tpclean -L 
output. To clean the drive, use the tpclean command.

-robot robnum
A unique number that identifies the robot to NetBackup. You assign the 
robot number when you add the robot using the add option.
For NetBackup DataCenter, robot numbers must be unique for all robots 
that share the same volume database host (and therefore use the same 
volume database). This applies regardless of the robot type or the host 
that controls them. For example, if you have two TSD robots controlled 
by different hosts, but they have the same volume database host, then the 
robot numbers must be different.

-robtype robtype
Specifies the type of robot that you are configuring and can be any of the 
types supported by NetBackup on Windows servers.
The type of robot can be any of the following for NetBackup DataCenter:
acs for Automated Cartridge System, rsm for Removable Storage 
Manager (Windows 2000 only), tl4 for Tape Library 4mm, tl8 for Tape 
Library 8mm, tld for Tape Library DLT, tlh for Tape Library Half-inch, 
tlm for Tape Library Multimedia, ts8 for Tape Stacker 8mm, tsd for 
Tape Stacker DLT.
The type of robot can be any of the following for NetBackup 
BusinesServer:
rsm for Removable Storage Manager (Windows 2000 only), tl4 for Tape 
Library 4mm, tl8 for Tape Library 8mm, tld for Tape Library DLT, ts8 
for Tape Stacker 8mm, tsd for Tape Stacker DLT.

-noverify
If this option is specified, drive paths are not verified. Normally, 
tpconfig verifies that the no rewind on close drive path has the correct 
minor number bits relating to no rewind, variable, Berkeley-style, and so 
on. This option is normally not required, but may be helpful if using 
non-standard platform device files. If this option is specified, caution 
should be taken in making sure the device files are correct.
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-robdrnum robdrvnum
Specifies the physical location (within the robot) of the drive. If you 
assign the wrong number, NetBackup does not detect it, but an error 
eventually occurs because the robotic control attempts to mount media on 
the wrong drive.
You can usually determine the physical location by checking the 
connectors to the drives or the vendor documentation.
The Robot Slot and Layout appendix of the Media Manager system 
administrator’s guide shows drive layouts for many of the robots that 
NetBackup supports.

Note The following four ACS options are not supported in NetBackup BusinesServer.

-ACS acsnum

-LSM lsmnum

-PANEL panelnum

-DRIVE drivenum
These options specify the configuration for ACS (Automated Cartridge 
System) robots.
acsnum specifies the number for the robotic library as configured on the 
ACS library software host.
lsmnum specifies the Library Storage Module that has this drive.
panelnum specifies the robot panel where this drive is located.
drivenum specifies the number of this drive.

Note The following two options are not supported in NetBackup BusinesServer.

-VendorDrvName venddrvname
Specifies the IBM device name for a TLH robotic drive or the DAS drive 
name for a TLM robotic drive.

-shared yes|no
Specify yes, if the drive you are adding or updating will be shared 
among hosts.

-asciiname asciidrivename
Specifies a name for the drive. This name identifies the drive to Media 
Manager. If you do not specify a drive name, Media Manager generates a 
name.
For NetBackup DataCenter, if you are adding or updating shared drives, 
make this name as descriptive as possible.
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-newasciiname asciidrivename
Specifies a new name for the drive.

Note For a SCSI-controlled robot on NetBackup DataCenter, specify the -port, -bus, 
-target, and -lun options if the robotic control is on the local Windows host and 
there is no changer name associated with the robotic library.
If the robot control is on the local Windows 2000 host and supported by Windows 
2000, configure the robot using  -robpath pathname (using the changer name as 
pathname).
If the robotic control is on a remote host, use the -cntlhost option.

Note For NetBackup BusinesServer if a TLD or TL8 robot is used on and supported by 
Windows 2000, configure it using  -robpath.

-port portnum
Specifies the SCSI port number to which the robot connects. You can find 
this information in the registry.

-bus busnum
Specifies the SCSI bus number to which the robot connects.

-target targetnum
Specifies the target number (or SCSI ID) to which the robot connects.

-lun lun
Specifies the logical unit number.

Note The following option is only applicable for NetBackup DataCenter.

-cntlhost cntlhost
For a robot whose robotic control is on another host, this option specifies 
the host that controls the robotic library. 
This option applies only to TL8, TLD, and TLH robots that can have the 
robotic control on another host, and to ACS and TLM robots.
For an ACS robot, specify the host name where the ACS library software 
is installed.
For a TLM robot, specify the host name where the DAS software is 
installed.

-robpath robpath
If the robot that you are adding or updating has a changer name 
associated with it, and is on UNIX host or Windows 2000 host, use this 
option.

Note The following option is only applicable for NetBackup DataCenter.
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-vdbhost volume_database_host
For a robot, this specifies the volume database host. This is the host that 
will have the information about the media in the robot.

EXAMPLES

Note In the following examples, the command that is entered is shown on multiple lines 
because of page limitations. The actual command is entered on one line.

EXAMPLE 1: ROBOTIC CONTROL ON LOCAL WINDOWS SERVER

The following example adds a robot that connects directly to a Windows host, and also 
adds drives to that robot. For NetBackup BusinesServer there is only one host (the 
master), so the -vdbhost option is not needed.

1. Add the robot using the following command:

tpconfig -add -robot 7 -robtype tld -port 0 -bus 0 -target 2 lun 
0 -vdbhost walleye

2. If there are drives in the robot that have not been configured, add them.

The following command configures the drive with the system name of Tape0 under 
control of the robot configured in step 1 (Tape0 has been attached and recognized by 
the server.)

tpconfig -add -drive -type dlt -path Tape0 -comment “DEC     
DLT2000 8414” -index 0 -drstatus up -robot 7 -robtype tld 
-robdrnum 1 -asciiname DLT2000_D1

The command in this example uses the comment field. This field is useful for storing 
the drive’s SCSI inquiry data so that drive type and firmware level can be easily 
checked.

3. If the robot contains drives that are currently configured as standalone drives, update 
the drive configuration to place them under robotic control. 

The following commands update the configuration for drives 1 and 2:

tpconfig -update -drive 1 -type dlt -robot 7 -robtype tld 
-robdrnum 1

tpconfig -update -drive 2 -type dlt -robot 7  -robtype tld 
-robdrnum 2

Note It is important that you assign the correct robot drive number to the drives. If robot 
drive numbers are incorrect, tape mounts or backups may fail.
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EXAMPLE 2: ROBOTIC CONTROL ON REMOTE HOST

Note The following example applies only to NetBackup DataCenter.

This example adds a robot that connects to another host. It assumes that one or more tape 
drives that are in the robot, connect to the Windows host where you are currently 
managing devices.

1. Add the robot by executing the following command:

tpconfig -add -robot 9 -robtype tld -cntlhost perch  -vdbhost 
perch

Ensure that the robot number matches the one on the control host.

2. If the robot contains drives that are currently configured as standalone, update the 
drive configuration to place them under robotic control.

The following commands update the configuration for drives 1 and 2:

tpconfig -update -drive 1 -type dlt -robot 9  -robtype tld 
-robdrnum 1

tpconfig -update -drive 2 -type dlt -robot 9  -robtype tld 
-robdrnum 2

Note It is important that drives are assigned the correct robot drive number. If robot drive 
numbers are incorrect, tape mounts or backups may fail.

3. If there are drives in the robot that have not been configured, add them now. 

The following command configures the drive with the system name of Tape0 under 
control of the robot configured in step 1. (Tape0 has been attached and recognized by 
the Windows server.)

tpconfig -add -drive -type dlt -name Tape0 -comment “DEC     
DLT2000 8414” -index 3 -drstatus up -robot 9 -robtype tld 
-robdrnum 3 -asciiname DLT2000_D3

EXAMPLE 3: CONFIGURING NEW STANDALONE DRIVES

The following is an example of adding a standalone drive, after the drive is installed:

tpconfig -add -drive -type dlt -name Tape0 -comment “DEC     
DLT2000 8414” -index 6 -asciiname DLT2000_standalone
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NAME

tpreq - request a tape volume for mounting and associate a file name with the assigned 
drive

SYNOPSIS

install_path\Volmgr\bin\tpreq -m media_id [-a accessmode] [-d density] 
[-p poolname] [-f] filename 

DESCRIPTION

This command initiates a mount request for a tape volume on a removable media device. 
The information that you specify with this command identifies and registers the specified 
file as a logical identifier for the mount request with Media Manager and manages access 
to the volume.

Media Manager automatically mounts the media if it is in a robotic drive. Otherwise, an 
operator mount request appears in the Device Monitor window. tpreq will not complete 
normally in the case of a mount request for a robotic drive, if operator intervention is 
required. These requests also appear in the Device Monitor window.

When the operation is complete, use the tpunmount command to remove the file name 
from the directory in which the file was created.

OPTIONS

-m media_id
Specifies the media ID of the volume to be mounted. You can enter the ID 
in upper or lowercase; Media Manager converts it to uppercase.

-a accessmode
Specifies the access mode of the volume. Valid access modes are w and r. 
If the access mode is w (write), the media must be mounted with write 
enabled. The default is r (read), which means the media may be write 
protected.

-d density
Specifies the density of the drive. This option determines the type of drive 
on which the tape volume is mounted. The default density is dlt.
Valid densities for NetBackup DataCenter follow:
4mm for 4-mm cartridge, 8mm for 8-mm cartridge, 8mm2 for 8-mm 
cartridge 2, 8mm3 for 8-mm cartridge 3, dlt for DLT cartridge, dlt2 for 
DLT cartridge 2, dlt3 for DLT cartridge 3, hcart for 1/2 Inch cartridge, 
hcart2 for 1/2 Inch cartridge 2, hcart3 for 1/2 Inch cartridge 3, qscsi for 
1/4-inch cartridge.
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For NetBackup DataCenter, the half-inch cartridge densities (hcart, 
hcart2, and hcart3) can be used to distinguish between any supported 
half-inch drive types. However, tape requests can only be assigned to 
drives of the associated media type. For example, a tape request with 
density hcart2 specifying a media ID with media type HCART2 will be 
assigned to an hcart2 drive. Likewise, a tape request with density hcart 
specifying an media ID with media type HCART will be assigned to an 
hcart drive. The same rules apply to the DLT densities (dlt, dlt2, and dlt3) 
and the 8MM densities (8mm, 8mm2, and 8mm3).

Valid densities for NetBackup BusinesServer follow:
4mm for 4-mm cartridge, 8mm for 8-mm cartridge, dlt for DLT cartridge, 
hcart for 1/2 Inch cartridge, qscsi for 1/4-inch cartridge.
The mount request must be performed on a drive type that satisfies the 
density.

-p poolname
Specifies the volume pool where the volume resides. poolname is case 
sensitive. The default is None.

-f filename
Specifies the file to be associated with the volume.
The file name can be a single name or a complete path. If you specify only 
a file name, the file is created in the current working directory. If you 
specify a path, the file is created in the directory named in the path. 
filename cannot be an existing file.
If the tpreq command is successful, Media Manager creates a file with 
the name that you specified. This file contains the name of the tape device 
where the media is mounted. Do not delete this file. Use the tpunmount 
command to remove it.
Specifying -f before filename is optional.
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NAME

tpunmount - removes a tape volume from a drive and tape file from the directory

SYNOPSIS

install_path\Volmgr\bin\tpunmount [-f] filename [-force]

DESCRIPTION

tpunmount removes a tape file from the directory and physically removes the tape 
volume from the drive (if the media was mounted). 

Standalone drives are not unloaded when the DO_NOT_EJECT_STANDALONE option is 
specified in the vm.conf file (and the -force option is not specified).

The tape file and the device must be closed before you can use tpunmount.

OPTIONS

-f filename
Specifies the file associated with the media. You must specify a file name.
Specifying -f before filename is optional.

-force
Ejects the volume from a standalone drive, even if 
DO_NOT_EJECT_STANDALONE was specified in the vm.conf file.

EXAMPLE

The following command unmounts the tape volume associated with file tape1 and 
removes the file from the current directory:

tpunmount tape1
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NAME

ts8d - Tape Stacker 8MM (TS8) process 

SYNOPSIS

install_path\Volmgr\bin\ts8d

DESCRIPTION

ts8d interfaces with Media Manager to mount and unmount tapes in a Tape Stacker 
8MM robot. It is initiated by the NetBackup Device Manager service (ltid), if the Media 
Manager device configuration shows drives in a Tape Stacker 8MM. Stopping this service 
stops ts8d. 

ts8d communicates directly with the robotics through a SCSI interface. When the 
connection is established (the path for robotics can be opened), ts8d puts the TS8 robot in 
the UP state and can mount and unmount tapes. If the robotics are inaccessible, ts8d 
changes the robot to the DOWN state. In this state, ts8d is still running and returns the 
robot to the UP state if it is able to make a connection.

The media ID and slot number information for 8mm tapes in a robot must be defined in 
the volume database before any tapes can be accessed through the NetBackup Device 
Manager service and ts8d.

If a cleaning volume is used, it must be defined in the volume configuration. See tpclean 
for information on setting the frequency for automatic drive cleaning.

The Internet service number for ts8d must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\ts8d with a single line that 
contains the service number for ts8d. The default service number is 13709.

 ERRORS

Media Manager logs any Tape Stacker 8MM and robotic errors to the Windows 
application event log. Log entries are also made when the state changes between UP and 
DOWN.
184 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



tsdd
tsdd

NAME

tsdd - Tape Stacker DLT (TSD) process 

SYNOPSIS

install_path\Volmgr\bin\tsdd

DESCRIPTION

tsdd interfaces with Media Manager to mount and unmount tapes in Tape Stacker DLT 
(TSD) robots. It is initiated by the NetBackup Device Manager service (ltid), if the Media 
Manager device configuration shows drives in the Tape Stacker DLT (TSD). Stopping this 
service stops tsdd. 

tsdd communicates directly with the robotics using a SCSI interface. When the 
connection is established (the path for robotics can be opened), tsdd puts the TSD robot 
in the UP state and can mount and unmount tapes. If the robotics are inaccessible, tsdd 
changes the robot to the DOWN state. In this state, tsdd is still running and returns the 
robot to the UP state if it is able to make a connection.

The media ID and slot number information for DLT tapes in a robot must be defined in the 
volume database before any tapes can be accessed through the NetBackup Device 
Manager service and tsdd.

If a cleaning volume is used, it must be defined in the volume configuration. See tpclean 
for information on setting the frequency for automatic drive cleaning.

The Internet service number for tsdd must be in 
%SystemRoot%\system32\drivers\etc\services. To override the services file, 
create the file install_path\Volmgr\database\ports\tsdd with a single line that 
contains the service number for tsdd. The default service number is 13714.

ERRORS

Media Manager logs any Tape Stacker DLT robot and robotic errors to the Windows 
application event log. Log entries are also made when the state changes between UP and 
DOWN.
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NAME

vmadd - Add volumes to the volume database

SYNOPSIS 

install_path\Volmgr\bin\vmadd -m media_id -mt media_type [-h 
volume_database_host] [-verbose] [-b barcode] [-rt 
robot_type] [-rn robot_number] [-rh robot_host] [-rc1 
rob_slot] [-rc2 rob_side] [-p pool_number] [-mm max_mounts 
| -n cleanings] [-op optical_partner] [-d "media_description"]

DESCRIPTION

Add volumes to the Media Manager volume database.

OPTIONS

-m media_id
Specifies the media ID of the volume to add. The media ID can be a 
maximum of 6 ASCII characters. 
For NetBackup DataCenter if you are adding an optical disk, specify the 
media ID for the A side of the optical platter. Media IDs for an API robot 
type (ACS, TLH, TLM, LMF, or RSM) must always match the barcodes.
For NetBackup BusinesServer, media IDs for an RSM robot must always 
match the barcodes.

-mt media_type
Specifies the media type of the volume to add. 
Valid media types for NetBackup DataCenter are: 4mm, 8mm, 8mm2, 
8mm3, dlt, dlt2, dlt3, dtf, hcart, hcart2, hcart3, odiskwm, odiskwo, qcart, 
4mm_clean, 8mm_clean, 8mm2_clean, 8mm3_clean, dlt_clean, 
dlt2_clean, dlt3_clean, dtf_clean, hcart_clean, hcart2_clean, hcart3_clean.
Valid media types for NetBackup BusinesServer are: 4mm, 8mm, dlt, 
hcart, qcart, 4mm_clean, 8mm_clean, dlt_clean, hcart_clean.

Note The following option is only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host with the volume database where the volume will be 
added. You should ensure that the host specified matches the volume 
database host name associated with the robot or set of standalone drives, 
as indicated in the device configuration. If no host is specified, the host 
where you execute the command is assumed.
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-verbose
Selects verbose mode.

-b barcode
Specifies the barcode attached to the volume.

-rt robot_type
Specifies the robot type of the robot where the volume is located.
Valid robot types for NetBackup DataCenter are: none, acs, lmf, odl, rsm, 
tl4, tl8, tld, tlh, tlm, ts8, tsd, tsh.
Valid robot types for NetBackup BusinesServer are: none, rsm, tl4, tl8, tld, 
ts8, tsd.

-rn robot_number
Unique, logical identification number for the robot where the volume is 
located.

-rh robot_host
Name of the host which controls the robot, where the volume is located.

-rc1 rob_slot
Robot coordinate 1 is the slot number in the robot where the volume is 
located.
For NetBackup DataCenter, do not enter slot information for Media 
Manager API robot types. The robot software tracks the slot locations for 
these robots.
For NetBackup BusinesServer, do not enter slot information for Media 
Manager RSM robot types. The robot software tracks the slot locations for 
these robots.

Note The following option is only applicable for NetBackup DataCenter.

-rc2 rob_side
Robot coordinate 2 is the platter side for optical disks (A or B).

-p pool_number
Index of the volume pool which will contain this volume. You can use 
vmpool -listall to determine the index for a given pool name.

-mm max_mounts
Maximum number of mounts allowed for this volume. Only used for 
non-cleaning media. When this limit is exceeded, the volume can be 
mounted for read operations only.

-n cleanings
Number of cleanings remaining for this volume. Only used for cleaning 
media.
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Note The following option is only applicable for NetBackup DataCenter.

-op optical_partner
If this is an optical disk, specify the media ID of the opposite side of the 
optical platter.

-d "media_description"
Media description of the volume. The double quote marks are required if 
the description contains any spaces.

EXAMPLES

The following command adds volume AJU244 in the NetBackup volume pool to the 
volume database on the host named llama. For NetBackup BusinesServer there is only one 
host (the master), so the -h option is not needed.

The volume, with a barcode of AJU244, is in slot 2 of TLD robot 1. For write operations, 
the volume may be mounted a maximum of 1000 times.

Note This command is usually entered on one line.

vmadd -m AJU244 -mt dlt -h llama -b AJU244 -rt tld -rn 1 -rh llama 
-rc1 2 -p 1 -mm 1000 -d "vmadd example"

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmchange, vmdelete, vmpool, vmquery
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NAME

vmchange - change media information in the Media Manager volume database

SYNOPSIS

Change volume group residence

install_path\Volmgr\bin\vmchange [-h volume_database_host] -vg_res 
-rt robot_type -rn robot_number -rh robot_host -v volume_group

Change volume residence

install_path\Volmgr\bin\vmchange [-h volume_database_host] -res -m 
media_id -mt media_type -rt robot_type -rn robot_number -rh 
robot_host -v volume_group -rc1 rob_slot [-rc2 rob_side]

Change volume expiration date

install_path\Volmgr\bin\vmchange [-h volume_database_host] -exp 
mm/dd/yy hh:mm:ss -m media_id

Change the barcode for a volume

install_path\Volmgr\bin\vmchange [-h volume_database_host] -barcode 
barcode -m media_id [-rt robot_type]

Change the media description for a volume

install_path\Volmgr\bin\vmchange [-h volume_database_host] -d 
"media_description" -m media_id

Associate this volume with a different pool

install_path\Volmgr\bin\vmchange [-h volume_database_host] -p 
pool_number -m media_id

Change a volume’s maximum mount count

install_path\Volmgr\bin\vmchange [-h volume_database_host] -maxmounts 
max_mounts -m media_id

Change a volume’s number of mounts count or cleanings

install_path\Volmgr\bin\vmchange [-h volume_database_host] -n 
num_mounts/cleanings -m media_id

Change a volume’s media type

install_path\Volmgr\bin\vmchange [-h volume_database_host] -new_mt 
media_type -m media_id
Appendix A, Media Manager Commands and Processes 189



vmchange
Change a volume’s robot type

install_path\Volmgr\bin\vmchange [-h volume_database_host] -new_rt 
robot_type -m media_id -rn robot_number

Change a volume’s group

install_path\Volmgr\bin\vmchange [-h volume_database_host] -new_v 
volume_group [-m media_id |-b barcode -mt media_type -rt 
robot_type]

Change a volume’s vault name 

install_path\Volmgr\bin\vmchange [-h volume_database_host] -vltname 
vault_name -m media_id

Change the date the volume was sent to the vault

install_path\Volmgr\bin\vmchange [-h volume_database_host] -vltsent 
mm/dd/yy hh:mm:ss -m media_id

Change the date when the volume returns from the vault

install_path\Volmgr\bin\vmchange [-h volume_database_host] -vltreturn 
mm/dd/yy hh:mm:ss -m media_id

Change a volume’s vault slot number

install_path\Volmgr\bin\vmchange [-h volume_database_host] -vltslot 
vault_slot -m media_id

Change the volume’s vault session id

install_path\Volmgr\bin\vmchange [-h volume_database_host] 
-vltsession vault_session_id -m media_id

Move (eject) volumes from an ACS, TLH, or TLM robot to standalone

install_path\Volmgr\bin\vmchange -api_eject -map map_id -w [-h 
volume_database_host] -res -ml media_id1:media_id2: ... 
media_idn -rt robot_type -rn robot_number -rh robot_host [-v 
volume_group]

Move (eject) multiple volumes from a TL8 or TLD robot to standalone

install_path\Volmgr\bin\vmchange -multi_eject -w [-h 
volume_database_host] -res -ml media_id1:media_id2: ... 
media_idn -rt robot_type -verbose -rn robot_number -rh 
robot_host

Move (inject) multiple volumes into a TL8 or TLD robot

install_path\Volmgr\bin\vmchange -multi_inject -w -res -rt 
robot_type -verbose -rn robot_number -rh robot_host
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Get robot information for a TL8 or TLD robot type

install_path\Volmgr\bin\vmchange -res -robot_info -verbose -rn 
robot_number -rt robot_type -rh robot_host

DESCRIPTION

Change volume information in the Media Manager volume database. 

OPTIONS

Note The following option is only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which keeps 
information about the media in robots and standalone drives. If no host 
is specified, the host where you execute the command is assumed.

-vg_res
Change volume group residence.

-rt robot_type
Specifies the robot type of the robot where the volume is located.
Valid robot types for NetBackup DataCenter are: none, acs, lmf, odl, rsm, 
tl4, tl8, tld, tlh, tlm, ts8, tsd, tsh.
Valid robot types for NetBackup BusinesServer are: none, rsm, tl4, tl8, tld, 
ts8, tsd.

-rn robot_number
Unique, logical identification number for the robot where the volume is 
located.

-rh robot_host
Name of the host which controls the robot, where the volume is located.

-v volume_group
A volume group is a logical grouping that identifies a set of volumes 
that reside at the same physical location.

-res
Change the volume’s residence.

-m media_id
Specifies the media ID of the volume to change.

-mt media_type
Specifies the media type of the volume to change. 
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Valid media types for NetBackup DataCenter are: 4mm, 8mm, 8mm2, 
8mm3, dlt, dlt2, dlt3, dtf, hcart, hcart2, hcart3, odiskwm, odiskwo, qcart, 
4mm_clean, 8mm_clean, 8mm2_clean, 8mm3_clean, dlt_clean, 
dlt2_clean, dlt3_clean, dtf_clean, hcart_clean, hcart2_clean, hcart3_clean.
Valid media types for NetBackup BusinesServer are: 4mm, 8mm, dlt, 
hcart, qcart, 4mm_clean, 8mm_clean, dlt_clean, hcart_clean.

-rc1 rob_slot
Robot coordinate 1 is the slot number in the robot where the volume is 
located.
For NetBackup DataCenter, do not enter slot information for API robot 
types. The robot software tracks the slot locations for these robots.
For NetBackup BusinesServer, do not enter slot information for RSM 
robot types. The robot software tracks the slot locations for these robots.

Note The following option is only applicable for NetBackup DataCenter.

-rc2 rob_side
Robot coordinate 2 is the platter side for optical disks (A or B).

-exp mm/dd/yy hh:mm:ss
Expiration date for this volume.

-barcode barcode
Specifies the barcode attached to the volume.

-d "media_description"
Media description for the volume. The double quote marks are required 
if the description contains any spaces.

-p pool_number
Index of the volume pool which will contain this volume. You can get 
the pool index using vmpool -listall.

-maxmounts max_mounts
Maximum number of mounts allowed for this volume. Only used for 
non-cleaning media.

-n num_mounts/cleanings
For non-cleaning media, num_mounts is the number of times this volume 
has been mounted.
For cleaning media, cleanings is the number of cleanings left for this 
cleaning tape.

-new_mt media_type
Specifies the media type of the volume to change. See the -mt option for 
a list of media types.
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-new_rt robot_type
Specifies the robot type. See the -rt option for a list of robot types.

-new_v volume_group
A volume group is a logical grouping that identifies a set of volumes 
that reside at the same physical location.

-b barcode
Specifies the barcode attached to the volume.

-vltname vault_name
Specifies the name of the logical vault configured for the robot that 
ejected the volume.

-vltsent mm/dd/yy hh:mm:ss
Specifies the date the volume was sent offsite.

-vltreturn mm/dd/yy hh:mm:ss
Specifies the date the volume was requested for return from the vault 
vendor.  For catalog backup volumes, this is the date that the volume will 
be requested for return from the vault vendor.

-vltslot vault_slot
Specifies the vault vendor’s slot number for the slot that this volume 
occupies.

-vltsession vault_session_id
Specifies the id of the vault session that ejected this media.

-api_eject
Eject ACS, TLH, or TLM volumes from the specified robot.

-map map_id
Specifies the media access port. For ACS robot types this is the CAP ID 
(which has the format: ACS, LSM, CAP).

-w
Wait flag. This flag must be used with the eject, multiple eject, and 
multiple inject commands.

-verbose
Selects verbose mode.

-ml media_id1:media_id2: ... media_idn
Specifies a list of media to be ejected from the robot.

-robot_info
Used to retrieve information about a robotic library. This option is valid 
only for TLD and TL8 robot types

-multi_eject
Use the robotic library’s media access port to eject multiple volumes.
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-multi_inject
Use the robotic library’s media access port to inject multiple volumes.

EXAMPLES

The following command changes the expiration date of volume AJS100:

vmchange -exp 12/31/99 23:59:59 -m AJS100

The following command changes the pool (which contains volume AJS999) to pool 1 
(which is the NetBackup pool):

vmchange -h dill -p 1 -m AJS999

The following command ejects volumes abc123 and abc124 from ACS robot number 
700. The residences for these two volumes are changed to standalone.

vmchange -res -api_eject -w -ml abc123:abc124 -rt acs -rn 700 -rh 
verbena -map 0,0,0

CAUTIONS

Only limited validation of the option parameters is done.

Some robotic libraries implement different functionality for their media access ports. For 
example, some libraries have front-panel inject and eject features that conflict with 
NetBackup’s use of the media access port (for example, Spectra Logic Bullfrog). Other 
libraries require front-panel interaction when using the media access port (for example, 
Spectra Logic Gator).

Make sure you read the operator manual for your robotic library to gain an understanding 
of its media access port functionality. Libraries such as the ones noted may not be fully 
compatible with NetBackup’s inject and eject features if not properly handled. Other 
libraries may not be compatible at all.

SEE ALSO

vmadd, vmdelete, vmpool, vmquery
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NAME

vmcheckxxx - Report the media contents of a robotic library

SYNOPSIS

install_path\Volmgr\bin\vmcheckxxx -rt robot_type -rn robot_number [-rh 
robot_host] [-h volume_database_host] [[-if 
inventory_filter_value] [-if inventory_filter_value] ...] [-full] 
[-list]

DESCRIPTION

Report the media contents of a robotic library and optionally compare its contents with 
the volume configuration. 

If no options are specified, the media contents of the robot and the volume configuration 
are listed along with a list of any mismatches detected.

OPTIONS

-rt robot_type
Specifies the robot type of the robot to inventory.
Valid robot types for NetBackup DataCenter are: none, acs, lmf, odl, rsm, 
tl4, tl8, tld, tlh, tlm, ts8, tsd, tsh.
Valid robot types for NetBackup BusinesServer are: none, rsm, tl4, tl8, tld, 
ts8, tsd.

-rn robot_number
Unique, logical identification number of the robot to inventory.

-rh robot_host
Name of the host which controls the robot. If no host is specified, the host 
where you execute this command is assumed.

Note The following two options are only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which contains 
information about the volumes in a robot. If no host is specified, the host 
where you execute this command is assumed.

-if inventory_filter_value
Specifies inventory filter values. Multiple -if options may be specified. 
The inventory filter value is an ACS scratch pool ID, a TLH volume 
category, or an LMF barcode prefix.
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The -if and -full options cannot be specified together.

-full
Specifies full inventory. The -full and -if options cannot be specified 
together.

-list
Lists the robot contents.

EXAMPLES

The following command lists the media contents of TLD robot 1 and the volume 
configuration for that robot on the host named niagra, along with a list of any mismatches 
that are detected:

vmcheckxxx -rt tld -rn 1 -rh niagra -h niagra

The following command lists the contents of TLH robot 2 that is connected to the host 
where the vmcheckxxx command was executed:

vmcheckxxx -rt tlh -rn 2 -list

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmupdate
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NAME

vmdelete - Delete volumes from the volume database

SYNOPSIS

install_path\Volmgr\bin\vmdelete [-h volume_database_host] [-m 
media_id | -v volume_group]

DESCRIPTION

Delete volumes from the volume database.

OPTIONS

Note The following option is applicable only for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which contains 
information about the volumes in a robot. If no host is specified, the host 
where you execute the command is assumed.

-m media_id
Specifies the media id of the volume to delete from the volume database.

-v volume_group
Specifies the volume group to delete. All volumes in this group are 
deleted from the volume database.

EXAMPLES

The following command deletes a single volume:

vmdelete -m AJS144

The following command deletes all volumes with the volume group name of 
DELETE_ME:

vmdelete -v DELETE_ME

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmadd, vmchange, vmquery
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NAME

vmoprcmd - perform operator functions on drives

SYNOPSIS

install_path\Volmgr\bin\vmoprcmd [-h device_host] -down | -up | 
-upopr | -reset drive_index | -downbyname | -upbyname | 
-upoprbyname | -resetbyname drive_name | 
-crawlreleasebyname drive_name | -comment drive_index 
["comment"] | -commentbyname drive_name ["comment"] | 
-assign drive_index mount_request_id | -assignbyname 
drive_name mount_request_id | -deny | -resubmit 
mount_request_id | -d [pr | ds | ad] | -help

DESCRIPTION

Perform operator functions on drives. The -h option is not required, but you must choose 
one and only one of the other options listed below.

OPTIONS

-h device_host
Name of the device host where the drives are attached and configured. 
If no host option is specified, the device host where you execute the 
command is assumed.
For NetBackup BusinesServer, the device host is the host where Media 
Manager is installed.

-down | -up | -upopr | -reset drive_index
-down Sets the drive to the DOWN state, if it is not assigned.
-up Sets the drive to UP in Automatic Volume Recognition (AVR) 
mode. This is the normal mode for all drives.
-upopr Sets the drive to UP in Operator (OPR) mode. This mode is 
normally used only for security reasons. For a drive in a robot, OPR and 
AVR are treated identically while the robot process is up.
-reset Resets the specified drive, terminating the drive assignment 
and taking control away from the assigned user.

Caution Do not reset an assigned drive unless directed by site policy or the system 
administrator. Terminating an active job can destroy user data.
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-downbyname | -upbyname | -upoprbyname | -resetbyname drive_name
These options are similar to -down, -up, -upopr, and -reset 
respectively, except the drive is specified by the drive name instead of 
drive index.

-comment drive_index ["comment"]
Add a comment for the drive. The quotes are required if your comment 
contains any spaces. If you do not specify comment, any existing 
comments for the drive are deleted.

-commentbyname drive_name ["comment"]
This option is similar to the -comment option, except the drive is 
specified by the drive name instead of drive index.

-assign drive_index mount_request_id
Assign a drive to a mount request.

-assignbyname drive_name mount_request_id
This option is similar to the -assign option, except the drive is 
specified by the drive name instead of drive index.

-deny | -resubmit mount_request_id
-deny Denying a mount request returns an error message to the user.
-resubmit Resubmit a mount request. If a pending action message 
involves a robot, you must correct the problem and resubmit the request 
that caused the message.

-d [pr | ds | ad]
If none of the following optional display parameters are specified, all 
information is displayed.
pr Display pending requests.
ds Display the status of drives under control of Media Manager.
ad Display additional status of drives under control of Media Manager.

-help
Display the usage statement for this command.

-crawlreleasebyname drive_name
This option forces all hosts (that are registered to use the drive) to issue a 
SCSI release command to the drive. Issue this option on the host that is 
the SSO device allocator (DA host) or use the -h option to specify the DA 
host.

Caution Use this option after a PEND status has been seen in Device Monitor. Do not use 
this option during backups.
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EXAMPLES

The following command sets the drive, with a drive index of 0, to UP mode:

vmoprcmd -up 0

The following command displays the drive status of all drives:

vmoprcmd -d ds

The following command displays pending requests and the drive status of all drives on 
the device host named crab:

vmoprcmd -h crab

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

tpconfig(1M)
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NAME

vmpool - Manage volume pools

SYNOPSIS

install_path\Volmgr\bin\vmpool [-h volume_database_host] -listall 
[-b] | -listscratch | -add pool_name "description" host uid 
gid | -change pool_name "description" host uid gid | -delete 
pool_name | -set_scratch pool_name | -unset_scratch 
pool_name

DESCRIPTION

Use this command to add, change, delete, or list volume pools. 

The -h option is not required, but you must choose one and only one of the other seven 
options (for example, -listscratch).

OPTIONS

Note The following option is only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which keeps 
information about the media in a robot. If no host is specified, the host 
where you execute the command is assumed.

-listall [-b]
List information about all volume pools. You can use the -b option to 
specify a brief format for volume pool information.

-listscratch
List all configured scratch pools.

-add pool_name "description" host uid gid
Add a new volume pool.

-change pool_name "description" host uid gid
Change an existing volume pool.

-delete pool_name
Delete a volume pool.

“description”
Description of the volume pool. The double quote marks are required if 
the description contains any spaces.
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host
Name of the host that will be permitted to request and use volumes in 
this volume pool.
For NetBackup DataCenter to permit only a specific host to access the 
volume pool, enter the name of that host. To permit any host to access 
the volume pool, enter ANYHOST. Using the value ANYHOST is 
recommended.
For NetBackup BusinesServer, you can only specify the value 
ANYHOST.

uid

Enter the default value, -1 (ANY), to permit any user id to access the 
pool.

gid

Enter the default value, -2 (NONE), to permit only the user id specified 
by uid to request or access the volume pool.

-set_scratch pool_name
If pool_name is a previously defined volume pool, pool_name will 
become the scratch pool and its description will not be changed. The 
NetBackup, DataStore, and None volume pools cannot be changed to 
scratch pools.
If pool_name is a new volume pool, a new pool will be created with 
"Scratch Pool" as the description. 
Only one scratch pool at a time can be defined.

-unset_scratch pool_name
Undefines pool_name as the scratch pool and defines it as a regular 
volume pool. The pool can be deleted using vmpool -delete 
pool_name.

EXAMPLES

The following command adds a new pool named MyPool on the host named llama with 
the default host, user id, and group id permissions:

vmpool -h llama -add MyPool "my description with spaces" ANYHOST -1 
-2

The following command lists all pools configured on the host where the command is 
executed:

vmpool -listall -b

NOTES

Only limited validation of the option parameters is done.
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uid and gid should only be used for restricting access to volumes by user or by group on 
UNIX hosts.
Appendix A, Media Manager Commands and Processes 203



vmquery
vmquery

NAME

vmquery - Query the volume database, or assign and unassign volumes

SYNOPSIS

install_path\Volmgr\bin\vmquery [-h volume_database_host, ... -h 
volume_database_host] [-b | -w] -a | -m media_id | -v 
volume_group | -rn robot_number | -rt robot_type | -mt 
media_type | -p pool_number | -pn pool_name | -res 
robot_type robot_number robot_host rob_slot rob_side | 
-assignbyid media_id media_type pool_number stat asg_time | 
-deassignbyid media_id pool_number stat

DESCRIPTION

Query the volume database for volume information. The -h, -b, and -w options are not 
required, but you must choose only one of the other (eleven) options. 

The -b or -w option can be used in conjunction with any of the other eleven options, but 
the -b or -w options cannot be specified together.

OPTIONS

Note The following option is applicable only for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database maintaining information 
about the volumes in a robot. If no host is specified, the host where you 
execute the command is assumed. Up to 100 volume database hosts can 
be queried.

-b
Specifies the brief output format for volume information. This option 
can be used in conjunction with any of the other eleven options.

-w
Specifies the wide output format for volume information. This option 
includes additional information not shown by the -b option and can be 
used in conjunction with any of the other eleven options.

-a
Show all volumes.
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-m media_id
Query volumes by media id. The media id is a maximum of 6 ASCII 
characters.

-v volume_group
Query volumes by volume group. A volume group is a logical grouping 
that identifies a set of volumes that reside at the same physical location.

-rn robot_number
Query volumes by robot number. A robot number is a unique, logical 
identification number for the robot where the volume is located.

-rt robot_type
Query volumes by the type of the robot where the volume is located. 
Valid robot types for NetBackup DataCenter are: none, acs, lmf, odl, rsm, 
tl4, tl8, tld, tlh, tlm, ts8, tsd, tsh.
Valid robot types for NetBackup BusinesServer are: none, rsm, tl4, tl8, tld, 
ts8, tsd.

-mt media_type
Query volumes by media type. 
Valid media types for NetBackup DataCenter are: 4mm, 8mm, 8mm2, 
8mm3, dlt, dlt2, dlt3, dtf, hcart, hcart2, hcart3, odiskwm, odiskwo, qcart, 
4mm_clean, 8mm_clean, 8mm2_clean, 8mm3_clean, dlt_clean, 
dlt2_clean, dlt3_clean, dtf_clean, hcart_clean, hcart2_clean, hcart3_clean.
Valid media types for NetBackup BusinesServer are: 4mm, 8mm, dlt, 
hcart, qcart, 4mm_clean, 8mm_clean, dlt_clean, hcart_clean.

-p pool_number
Query volumes by pool number. Pool number is an index into the 
volume pool. You can use vmpool -listall to determine the index for 
a given pool name.

-pn pool_name
Query volumes by pool name.

-res robot_type robot_number robot_host rob_slot rob_side
Query volumes by residence.

robot_host
Name of the host which controls the robot, where the volume is located.

rob_slot
This is the slot number in the robot (robot coordinate 1) where the 
volume resides.

rob_side
This is the platter side (robot coordinate 2) for optical disks (A or B). If the 
volume is not an optical disk, specify zero for rob_side.
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-assignbyid media_id media_type pool_number stat asg_time
Assign volume by media id, pool, and status.

stat
Status applies only to volumes that are assigned to NetBackup or 
Storage Migrator.
A status of 0 means the volume is assigned to NetBackup regular 
backups.
A status of 1 means the volume is assigned to NetBackup catalog 
backups.
A status of 2 means the volume is assigned to Storage Migrator (valid 
with NetBackup DataCenter only).
A status of 3 means the volume is assigned to Storage Migrator for 
Microsoft Exchange or Storage Migrator for Windows 2000.

asg_time
Applies only to volumes assigned to NetBackup or Storage Migrator 
(NetBackup DataCenter only).
asg_time is the time when the volume was assigned and is the number of 
seconds since 00:00:00 UTC, January 1, 1970. asg_time was originally 
created using the time() call.

-deassignbyid media_id pool_number stat
Unassign volume by media id, pool, and status.

Caution Unassigning volumes may cause inconsistencies between the application media 
database and the volume database, leading to possible data loss. You must use a 
NetBackup application interface (for example, NetBackup Console) to expire 
the media after unassigning volumes.

EXAMPLES

The following command lists all volume information, in brief format from the volume 
database on the host named llama:

vmquery -h llama -b -a

The following command assigns volume A23456, which is in pool 1 (NetBackup), and sets 
the status to 0 and the assign time to 12/31/98 15:50:22:

vmquery -assignbyid A23456 8mm 1 0 915141022

The following command unassigns volume A23456, which is in pool 1 (NetBackup), with 
a status of 0:

vmquery -deassignbyid A23456 1 0
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NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmadd, vmchange, vmdelete, vmpool
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NAME

vmrule - Manage barcode rules

SYNOPSIS

install_path\Volmgr\bin\vmrule [-h volume_database_host] -listall 
[-b] | -add barcode_tag media_type pool_name max_mounts 
“description” | -change barcode_tag media_type pool_name 
max_mounts “description“ | -delete barcode_tag

DESCRIPTION

Use this command to add, change, delete, or list barcode rules. The -h option is not 
required, but you must chose one and only one of the other four options.

OPTIONS

Note The following option is only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which contains 
information about the volumes in a robot. If no host is specified, the host 
where you execute the command is assumed.

-listall [-b]
List information about all barcode rules. You can use the -b option to 
specify a brief format for the barcode rule information that is displayed.

-add barcode_tag media_type pool_name max_mounts “description”
Add a new barcode rule.

-change barcode_tag media_type pool_name max_mounts “description”
Change a barcode rule.

-delete barcode_tag
Delete a barcode rule.

barcode_tag
Specifies the barcode prefix which will invoke the barcode rule.

media_type
Specifies the media type of the volume, a barcode rule attribute. This 
affects whether the rule will be used and also affects the media type for 
volumes added using a robot inventory update.
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Valid media types for NetBackup DataCenter are: 4mm, 8mm, 8mm2, 
8mm3, dlt, dlt2, dlt3, dtf, hcart, hcart2, hcart3, odiskwm, odiskwo, qcart, 
4mm_clean, 8mm_clean, 8mm2_clean, 8mm3_clean, dlt_clean, 
dlt2_clean, dlt3_clean, dtf_clean, hcart_clean, hcart2_clean, hcart3_clean.
Valid media types for NetBackup BusinesServer are: 4mm, 8mm, dlt, 
hcart, qcart, 4mm_clean, 8mm_clean, dlt_clean, hcart_clean.

pool_name
Specifies the pool to which the volumes will be added.

max_mounts
Maximum number of mounts allowed for this volume (when the volume 
is added). This option is used only for non-cleaning media.  When this 
limit is exceeded, the volume can only be mounted for read operations.

“description”
Description of the barcode rule. The double quote marks are required if 
the description contains any spaces.

EXAMPLES

The following command creates a rule that defines any tape with a barcode starting with 
ABC is a DLT tape in the NetBackup pool. The tape can be mounted up to 100 times for 
writes and is given a description.

vmrule -add ABC dlt NetBackup 100 "DLT cleaning tape"

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmupdate
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NAME

vmupdate - Inventory the media contents of a robotic library and update the volume 
database

SYNOPSIS

install_path\Volmgr\bin\vmupdate -rt robot_type -rn robot_number [-rh 
robot_host] [-h volume_database_host] [[-if 
inventory_filter_value] [-if inventory_filter_value] ...] [-full] 
[-recommend] [-interactive] [-involgrp volume_group] 
[-outvolgrp volume_group] [-mt media_type] [-p pool_name] 
[-use_barcode_rules] [-use_seed] [-mp media_id_prefix] 
[-no_sides] [-no_format_optical] [-overwrite_labels] 
[-empty_map]

DESCRIPTION

Inventory the media contents of a robotic library and update the volume database. If no 
options are specified, the volume configuration is updated to match the robot contents.

OPTIONS

-rt robot_type
Specifies the robot type of the robot to inventory.
Valid robot types for NetBackup DataCenter are: none, acs, lmf, odl, rsm, 
tl4, tl8, tld, tlh, tlm, ts8, tsd, tsh.
Valid robot types for NetBackup BusinesServer are: none, rsm, tl4, tl8, tld, 
ts8, tsd.

-rn robot_number
Unique, logical identification number for the robot to inventory.

-rh robot_host
Name of the host which controls the robot. If no host is specified, the host 
where you execute this command is assumed.

Note The following two options are only applicable for NetBackup DataCenter.

-h volume_database_host
Name of the host that has the volume database which contains 
information about the volumes in a robot. If no host is specified, the host 
where you execute this command is assumed.
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-if inventory_filter_value
Specifies inventory filter values. Multiple -if options may be specified. 
The inventory filter value is an ACS scratch pool ID, a TLH volume 
category, or an LMF barcode prefix.
The -if and -full options cannot be specified together.

-full
Specifies full inventory. The -full and -if options cannot be specified 
together.

-recommend
Lists changes required to update the volume configuration.

-interactive
Prompts you before updating the volume configuration.

-involgrp volume_group
Specifies the volume group for media moved into the robot.

-outvolgrp volume_group
Specifies the volume group for media moved out of the robot.

-mt media_type
Specifies the media type of the volume.
Valid media types for NetBackup DataCenter are: 4mm, 8mm, 8mm2, 
8mm3, dlt, dlt2, dlt3, dtf, hcart, hcart2, hcart3, odiskwm, odiskwo, qcart, 
4mm_clean, 8mm_clean, 8mm2_clean, 8mm3_clean, dlt_clean, 
dlt2_clean, dlt3_clean, dtf_clean, hcart_clean, hcart2_clean, hcart3_clean.
Valid media types for NetBackup BusinesServer are: 4mm, 8mm, dlt, 
hcart, qcart, 4mm_clean, 8mm_clean, dlt_clean, hcart_clean.

-p pool_name
Specifies the name of the volume pool to which new media will be 
assigned.

-use_barcode_rules
Specifies that barcode rules will be used for assigning attributes to new 
media.

-use_seed
Specifies automatic generation of media IDs for media with no barcodes.

-mp media_id_prefix
Specifies the prefix that is used as a seed to generate new media IDs for 
media with no barcodes.

-no_sides
Specifies that any new optical media IDs will not always contain platter 
side A or B.
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-no_format_optical
Specifies to NOT format new optical media.

-overwrite_labels
Specifies that existing labels will be overwritten when formatting optical 
media.

-empty_map
Specifies that volumes in the media access port (map) will be moved into 
the robot before the robot inventory is started. This option is only valid 
for TL8, TLD, or TLM robot types.

EXAMPLES

The following command updates the volume configuration on the host named mymaster 
to match the contents of TLD robot 7 connected to the host macris:

vmupdate -rt tld -rn 7 -rh macris -h mymaster

NOTES

Only limited validation of the option parameters is done.

SEE ALSO

vmcheckxxx
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 B

This chapter includes the following Media Manager reference and conceptual topics:

� Robot Overview

� Correlating Device Files to Physical Drives When Adding Drives

� Drive Cleaning

� Volume Pools and Volume Groups

� Barcodes

� vmd Security

� How Media Manager Selects a Drive for a Robotic Mount Request

� Administrators Quick Reference

� Media Manager Configuration File (vm.conf)

Robot Overview
In Media Manager, a robot is a peripheral device that contains a mechanism for the 
automated mounting and dismounting of media in tape drives. A robot may also be called 
a robotic library, media changer, automated library, jukebox, or tape stacker. Media 
Manager considers any of these types of devices to be robots. Media Manager software 
that controls robots is referred to as robotic control software.

Media Manager Robot Types
Media Manager classifies robots by robot type, according to one of the following:

� The physical characteristics of the robot.

Library usually refers to a larger robot, in terms of slot capacity or number of drives.

Stacker usually refers to a robot with one drive and low media capacity.

� The media type commonly used by that class of robots.
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4 MM and 8 MM are examples of media types.

The following table lists the Media Manager robot types, with drive and slot limits for 
each type. Visit the VERITAS support web site (http://www.support.veritas.com) 
to determine which robot type applies to the model of robot that you are using.

Media Manager Media Types
Media Manager uses media types to differentiate tape media with differing physical 
characteristics. Each Media Manager media type may represent a specific physical media 
type, for example Sony AIT media can have a Media Manager media type of 8MM, 
8MM2, or 8MM3.

The following table lists the Media Manager media types:

Media Manager Robot Types

Robot Type Description Drive Limits Slot Limits

RSM Removable Storage Manager 2 30

TL4 Tape Library 4MM 1 15

TL8 Tape Library 8MM 2 30

TLD Tape Library DLT 2 30

TS8 Tape Stacker 8MM 2 21

TSD Tape Stacker DLT 1 14

Media Manager Media Types

Media Type Description

QCART 1/4 inch cartridge tape

HCART 1/2 inch cartridge tape

4MM 4MM cartridge tape

8MM 8MM cartridge tape

DLT DLT cartridge tape
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Robot Attributes
Media Manager configures and controls a robot device differently depending on the robot 
type. The following tables list the attributes that dictate how these robot types differ.

Note See the NetBackup release notes or visit the VERITAS support web site for more 
detailed information on supported peripherals, platforms, and firmware levels 
tested.

HC_CLN 1/2 inch cleaning tape

4MM_CLN 4MM cleaning tape

8MM_CLN 8MM cleaning tape

DLT_CLN DLT cleaning tape

Media Manager Media Types (continued)

Media Type Description

RSM Robot Attributes

Attribute Comment

SCSI Control No

LAN Control No

Remote Robot Control No

NDMP Support No

Shared Drives Support No

Media Type Support 4MM

8MM

DLT

HCART

QIC
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Barcode Support Yes, if the robot supports barcodes. Barcodes are assumed to 
be the same as the media ID.

Drive Cleaning Support No, drive cleaning is supported using the RSM utilities in 
Windows 2000.

Media Access Port Support Eject is supported. Inject is not supported, but the Windows 
2000 RSM Inject wizard can be used.

Media Manager Tracks Slots No

For More Information See the RSM appendix, “Microsoft Removable Storage 
Manager (RSM)” on page 269.

Robot Examples Exabyte 210

Quantum DLTStor

Host Supported Windows 2000

TL4 Robot Attributes

Attribute Comment

SCSI Control Yes

NDMP Support No

Media Type Support 4MM

Barcode Support No, but the robot has inventory capability and can report 
whether a slot has media.

Drive Cleaning Support Yes

Media Access Port  Support No

Media Manager Tracks Slots Yes

For More Information See the NetBackup Media Manager device configuration guide 
for UNIX.

RSM Robot Attributes (continued)

Attribute Comment
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Robot Examples ADIC 4mm DAT Autochanger

HP DAT Autoloader

Host Supported Windows 

UNIX

TL8 Robot Attributes

Attribute Comment

SCSI Control Yes

NDMP Support Yes

Media Type Support 8MM

Barcode Support Yes

Drive Cleaning Support Yes

Media Access Port  Support Yes

Media Manager Tracks Slots Yes

For More Information See the NetBackup Media Manager device configuration guide 
for UNIX.

Robot Examples IBM 7331

Exabyte X200

Host Supported Windows 

UNIX

TL4 Robot Attributes (continued)

Attribute Comment
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TLD Robot Attributes

Attribute Comment

SCSI Control Yes

NDMP Support Yes

Media Type Support DLT

8MM

HCART

Barcode Support Yes

Drive Cleaning Support Yes

Media Access Port  Support Yes

Media Manager Tracks Slots Yes

For More Information See the NetBackup Media Manager device configuration guide 
for UNIX.

Robot Examples ADIC Scalar

HP SureStore DLT Library

STK 7430

Host Supported Windows 

UNIX

TS8 Robot Attributes

Attribute Comment

SCSI Control Yes

NDMP Support No

Media Type Support 8MM
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Barcode Support Yes

Drive Cleaning Support Yes

Media Access Port  Support No

Media Manager Tracks Slots Yes

For More Information See the NetBackup Media Manager device configuration guide 
for UNIX.

Robot Examples Exabyte 10x

Exabyte 210

Host Supported Windows

UNIX

TSD Robot Attributes

Attribute Comment

SCSI Control Yes

NDMP Support Yes

Media Type Support DLT

Barcode Support No, but the robot has inventory capability and can report 
whether a slot has media.

Drive Cleaning Support Yes

Media Access Port  Support No

Media Manager Tracks Slots Yes

For More Information See the NetBackup Media Manager device configuration guide 
for UNIX.

TS8 Robot Attributes (continued)

Attribute Comment
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Table-Driven Robotics
Table-driven robotics provides support for some new library devices without the need to 
modify any robotic library control binaries. This feature uses external device mapping 
files for supported robots and drives.

This means that support for your new or upgraded devices may be accomplished without 
waiting for a patch from VERITAS. Since the external device mapping files include 
pertinent information relating to the operation and control of libraries, support for some 
new devices may only require that you download an updated external mapping file when 
any device changes are made to your configuration.

See “External Device Mapping Files” on page 26 for information on how to download the 
latest mapping files for your devices.

Robotic Test Utilities
You can use the robotic test utilities for configured robots by executing 
install_path\volmgr\bin\robtest.exe and selecting the desired robotic library.

From each test utility, you can obtain a list of available test commands by entering a 
question mark.

Robotic Processes
A Media Manager robotic and possibly a robotic control process exist for any robotic 
library that you may install on a Windows media server.

Every Media server that has a drive in a robotic library has a robotic process for that 
robotic library. The robotic process receives requests from the NetBackup Device Manager 
and sends necessary information directly to the robotics or to a robotic control process.

Robot Examples Sun StorEdge L280

Quantum DLTStor

Host Supported Windows 

UNIX

TSD Robot Attributes (continued)

Attribute Comment
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Robotic control processes exist only for robot types that support library sharing (or robot 
sharing). Library sharing allows different drives in a robot to be connected to different 
hosts. Library sharing is not supported in NetBackup BusinesServer.

Starting the NetBackup Device Manager service on a media server starts the robotic and 
robotic control processes for all robots configured on that host. Stopping this service stops 
these processes.

The Services tab of the NetBackup Activity Monitor has commands for starting and 
stopping all services, including the NetBackup Device Manager service. You can also start 
and stop this service through commands on the Device Monitor Actions menu or the 
Media and Device Management Actions menu. In addition, “Media Manager Commands 
and Processes” on page 161 describes commands for controlling robotic processes that run 
on Windows media servers.

When a robotic or robotic control process is running, the NetBackup Activity monitor 
processes tab shows it in the UP or DOWN state. When a connection is made to the 
appropriate robotic library, the corresponding process is in the UP state and can mount or 
unmount tapes. If the connection cannot be made or errors exist, the process changes to 
the DOWN state. In the DOWN state the process is still running and returns to the UP 
state when the connection is made or problems no longer exist.

The following table lists the robotic and robotic control processes for each robot type that 
are supported on Windows media servers. 

Robotic and Robotic Control Processes

Robot Process Description

Tape Library 
DLT (TLD)

tldd

tldcd

tldd, runs on a NetBackup server that has a drive in the Tape Library 
DLT. This process receives NetBackup Device Manager requests to 
mount and unmount volumes, and sends these requests to the 
robotic-control process, tldcd.

tldcd communicates with the Tape Library DLT robotics through a 
SCSI interface.

Tape Library 
4MM (TL4)

tl4d tl4d runs on the host that has a Tape Library 4MM. This process 
receives NetBackup Device Manager requests to mount and unmount 
volumes and communicates these requests to the robotics through a 
SCSI interface.

Tape Library 
8MM (TL8)

tl8d

tl8cd

tl8d, runs on a NetBackup server that has a drive in the Tape Library 
8MM. This process receives NetBackup Device Manager requests to 
mount and unmount volumes, and sends these requests to the 
robotic-control process, tl8cd.

tl8cd communicates with the TL8 robotics through a SCSI interface.
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Correlating Device Files to Physical Drives When Adding 
Drives

The following two topics may not be necessary, if you used the Device Configuration 
Wizard to configure your drives, and the drives and robotic libraries both support device 
serialization.

� Correlating On Windows Hosts.

� Correlating On UNIX Hosts.

Correlating On Windows Hosts
When selecting the drive address (for example, robot drive number) for a tape drive, 
match the logical device name with the drives in the physical drive layout as follows:

1. Note the SCSI target of the drive and check the Windows Tape Devices display to 
determine which device name (for example, Tape0) was assigned to the drive.

2. Correlate the SCSI target to the drive address using the robot’s interface panel or 
checking the indicators on the rear panel of the tape drive.

3. Determine the physical drive address (for example, number) by checking labels on the 
robot itself or by using the diagrams in the Robot Drive and Slot Layout appendix. 
This appendix shows the layout for many of the robots that Media Manager supports.

Tape Stacker 
8MM (TS8)

ts8d ts8d runs on the NetBackup server that has a Tape Stacker 8MM 
attached. This process receives NetBackup Device Manager requests to 
mount and unmount volumes and communicates these requests to the 
robotics through a SCSI interface.

Tape Stacker 
DLT (TSD)

tsdd tsdd runs on the NetBackup server that has a Tape Stacker DLT 
attached. This process receives NetBackup Device Manager requests to 
mount and unmount volumes and communicates these requests to the 
robotics through a SCSI interface.

Removable 
Storage 
Manager 
(RSM)

rsmd rsmd runs on a Windows 2000 NetBackup server. rsmd interfaces with 
NetBackup Device Manager to mount and unmount tapes that are 
under Microsoft RSM control.

Robotic and Robotic Control Processes (continued)

Robot Process Description
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4. Configure the robot and then add the drives.

When you add the drives, check your notes to ensure that you are assigning the 
correct drive address to each device path.

5. Optionally, use the appropriate robotic test utility to verify the configuration.

a. Stop the NetBackup Device Manager service (ltid).

b. Start ltid to start the Automatic Volume Recognition process (avrd). 

You must stop and restart ltid to ensure that the current device configuration 
has been activated.

c. Use the robotic test utility to mount a tape on a drive.

d. Use the Device Monitor to verify the tape was mounted on the correct robot drive.

For example, assume you have the following drives in a TLD robot and have the 
device names configured as follows:

Drive 1: Tape0

Drive 2: Tape1

Also assume that in step c you requested that the tape be mounted on Drive 1. If the 
device name for the drive is correctly configured, the Device Monitor shows the tape 
mounted on Drive 1. Unload and unmount the tape from Drive 1 using the robotic 
test utility. Repeat the test for each drive.

During your testing, if the Device Monitor shows the tape mounted on a drive other 
than the drive you specified in the test utility, the device name for that drive is not 
correctly configured. For instance, if you mounted a tape on Drive 2 and the Device 
Monitor shows the tape mounted on Drive 1, the device name for Drive 2 is incorrect. 
Replace the Drive 2 device name (Tape1) with the correct device name (Tape0) for 
Drive 1. You may need to use a temporary device name while making these changes. 

Correlating On UNIX Hosts
Establish device file to physical drive correlation during installation when you create the 
device files for each drive. The following is a general procedure:
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1. Determine the physical location of each drive within the robotic library. This is 
usually shown on the connectors to the drives or in the vendor’s documentation. The 
Robot Drive and Slot Layout appendix shows drive locations in many of the robots 
that Media Manager supports.

2. Physically connect the drives to SCSI adapters in your host.

3. Record the adapter and SCSI addresses to which you connected each drive.

4. Create device files for each drive based on the SCSI addresses of the drives and 
adapters. Add the device file using your notes from step 3 to complete the correlation 
between device files and physical drive location.

5. Configure the robot and then add the drives.

When you add the drives, check your notes to ensure that you are assigning the 
correct drive address (for example, robot drive number) to each device path.

6. Optionally, you can use the appropriate robotic test utility to verify the configuration.

a. Stop the device daemon (ltid).

b. Start ltid to start the Automatic Volume Recognition daemon (avrd). 

You must stop and restart ltid to ensure that the current device configuration 
has been activated.

c. Use the robotic test utility to mount a tape on a drive.

d. Use the Device Monitor to verify the tape was mounted on the correct robot drive.

For example, assume you have the following drives in a TLD robot and have the 
device paths configured as follows:

Drive 1: /dev/rmt/0cbn

Drive 2: /dev/rmt/1cbn

Also assume that in step c you requested that the tape be mounted on Drive 1. If the 
device path for the drive is correctly configured, the Device Monitor shows the tape 
mounted on Drive 1. Unload and unmount the tape from Drive 1 using the robotic 
test utility. Repeat the test for each drive.

During your testing, if the Device Monitor shows the tape mounted on a drive other 
than the drive you specified in the test utility, the device path for that drive is not 
correctly configured. For instance, if you mounted a tape on Drive 2 and the Device 
Monitor shows the tape mounted on Drive 1, the device path for Drive 2 is incorrect. 
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Replace the Drive 2 device path (/dev/rmt/1cbn) with the correct device path 
(/dev/rmt/0cbn) for Drive 1. You may need to use a temporary device path while 
making these changes. 

Drive Cleaning
For drives in libraries that are under RSM robotic control, the Windows 2000 RSM 
software controls drive cleaning. Use the Windows 2000 administrative interfaces to 
manage drive cleaning.

Note Library-based cleaning is not supported by Media Manager for most robots, since 
robotic library and operating systems vendors have implemented this type of 
cleaning in many different ways.

This topic on drive cleaning covers the following areas:

� Frequency-Based Cleaning

� On-Demand Cleaning

� TapeAlert

� Using a Cleaning Tape

Frequency-Based Cleaning
When you add a drive, you can specify the number of hours (cleaning frequency) a drive 
will be used between drive cleanings. Media Manager updates the mount time for the 
drive each time a tape is unmounted. You can also change the cleaning frequency value.

If the following conditions are met, drive cleaning occurs when the accumulated mount 
time exceeds the time you specified for cleaning frequency:

� The drive is in a robotic library that supports cleaning (see “Robot Attributes” on 
page 215).

� A cleaning tape is configured and available in Media Manager for the robotic library.

� The cleaning tape has cleanings remaining.

Media Manager cleans the drive immediately after the unmount. Drive cleaning never 
causes an unmount in the middle of an active backup. The mount time is reset after the 
drive is cleaned. The cleaning frequency value remains the same.

A cleaning can occur within a backup if you are spanning tapes. For example, if cleaning 
is due after the first tape is full, Media Manager cleans the drive before proceeding to the 
next tape.
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Leaving media in a drive for extended periods does not affect cleaning frequency because 
Media Manager increments the mount time only when the media is actually assigned to a 
process.

To set, change or reset the cleaning frequency, use the tpclean command (see the 
appendix, “Media Manager Commands and Processes” on page 161).

On-Demand Cleaning
If the drive is standalone or if a cleaning tape is not defined, the message NEEDS 
CLEANING appears in the Comment field of the output from the tpclean -L 
command. You can then use the tpclean command to clean the drive and reset the 
accumulated mount time to zero after cleaning the drive.

You can manually clean a drive regardless of the cleaning frequency and accumulated 
mount time. You can clean standalone and robotic drives if a cleaning tape of the correct 
media type and residence for the drive has been added to the appropriate volume 
database.

TapeAlert
Reactive cleaning using TapeAlert is a function of the tape drive. If a drive supports the 
TapeAlert feature and TapeAlert is enabled on the drive, Media Manager polls the drive 
for status from TapeAlert. 

TapeAlert allows reactive cleaning for most drive types. Not all platforms, robots, and 
drives, at all firmware levels, support this type of reactive cleaning. In the cases where 
TapeAlert is not supported on a particular drive, frequency-based cleaning may be 
utilized (see “Frequency-Based Cleaning” on page 225 and “TapeAlert and 
Frequency-based Cleaning” on page 227).

Since TapeAlert provides the same type of cleaning as library-based cleaning (also known 
as robotic cleaning or auto cleaning), it is recommended that you disable library-based 
cleaning when using TapeAlert (for most vendor’s robots). 

Requirements for TapeAlert and Media Manager

To use TapeAlert with Media Manager, you need the following conditions to be met. No 
additional configuration is needed.

� The drive must support the TapeAlert feature and the feature must be enabled on the 
drive.

To determine if drives support TapeAlert, see the VERITAS support site for 
information on drive support for TapeAlert.
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� A cleaning tape is configured and available in Media Manager for the robotic library.

� The cleaning tape has cleanings remaining.

TapeAlert and Media Manager

A drive with TapeAlert knows how many read and write errors it has encountered within 
a certain time period. Although these errors are recoverable, once a threshold is reached a 
CLEAN_NOW or CLEAN_PERIODIC flag is set by TapeAlert.

If Media Manager finds either of these flags set, it performs a cleaning at one of the 
following times:

� At the end of a backup or restore to the drive.

� Prior to the next backup or restore to the drive.

TapeAlert and Frequency-based Cleaning

Using TapeAlert with frequency-based cleaning ensures that a given drive will get cleaned 
at least every x hours, depending on the cleaning frequency value. In addition the drive 
may be cleaned sooner, if the CLEAN_NOW or CLEAN_PERIODIC flags are set by the 
drive.

Using TapeAlert without frequency-based cleaning, ensures that the tape will be cleaned 
only when the drive sets its CLEAN_NOW or CLEAN_PERIODIC flags.

Using a Cleaning Tape
You can specify the number of cleanings that are allowed for a cleaning tape. This number 
is decremented with each cleaning and when it is zero, Media Manager stops using the 
cleaning tape. At this point, you can use a new cleaning tape or increase the number of 
cleanings allowed. You can also change this number of cleanings at any time in Media 
Manager.

Volume Pools and Volume Groups
This topic on volume pools and groups covers the following areas:

� Volume Pools

� Volume Groups

� Volume Pools and Groups Example

� Scratch Volume Pools
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� Moving Volumes

Volume Pools
A volume pool is used to identify a logical set of volumes by usage. Associating volumes 
with a volume pool protects them from access by unauthorized applications. You can 
create volume pools for applications or other reasons; and as you add volumes, associate 
them with the appropriate pool. You can also move unassigned volumes to a different 
pool later.

With the exception of the NetBackup and DataStore volume pools, you must create a 
volume pool before you can add volumes to it. By default, Media Manager creates volume 
pools, named NetBackup and DataStore.

During initial configuration, it is easiest to create all of your volume pools first if you want 
to use volume pools other than the NetBackup volume pool. Then as you add volumes, 
you can assign them to these volume pools.

You can also configure a scratch volume pool (see “Scratch Volume Pools” on page 230).

Volume Groups
A volume group is a logical grouping that identifies a set of volumes that reside at the 
same physical location. Volume groups are an administration convenience for logically 
moving multiple volumes (where a logical move means to change the volume attributes to 
show the new location). Using a volume group lets you move a set of volumes between a 
robotic library and a standalone location, or delete them from the configuration by 
specifying the group name, rather than each individual media ID. Volume groups are also 
convenient for tracking location, such as when a group is moved offsite.

The following are the rules for assigning volume groups:

� All volumes in a group must be the same media type.

However, a media type and its corresponding cleaning media type are allowed in the 
same volume group (for example, DLT and DLT_CLN).

� All volumes in a robotic library must belong to a volume group. You cannot add 
volumes to a robotic library without specifying a group or having Media Manager 
generate a name.

� The only way to clear a volume group name is to move the volume to standalone and 
not specify a volume group.

� More than one volume group can share the same location. For example, a robotic 
library can contain volumes from more than one volume group and you can have 
more than one standalone volume group.
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� All members of a group must be in the same robotic library or be standalone. 

Do not confuse volume pools with volume groups. Remember that

� A volume pool identifies a set of volumes by usage.

� A volume group identifies a set of volumes by physical location and, like the volume 
pool, is specified when you add the volume. Groups are convenient for updating the 
configuration when moving volumes (for example from robotic to standalone).

Volume Pools and Groups Example
The following figure shows an example with one volume pool (NB_pool) and several 
volume groups. In this example, volumes can be moved between the groups in the robotic 
library and the groups that are offsite. All volumes, however, remain in the same pool.

Volume Pool With Multiple Volume Groups

In the following figure, members of the same volume pools are in different volume 
groups. The important thing to notice in this example is that the data intended for use by 
different departments are kept on separate volumes by assigning different volume pools. 
The volumes in a pool can be in more than one physical location and in more than one 
volume group.

In this example, the volumes in NB_pool_dept_1 are spread among the rob_A, 
standalone1, and offsite volume groups. These groups also have volumes from more than 
one pool (though the volumes in each group must all be the same type).

Robotic

Group 1 Group 2 

Group 3 Group 4

Offsite 1

Offsite 2

Standalone
NB_pool
Appendix B, Media Manager Reference Topics 229



Volume Pools and Volume Groups
Volume Groups With Multiple Volume Pools

It is also possible to configure a scratch pool from which Media Manager can transfer 
volumes when another volume pool has no media available (see “Scratch Volume Pools” 
on page 230).

Scratch Volume Pools
The scratch pool is an optional volume pool that you can configure. Each media server in 
your configuration can have one scratch pool configured. If a scratch pool is configured, 
Media Manager moves volumes from that pool to other pools that have do not have 
volumes available.

See “Adding a New Volume Pool or Scratch Volume Pool” on page 56 for configuration 
information.

For example in the following figure, the scratch pool is named Scratch_pool and Robot C 
contains volumes from that pool in addition to those from other pools. Assume the 
following

� NetBackup requires a DLT volume, so Media Manager attempts to assign one from 
NB_pool_dept_1 in Robot C.

Group 
offsiteGroup 

standalone1

Robot A

NB_pool
_dept_2

NB_pool
_dept_1

Standalone
Standalone

NB_pool
_dept_3

 

Group 
rob_A
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� Robot C has no unassigned volumes available in the NB_pool_dept_1 pool.

Media Manager searches the scratch pool for an unassigned DLT volume in Robot C. If 
there is an available volume, Media Manager moves it to NB_pool_dept_1 and assigns it 
to NetBackup. Otherwise, a media unavailable status is logged.

Scratch Pools

The following list contains important notes on scratch pool usage:

� If the scratch pool contains assigned volumes, these volumes remain in the scratch 
pool. Media Manager does not move assigned volumes to other pools as it does with 
unassigned volumes.

� Media Manager will not assign volumes while they are in a scratch pool. For example, 
if a NetBackup policy or schedule specifies the scratch pool, all requests for those 
volumes are denied.

� Volumes moved from a scratch pool to another pool remain in that new pool. Media 
Manager does not automatically move it again for any reason, but you can manually 
reassign it to another volume pool.

� To have Media Manager manage the allocation of your volumes to your volume 
pools, do one of the following:

 

NB_pool_dept_1

NB_pool_dept_2

Scratch_pool

Robot C - DLT

Group
Appendix B, Media Manager Reference Topics 231



Volume Pools and Volume Groups
- Create volume pools as required, but do not add any volumes to the pools.

- Create a scratch pool and add all of your volumes to it. Media Manager will move 
volumes to the other pools as they are required.

Moving Volumes
When you move volumes in or out of a robotic library, you must physically and logically 
move the volume (see the following figure).

� The physical part of the move is done when you insert or remove the volume. For 
some robot types, you can use Media Manager to physically move the volume (using 
Inject/Eject options).

� The logical part of the move is done when you use Media Manager to move volumes. 
Media Manager updates the volume database to show the volume at the new location.

Example of Moving Volumes

Common instances when you move volumes are as follows:

� Replacing full volumes in a robotic library. When a volume is full and there are no 
more empty slots in the robotic library, you move the full volume to standalone and 
configure a volume for the empty slot, or move a volume into that slot. Use the same 
process to replace a defective volume.

� Moving volumes from a robotic library to an offsite location or from an offsite location 
into a robotic library. When you move tapes to an offsite location, you move them to 
standalone.

2. Move new volume
to robotic

1. Move full volume
to standalone

Example of replacing a full volume with
a new volume.

Update the volume configurationReplace the full with the new

1 2

Physical Move Logical Move

full new
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� Changing the volume group for a volume or volumes.

In one move operation, you can move a single volume, multiple volumes, or combinations 
of single and multiple volumes. You are limited only in that you cannot move volumes to 
an invalid location (for example, DLT media to an 8-mm robot). 

The best approach is to keep your moves simple by selecting and moving only one type of 
media at a time to a single destination. For example, if you have to move 8 mm and 4 mm 
cartridge tapes, do it in separate moves.

Barcodes
Reading barcodes is a function of the robotic library hardware. When a robotic library has 
a barcode reader, it scans the media for barcodes and saves the results. This associates the 
slot number and the barcode with the media in that slot. Media Manager obtains this 
association from the robotic library.

VERITAS suggests that you use media with barcodes in robots that can read barcodes. 
Barcodes offer the following advantages:

� Automatic media ID assignment.

When you add new media to a robot, Media Manager is able to assign media IDs 
according to the criteria that you specify.

� More accurate tracking of volume location.

The Update Volume Configuration option can easily determine which volumes are in 
a robot.

� Increased performance.

Media Manager functions well whether or not barcodes are used. However, not using 
barcodes can adversely affect performance for some robots. 

A robot that reads barcodes will perform a scan each time it moves a tape. This is 
normal and is done in order to store the correct barcode in memory or to verify a 
previously saved barcode. However, if a barcode is missing, the robot will retry the 
scan multiple times, degrading performance.

Note Volumes in an RSM robot use the media name as a volume identifier. This volume 
identifier is used as the Media Manager media ID. The last six characters of the 
media name are used. If these characters contain spaces, only the characters back to 
the first space are used.

When selecting barcodes for your volumes keep the following points in mind:

� Barcodes appear on labels that you attach to the outside of tape volumes.
Appendix B, Media Manager Reference Topics 233



Barcodes
� Media Manager supports barcodes with a maximum of eight characters (a maximum 
of six characters in RSM robots).

� When you buy barcode labels for use with Media Manager, always follow the robotic 
library vendor’s recommendations. The following are some general guidelines:

Ensure that the barcodes have the correct number of characters.

Barcodes can represent any combination of alpha and numeric characters, but 
different robots support different lengths of barcodes. See the vendor’s 
documentation to determine the requirements for a specific robot type.

Use barcodes without spaces (leading spaces, trailing spaces, or spaces between any 
characters). Otherwise, the robot or Media Manager can have difficulty interpreting 
them.

� You can match barcodes to media IDs by getting custom labels with six-character 
barcodes in the same series as your media IDs. For example, to match a set of media 
IDs from AA0000 to ZZ9999, get barcode labels in that series.

� When a robotic library can contain more than one media type, a good strategy for 
assigning barcodes is to assign specific characters in the barcode to different media 
types using media ID generation rules (see “Media ID Generation Rules” on 
page 236). Another approach is to use barcodes to differentiate between data tapes 
and cleaning tapes, or between volume pools.

Barcode Rules
A barcode rule specifies the criteria for assigning attributes to new robotic volumes. These 
attributes are assigned by Media Manager according to the barcode on the volume that is 
detected by the robotic library. In Media Manager, you choose whether to use barcode 
rules when you set up the robot inventory update operation.

The following table shows some example barcode rules. Rules are sorted first according to 
the number of characters in the barcode tag and then in the order you add them. Two 
exceptions are the <NONE> and <DEFAULT> rules, which are always at the end of the 
list.

Example Barcode Rules

Barcode Tag Media Type Volume Pool
Max Mounts/
Cleanings Description

0080 8MM b_pool 55 new 008 volumes

DLT DLT d_pool 200 dlt backup
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When a robot update operation uses Media Manager barcode rules and a new barcode is 
detected in a slot, Media Manager searches the rules starting at the top of the list and 
checks for a barcode tag that matches the new barcode. If a tag matches, the media type 
for the rule is checked to ensure that it is compatible with the type you specified for the 
robot update. If the media type also matches, Media Manager uses the rule’s media type, 
volume pool, maximum number of mounts (or number of cleanings), and description 
when it assigns attributes in the volume database.

Note Media Manager will not use barcode rules for barcodes that are being used by 
existing volumes.

For example, assume that you select the following Update Options for a new 8-mm tape in 
a TS8 robot:

Media Type: 8MM

Volume Group: 00_000_TS8

Use Barcode Rules: YES

Volume Pool: DEFAULT

If a new tape in this robotic library has a barcode of TS800001, Media Manager uses the 
rule with the barcode tag of TS8 and uses the following attributes for the tape:

Media ID: 800001 (last six characters of barcode)

Volume Group: 00_000_TS8

Volume Pool: t_pool

Max Mounts: 0 (infinite)

CLD DLT_CLN None 30 dlt cleaning

CLT 8MM_CLN None 20 8-mm cleaning

TS8 8MM t_pool 0 8-mm backup

TS 8MM None 0 8-mm no pool

<NONE> DEFAULT None 0 no barcode

<DEFAULT> DEFAULT NetBackup 0 other barcodes

Example Barcode Rules (continued)

Barcode Tag Media Type Volume Pool
Max Mounts/
Cleanings Description
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If a new tape has a barcode of TS000001, Media Manager uses the rule with the barcode 
tag of TS and the attributes for the tape are:

Media ID: 000001 (last six characters of barcode)

Volume Group: 00_000_TS8

Volume Pool: None

Max Mounts: 0 (infinite)

Media ID Generation Rules

Note To use media ID generation rules, the robot must support barcodes and the robot 
type cannot be RSM.

Using media ID generation rules allows you to manage your barcodes when you do not 
want to use the default rule for media ID generation. You control how Media Manager 
media IDs are created by defining rules that specify which characters of a barcode on tape 
will be used in the media ID. You also can specify that alphanumeric characters are to be 
inserted into the ID.

For example, two eight-character barcodes might be S00006L1 and 000006L1. If you do 
not specify media ID generation rules, Media Manager uses the right-most six characters 
of the barcode to create its media IDs. In this example, the same media ID for the two 
barcodes would be created.

Rules can be defined with respect to a robot and barcode lengths. Multiple barcode 
creation entries can be specified, allowing the ID generation to be specific for each robot; 
or for each barcode format having different numbers of characters in the barcode. This 
allows flexibility for multi-media. 

vmd Security
Media Manager vmd security works in conjunction with NetBackup 
authentication/authorization security to control user access to vmd (the NetBackup 
Volume Manager service).

Media Manager vmd security consists of the following levels of security. Each successive 
level provides more security. These levels are explained in the following topics:

� “Media Manager vmd Authentication/Authorization” on page 238.

� “Media Manager Server-Based vmd Security” on page 239.

� “Media Manager Enhanced vmd Authorization” on page 240.
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Possible NetBackup and Media Manager Conflicts
Media Manager authentication/authorization may affect systems where NetBackup 
authentication/authorization has been enabled.

Connections to vmd will fail if the following are all true:

� Authentication/authorization are enabled.

� An AUTHORIZATION_REQUIRED entry is present in vm.conf.

� The caller of vmd does not have the required permission to use vmd functions. 

If authentication/authorization is needed in NetBackup but not in Media Manager, you 
can do one of the following:

� Add SERVER entries in vm.conf.

� Have no SERVER and no AUTHORIZATION_REQUIRED entries in vm.conf.

NetBackup Authentication/Authorization
NetBackup authentication verifies NetBackup client to server access and also controls 
access to the services available on that host. 

NetBackup authorization verifies if a NetBackup administration user has permission to use 
the services available on that host. Authorization provides additional security over the 
security provided by authentication.

The steps you use to set up security levels for your NetBackup master server apply 
generally to setting up security for Media Manager media servers. See the NetBackup 
system administrator’s guide (UNIX or Windows) for more information including the 
following:

� Explanations of authentication and authorization.

� Explanations of Enhanced Authentication.

� Explanations of Enhanced Authorization.

� Definition of the NetBackup configuration file (bp.conf).

� Definitions of the methods.txt, methods_allow.txt, and authorize.txt files.

� Information on bpauthsync(1M), vopied(1M), and vopie_util(1M)man pages.
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Media Manager vmd Authentication/Authorization
Media Manager security for vmd works in conjunction with the following to control 
access to vmd:

� NetBackup authentication/authorization

� Media Manager server-based security

� Media Manager enhanced authorization 

The following two tables provide an overview of Media Manager vmd security. Server 
Name, used in these matrices, refers to SERVER entries in the vm.conf file. 

See “Media Manager Configuration File (vm.conf)” for more information about SERVER, 
AUTHORIZATION_REQUIRED, and PREFERRED_GROUP entries.

No vm.conf Entry Present

The following table describes Media Manager vmd security when there is no 
AUTHORIZATION_REQUIRED entry in the vm.conf file.

If Authentication is not enabled (see the fourth row in the table), the resulting security 
reduces to Media Manager server-based security.

vmd Security Matrix - No AUTHORIZATION_REQUIRED Entry in vm.conf

Access to vmd
Functionality?

Server Name
is in vm.conf

No Server Names
in vm.conf
(or there is no
vm.conf File)

Server Name is Not
in vm.conf (other
Server Names are)
in vm.conf

Authentication Failed Denied Denied Denied

Authentication Enabled
and
User is Authorized

Allowed Allowed Allowed (overrides
server-based
security)

Authentication Enabled
and
User is Not Authorized

Allowed (uses
server-based
security)

Allowed (uses
server-based
security)

Denied

Authentication Not Enabled Allowed Allowed Denied
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vmd Security
vm.conf Entry Present

The following table describes Media Manager vmd security when there is an 
AUTHORIZATION_REQUIRED entry in the vm.conf file.

Your level of security is dependent upon your use of the following:

� Authentication

� Authorization

� SERVER entries 

Media Manager Server-Based vmd Security
SERVER entries in vm.conf are used for server-based Media Manager vmd security. 
Without any SERVER entries present on a particular host and without the 
AUTHORIZATION_REQUIRED entry present, other hosts can access vmd on the host. You 
can add SERVER entries allowing only specific hosts to remotely access vmd.

If a host’s vm.conf file contains any SERVER entries, there must also be a SERVER entry 
for that host or it will not be able to manage its own devices.

The fourth row of the table in “No vm.conf Entry Present” on page 238 provides an 
overview of Media Manager server-based vmd security.

vmd Security Matrix - AUTHORIZATION_REQUIRED Entry is in vm.conf

Access to vmd
Functionality?

Server Name
is in vm.conf

No Server Names
in vm.conf

Server Name is Not
in vm.conf (other
Server Names are)
in vm.conf

Authentication Failed Denied Denied Denied

Authentication Enabled
and
User is Authorized

Allowed Allowed Allowed (overrides
server-based
security)

Authentication Enabled
and
User is Not Authorized

Allowed (uses
server-based
security)

Denied (disables
server-based
security)

Denied

Authentication Not Enabled Allowed Denied Denied
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How Media Manager Selects a Drive for a Robotic Mount Request
Media Manager Enhanced vmd Authorization
The set of commands that Media Manager Enhanced Authorization allows users to 
execute are limited to those commands that interact with vmd. Other administration 
commands that manipulate the Media Manager database and configuration files directly 
can not be used by administrators through Enhanced Authorization.

The Media Manager commands that are allowed with Enhanced Authorization follow:

� vmadd

� vmchange

� vmdelete

� vmoprcmd

� vmpool

� vmquery

� vmrule

Setting up Enhanced Authorization

If you want to control user access to administer Media Manager vmd commands, see the 
Enhanced Authentication and Authorization chapter of the UNIX NetBackup system 
administrator’s guide for instructions on using enhanced authentication and 
authorization.

How Media Manager Selects a Drive for a Robotic Mount 
Request

When a mount request is issued, ltid queries vmd on the volume database host(s) for the 
media ID specified. If the media ID is found, vmd returns the location of the media (which 
robotic library and the storage slot number, if applicable).

If a drive exists that meets the following criteria, the mount request is forwarded to the 
appropriate robotic process.

� The drive is configured.

� The drive is in the robotic library that contains the media.

� The drive allows the requested media density.

The robotic process is managing the drives and requests for drives in the robotic library 
that contains the requested media. The process (for example, tldd) does the following:
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Administrators Quick Reference
� Determines which of the drives are currently available. Some of the things that are 
checked to determine drive availability follow. Is the drive

- Configured as DOWN?

- Already assigned?

- Of a compatible type?

- Reserved by another host?

� Picks the drive that was used least recently.

The time stamp used by drive selection is contained in robotic process memory. If the 
process is stopped and restarted, everything starts out equal again. The first drive as 
shown by tpconfig -d in the drive configuration will be used first, then the second, 
and so on. This time stamp is based on the dismount time, not the mount time.

Administrators Quick Reference
The following tables provide a quick reference to information that you will frequently use 
while using Media Manager. 

Media Manager Commands
See “Media Manager Commands and Processes” on page 161 for detailed information on 
most of the commands shown in the following table.

Note Services should be started and stopped using the Services applet in the Windows 
control panel. If they are started from the command line, some will occupy that 
NetBackup Console session until they are stopped.

The commands listed are located in install_path\volmgr\bin.

Commands

Command Description

Administrator Utilities

robtest Starts the robotic test utilities.

NOTE: This utility is not officially supported.

Starting Services and Processes
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Log Files
The following table contains descriptions of important Media Manager log files.

avrd The Automatic Volume Recognition process. This process is started by ltid.

ltid Starts the NetBackup Device Manager service. Starting ltid also starts the 
robotic, robotic control, and Media Manager volume (avrd) processes.

tl4d The Tape Library 4MM robotic process. This process is started by ltid.

tl8cd Starts the Tape Library 8MM robotic-control process. This process is started by 
ltid.

tl8d The Tape Library 8MM robotic process. This process is started by ltid.

tldcd Starts the Tape Library DLT robotic-control process. This process is started by 
ltid.

tldd The Tape Library DLT robotic process. This process is started by ltid.

ts8d The Tape Stacker 8MM robotic process. This process is started by ltid.

tsdd The Tape Stacker DLT robotic process. This process is started by ltid.

vmd The NetBackup Volume Manager service. This process is started by ltid.

Stopping Services and Processes

stopltid Stops the device, robotic, and robotic-control services.

tldcd -t Stops the Tape Library DLT robotic-control process.

tl8cd -t Stops the Tape Library 8MM robotic-control process.

Commands (continued)

Command Description

Logs

Log File Description

Event Viewer Contains general Media Manager logging, including errors. 
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Media Manager Configuration File (vm.conf)
Media Manager Configuration File (vm.conf)
The install_path\volmgr\vm.conf file contains entries for media and device 
management. This file usually is created by NetBackup, but if it does not exist you need to 
create it to add entries.

The entries that this file can contain are as follows. See “Example vm.conf File” on 
page 250 for an example configuration file.

Authorization Required

AUTHORIZATION_REQUIRED

If this entry is specified, Media Manager and NetBackup utilities must have authorization 
to connect to vmd; or a SERVER entry must be present in the vm.conf file. This entry is 
recommended for maximum security.

If this entry is not specified, Media Manager and NetBackup utilities may connect to vmd 
without specific authorization, except in the case when a non-matching SERVER entry is 
present in vm.conf.

Backup Exec - Mapping Media Types

backup_exec_media_type = netbackup_robot_number netbackup_media_type

daemon/ddmmyy.log Contains debug information for the NetBackup Volume Manager 
service (vmd) and its associated processes (oprd and rdevmi). 

The path is install_path\volmgr\debug\daemon.

reqlib/ddmmyy.log Contains debug information on the processes that request vmd. 

The path is install_path\volmgr\debug\reqlib.

tpcommand/ddmmyy.log Contains debug information for device configuration. Includes 
information for tpconfig, tpautoconf, and the NetBackup GUIs.

The path is install_path\volmgr\debug\tpcommand.

ltid/ddmmyy.log Contains debug information for ltid, the NetBackup Device 
Manager service.

The path is install_path\volmgr\debug\ltid.

Logs (continued)

Log File Description
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Media Manager Configuration File (vm.conf)
This entry maps Backup Exec media types to NetBackup media types and is used with the 
Backup Exec tape reader feature. This entry can be used when a NetBackup robot has 
different drives of a similar type configured.

For example in a Backup Exec configuration, you have a robot with two DLT drives. Both 
drives are considered to be DLT and all media in this robot have a media type of BE_DLT. 
You plan to move your Backup Exec media to be used with NetBackup.

In your NetBackup configuration, you have a different robot (robot 1) with two DLT 
drives. One drive is configured as DLT (Drive0) and the other drive is DLT3 (Drive1). The 
Backup Exec DLT media type can map to DLT or DLT3.

If a backup_exec_media_type entry is not specified, the Backup Exec media type will be 
mapped to the media type of the drive with the lowest index. Based on information not 
shown for this example, Drive0 is determined to have the lowest drive index. Drive0 is 
DLT, so Backup Exec media type DLT will be mapped to the NetBackup media type DLT. 
(This is equivalent to specifying BE_DLT = 1 DLT.)

If you do not want this default mapping, you can add a backup_exec_media_type entry 
to specify that for this robot, the Backup Exec DLT media type maps to the NetBackup 
DLT3 media type (BE_DLT = 1 DLT3).

backup_exec_media_type is the Backup Exec media type.

netbackup_robot_number is the NetBackup robot number. For standalone drives, the 
robot number must be -1. For example,  BE_DLT = -1 DLT

netbackup_media_type is the NetBackup media type (see “Media Manager Media Types” 
on page 214).

Allowable and default mappings are as follows:

Client Port Range

CLIENT_PORT_WINDOW = start end

Backup Exec Media Type NetBackup Media Type Default Mapping

BE_8MM  8MM, 8MM2, 8MM3 8MM

BE_DLT DLT, DLT2, DLT3 Media type of the drive with 
the lowest index

BE_HALF_INCH HCART, HCART2, HCART3 Media type of the drive with 
the lowest index
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Specifies the range of nonreserved ports on this computer that are used for connecting to 
vmd on other computers. 

For example the following entry permits ports from 4800 through 5000:

CLIENT_PORT_WINDOW = 4800 5000

If you specify 0 for start, the operating system determines the nonreserved port to use. If 
you do not specify a CLIENT_PORT_WINDOW entry, the operating system determines the 
nonreserved port. 

Days To Keep Debug Logs

DAYS_TO_KEEP_LOGS = days

Specifies the number of days to keep debug logs before vmd deletes them. 0 means that the 
logs are not deleted. The default is 0.

Disable Automatic Path Remapping

DISABLE_AUTO_PATH_CORRECTION

Disables automatic device path remapping. With this entry, the device configuration will 
remain unchanged when the NetBackup Device Manager service is started. This may 
result in the device configuration becoming out of sync with the host’s view of devices 
following a reboot.

Disallow Non-NDMP Request on NDMP Drive

DISALLOW_NONNDMP_ON_NDMP_DRIVE

In NetBackup, all read types of operations (restore, the read-portion of duplicates, import, 
and verify) and the write-portion of duplicates are not scheduled. Therefore these 
operations compete for available drives.

NetBackup attempts to use an available drive based on the type of request:

� For a NDMP backup or restore request, the drive must be a NDMP drive. 

� For a non-NDMP request of any kind, NetBackup always tries to find an available 
non-NDMP drive. But, if a non-NDMP drive is not available and a NDMP drive is 
available, the operation will be done using the slower NDMP drive.

If a DISALLOW_NONNDMP_ON_NDMP_DRIVE entry is specified on master or media 
servers, NetBackup will not assign a non-NDMP request to available NDMP drives. 
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Be aware when specifying this entry, that because some operations may have to wait 
for available non-NDMP drives to become available, the media mount timeout value 
may have to be increased (by using an entry in the UNIX bp.conf file or in the 
registry on Windows).

Do Not Eject Standalone Tapes

DO_NOT_EJECT_STANDALONE

If this entry is specified, tapes in any standalone drives will not be ejected when a backup 
has completed (tapes will be ejected, if end of media is reached during a backup). This 
entry can be used in a NetBackup environment, where it is desirable to keep a standalone 
drive ready after successful backups are performed.

The NO_STANDALONE_UNLOAD file is also used to control tape ejects in standalone drives. 
Refer to the appendices of the NetBackup system administrator’s guides for Windows 
servers for more information about this file.

Media ID Generation

MEDIA_ID_BARCODE_CHARS = robot_num barcode_length media_ID_rule

Note To use this entry, the robot must support barcodes and the robot type cannot be 
RSM.

This entry controls Media Manager media ID generation. You choose how IDs are created 
by defining rules that specify which characters of a barcode on tape will be used. You also 
can specify alphanumeric characters to be inserted in the ID.

Multiple barcode creation entries can be specified, allowing the media ID generation to be 
specific for each robot; or for each barcode format having different numbers of characters 
in the barcode. This allows flexibility for multi-media. 

If MEDIA_ID_BARCODE_CHARS entries are not present or you enter an invalid entry, 
Media Manager uses the rightmost six characters of the barcode to create its media ID.

robot_num is the robot number.

barcode_length is the length of the barcode.

A media_ID_rule consists of a maximum of six fields delimited by colons. Numbers in the 
fields of the rule define the positions of the characters in the barcode that are to be 
extracted (numbering is from the left). For example, 2 in a field extracts the second 
character from the barcode. The numbers can be specified in any order.
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Characters prefixed by # in a field result in that character being inserted in that position in 
the generated ID. Any alphanumeric characters that are specified must be valid for a 
media ID. You can use rules to create media IDs of many varied formats, but keep in mind 
that the difference in the label on the media and the generated media ID may make it 
difficult to manage your media. The following is an example rule and the resulting media 
ID:

Barcode on the tape: 032945L1
Media ID rule:       #N:2:3:4:5:6
Generated media ID:  N32945

Also see “Media ID Generation Rules” on page 236.

Media ID Prefix

MEDIA_ID_PREFIX = media_id_prefix

Defines the media ID prefixes to use for media without barcodes. You add the media to a 
robot with Update Volume Configuration option.

See “Changing the Update Options” on page 101.

Preferred Group

PREFERRED_GROUP = netgroup_name

This entry is used by all callers in Media Manager and NetBackup (other than 
bpgetmedia and bptm) for authentication/authorization for vmd. netgroup_name is case 
sensitive.

If this entry is specified, a check is made to determine if the user is a member of 
domain\group. This check is limited to Windows global groups. If PREFERRED_GROUP is 
set to a domain local group, a match does not occur and the user's primary domain\group 
is used. 

If a PREFERRED_GROUP entry is not specified or the user is not a member of the 
domain\group, the user's primary domain\group is obtained. If the domain name is an 
empty string or the name of the local machine, it is considered to be local.

If a PREFERRED_GROUP entry is not specified, the 
HKEY_LOCAL_MACHINE\SOFTWARE\VERITAS\NetBackup\
CurrentVersion\Config registry key is checked for an entry.

To achieve a platform independent implementation, netgroup_name is case sensitive. The 
following is an example entry:

PREFERRED_GROUP =  NTDOMAINNAME\Backup Operators
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Prevent Media Removal (TL8 Robots)

PREVENT_MEDIA_REMOVAL

Note Specifying this entry changes the default operation for TL8 robots. Without this 
entry present, Media Manager allows the removal of media.

If this entry is specified, TL8 robots will execute the SCSI command PREVENT MEDIUM 
REMOVAL. You then will not be able to open the robot’s main door or gain access to the 
media access port while the robotic control daemon is running. You can override this 
action by doing one of the following:

� Use the test utility and execute allow media removal.

� Use inject/eject for access, when adding or moving volumes.

Random Port Numbers

RANDOM_PORTS = YES|NO

Specifies whether Media Manager chooses port numbers randomly or sequentially when 
it requires a port number for communication with Media Manager on other computers. 

� If RANDOM_PORTS = YES (the default), Media Manager chooses port numbers 
randomly from those that are free in the allowed range. For example, if the range is 
from 1024 through 5000, Media Manager chooses randomly from the numbers in this 
range.

� If RANDOM_PORTS = NO, Media Manager chooses numbers sequentially, starting 
with highest number that is available in the allowed range. For example, if the range 
is from 1024 through 5000, Media Manager chooses 5000 (assuming it is free). If 5000 
is being used, port 4999 is chosen.

By default, a RANDOM_PORTS entry is not present in the Media Manager configuration 
file. This means that Media Manager uses the random method for selecting port numbers.

If you are specifying RANDOM_PORTS = NO in the NetBackup configuration file, you 
should also specify RANDOM_PORTS = NO in the Media Manager configuration file.

Required Network Interface

REQUIRED_INTERFACE = host_name
248 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



Media Manager Configuration File (vm.conf)
Specifies the network interface that Media Manager uses when connecting to another 
Media Manager server. A Media Manager server can have more than one network 
interface and by default, the operating system determines the one to use. To force Media 
Manager connections to be through a specific network interface, use this entry and specify 
the network host name of that interface. 

In the following example, host1 is the network host name of the interface.

REQUIRED_INTERFACE = host1

Refer to the NetBackup system administrator’s guide for more information on NetBackup 
network configuration.

RSM Media Mapping

RSM_mediatype

Maps Windows 2000 Removable Storage Manager (RSM) media types to Media Manager 
media types.

See the appendix, “Microsoft Removable Storage Manager (RSM)” on page 269 for more 
information.

Scratch Pool Configuration

SCRATCH_POOL = pool_name

Configures the specified volume pool as the scratch pool. The scratch pool is a special 
volume pool from which media is moved as needed into volume pools that have no 
available media.

You can specify any scratch pool name, except the names: NetBackup, DataStore, or None. 
If the specified volume pool does not exist, Media Manager creates it and sets the host, 
user, group, and description for the pool to ANYHOST, root, NONE, and Scratch Pool, 
respectively.

If you subsequently delete the SCRATCH_POOL entry, the specified volume pool will no 
longer be the scratch pool.

See “Adding a New Volume Pool or Scratch Volume Pool” on page 56.

Server Entry

SERVER = host_name
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This entry is used for security and specifies which hosts can monitor and control devices 
on this host. Without any SERVER entries and authentication enabled, any host can 
manage the devices and volumes on the local host.

For security you can add entries allowing only specific hosts to remotely access the 
devices. If a host’s vm.conf file contains any SERVER entries, there must also be a 
SERVER entry for that host or it will not be able to manage its own devices.

Verbose Message Logging

VERBOSE

Causes most Media Manager processes to be started with verbose logging enabled.

Use this option only if problems occur or if requested by VERITAS support. After the 
problem is resolved, remove any debug logs that were created or add a 
DAYS_TO_KEEP_LOGS entry.

Example vm.conf File
The following is an example of a vm.conf file, on host yak:

SERVER = yak

SERVER = whale

MEDIA_ID_PREFIX = NV

MEDIA_ID_PREFIX = NETB

SCRATCH_POOL = ScratchPool
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Robot Drive and Slot Layouts
 C

This appendix contains diagrams of slot layouts and drive locations in some of the more 
popular robots supported by Media Manager. If your robot is not included here, see the 
vendor’s documentation for the device.
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ADIC Scalar 218 (TLD)
ADIC Scalar 218 (TLD)

Note With a barcode reader installed, the slot physically labeled as slot 1 is disabled, and 
physical slots 2 through 18 become known in Media Manager as slots 1 through 17. 
With a virtual media access port configured, physical slot 12 becomes the port and 
physical slots 2-11 and 13-18 become known in Media Manager as slots 1-16.

Exabyte 430
Sony LIB-304 (TL8)

Drive 2 Drive 1 

Slot 1 Slot 12

Slot 13 Slot 18

. . .20  11

Fixed Cartridge Slots Tape Drives

Magazine 1Magazine 2

. . .10  1

. . .21  30 1  4

Media access port

32
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ADIC VLS DLT (TSD)
ADIC VLS DLT (TSD)

ATL 2/28 DLT Library (TLD)

Drive 1 (the only drive)

SlotSlot

1 72 3 4 5 6

Drive 2

Drive 1

I/E slot 1

I/E slot 2

I/E slot 3

I/E slot 4

.

.

.

.

.

.

.

.

.

Slot 8

Slot 1

Slot 16

Slot 9 Slot 17

Slot 24

(Not Used) (Not Used) (Not Used)
Appendix C, Robot Drive and Slot Layouts 253



ATL P1000 Sun StorEdge L1000 (TLD)
ATL P1000 
Sun StorEdge L1000 (TLD)

The slot mapping shown below apply to libraries that are configured with 25 slots. Other 
configurations may vary.

Slot 5

Slot 4

Slot 6

Slot 7

Slot 8

Slot 9

Slot 18

Slot 25

Slot 10

Slot 17

Slot 1

Slot 2

Slot 3

Drive 1 Drive 2

Drive 3 Drive 4

Back (Inside view of back wall from the front

Front (Inside view of front wall from the back

Media 
Access 
Port
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ATL M1500 M4 Data M1500 (TLD)
ATL M1500 
M4 Data M1500 (TLD)

The slot mapping below shows a robot with two units, each unit having two removable 
magazines. For NetBackup BusinesServer, only a single unit is allowed and the fixed slot 
is 21.

Front View

Top Unit

Bottom Unit

Removable

Magazine

Removable

Magazine

Removable

Magazine

Removable

Magazine

Slot 1

Slot 10

Top Unit - (Front) Bottom Unit - (Front)

Slot 20

Slot 11

Slot 21

Slot 30

Slot 40

Slot 31

Top View of Magazines

Slot 41 Slot 42
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Breece Hill Q2.15 IBM 7337-305 IBM 3447-105 (TLD)
Breece Hill Q2.15
IBM 7337-305 
IBM 3447-105 (TLD)

Breece Hill Q7 (TLD)

Drive 1 Drive 2 

(Top View)

Slot 1 Slot 10

Slot 11 Slot 15

Drive 1

Drive 2

Face 0 Face 3Face 2Face 1

.

.

.

.

.

.

.

.

.

.

.

.

Slot 8

Slot 14Slot 7

Slot 1 Slot 15

Slot 21 Slot 28

Slot 22
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Compaq 35/70 (TLD)
Compaq 35/70 (TLD)

Exabyte 10i, 10e, 10h
Exabyte 210
Exabyte EZ17 (TS8)

Drive 1 Drive 2

.

.

.

.

.

.

.

.

.

Slot 5

Slot 1 Slot 6

Slot 10 Slot 15

Slot 11

Drive 1

.

.

.

Drive 1

Drive 2

Drive 1

.

.

.

.

.

.

EZ17Fixed Slot 0
EXB-210

EXB-10i and 10e

Slot 1

Slot 7

Slot 10

Slot 1

Slot 1

Slot 10
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Exabyte 18D (TLD)
Exabyte 18D (TLD)

Exabyte 220
ADIC Scalar AIT 220 
Sun StorEdge L400 (TL8)

Drive 1

.

.

.

Slot 1

Slot 8

Drive 1

Drive 2

Face 0 Face 1

.

.

.

.

.

.

Fixed Slot 0

Slot 11

Slot 20

Slot 1

Slot 10
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Exabyte 230D (TLD)
Exabyte 230D (TLD)

HP SureStore 1/9
Sun StorEdge L9 (TLD)

This is a top view of the robot.

Drive 2

Drive 1

Fixed slot - 0

Face-0 Face-1 Face-2 Face-3 Face-4 Face-5

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

Slot 5 Slot 10 Slot 15 Slot 20 Slot 25 Slot 30

Slot 1 Slot 6 Slot 11 Slot 16 Slot 21 Slot 26

Drive 1
Slot
7

Slot
1

Slot
2

Slot
3

Slot
4

Slot
8

Slot
5

Slot
9

Slot
6

Appendix C, Robot Drive and Slot Layouts 259



ADIC Fastor (TLD)
ADIC Fastor (TLD)

.

.

.

 

Slot 6

Slot 7

Slot 1

Slot 5

 

Drive 1

BackFront
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NEC Autoloader DLT (TLD)
NEC Autoloader DLT (TLD)
The following diagram shows a standard model.

The following diagram shows a model with a barcode reader.
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Overland Data LXBx110 Overland Data LXBx210 Compaq TL891 Compaq TL892 (TLD)
Overland Data LXBx110 
Overland Data LXBx210 
Compaq TL891
Compaq TL892 (TLD)

.

.

.

Slot 10

Slot 1

Front

(Tape Holder)

(LXBx210 has two drives inside)

(LXBx110 has one drive inside) 
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Overland Data Library Pro (TL8)
Overland Data Library Pro (TL8)
The following is the top view.

.

.

.

Slot 19

Drive 2

Drive 1

Slot 1

Media 
access 
port

Picker
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Overland Data NEO Overland Data LxL1u11 (TLD)
Overland Data NEO
Overland Data LxL1u11 (TLD)

The following diagram shows a robot with the media access port enabled.

The following diagram shows a robot with the media access port disabled and is also 
similar to the LxL1u11 model which only supports one drive and 11 slots.
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Compaq Storage Works MSL 5026 Compaq Storage Works MSL 5052 (TLD)
Compaq Storage Works MSL 5026
Compaq Storage Works MSL 5052 (TLD)

The following diagram shows a 5026 robot model.

The following diagram shows a 5052 robot model.

FRONT

BACK

Drive 2

.

.

.

Slot 0

Slot 11

Drive 1

.

.

.

Slot 12

Slot 24

Media 
access 
port

Drive 2

.

.

.

Slot 0

Slot 11

Drive 1

.

.

.

Slot 12

Slot 24

Media 
access 
port

TOP FRONT

Drive 4

.

.

.

Slot 25

Slot 36

Drive 3

.

.

.

Slot 37

Slot 49

Media 
access 
port

BOTTOM BACK

BOTTOM FRONT

TOP BACK
Appendix C, Robot Drive and Slot Layouts 265



STK 9730 STK 9738 DELL 130T HP SureStore E 3/30 (A4853A) (TLD)
STK 9730 
STK 9738 
DELL 130T
HP SureStore E 3/30 (A4853A) (TLD)

If auto cleaning is set, slots 9 through 30 (or 9 through 28) become slots 8 through 29 (or 8 
through 27). The slot labeled below as slot 8 becomes reserved for library use (for a 
cleaning tape). Other configurations may vary.
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STK L20 NCR 6461 (TLD)
STK L20
NCR 6461 (TLD)

If the media access port is turned on in the configuration, slot 20 becomes the media access 
port and is unusable for storage.
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STK L20 NCR 6461 (TLD)
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Microsoft Removable Storage Manager 
(RSM)
 D
Media Manager provides support for robotics under control of the Microsoft Windows 
2000 Removable Storage Manager (RSM) interface.

In Media Manager, RSM-attached robotic devices are

� Classified as Media Manager robot type RSM

� Considered API robots (the robot manages its own media)

Support for these devices is different than for other types of Media Manager robotic 
control. This appendix provides an overview of those differences.

Media Manager and Microsoft RSM
Microsoft RSM presents a common interface to devices that are RSM-compatible and 
attached to a Windows 2000 server. Media Manager supports the changer library devices 
listed on the Microsoft web site that contain drives that are shown in the supported drives 
list on the VERITAS support web site. Many of these devices vary in their support of 
features like barcodes and tape cleaning (tape cleaning is supported using the RSM applet 
see “Microsoft RSM Interface” on page 270).

Microsoft RSM Libraries represent physical layouts of the system (for example, robots and 
drives) and RSM Media Pools represent a logical layout of RSM media.

Media Manager libraries represent an individual changer, silo, robot, and so on. Also, 
Media Manager uses Volume Pool for a logical grouping of media (for example, all tapes 
currently available for backups) and Volume Group for a physical grouping of media (for 
example, all the tapes in a specific robot).

Because the devices and media are directly managed by Microsoft RSM, the Media 
Manager RSM process (rsmd) must always be running to configure media in Media 
Manager.

Considerations When Using Microsoft RSM
Before you configure a robot as an RSM robot, consider the following:
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Media Requests Involving an RSM Robot
� Your Media Manager device host must be running Windows 2000.

� Microsoft Removable Storage Manager will control the robot and drives, rather than 
Media Manager.

� Media Manager library sharing and standalone drives are not supported.

� A robot configured as an RSM robot, cannot also be used as a Media Manager 
direct-controlled (SCSI) robot (for example, TLD).

� RSM libraries could potentially be used by other applications.

Microsoft RSM Interface
You use the Microsoft Removable Storage Manager to configure and manage your RSM 
media and devices. This interface is located in the Computer Management applet under 
the Administrative Tools folder in the Start menu. Documentation on how to use this 
interface is provided by Microsoft.

Media Requests Involving an RSM Robot
A request for media in an RSM robot begins in the same manner as other media requests. 
The NetBackup Device Manager service (ltid) receives the request and queries the 
NetBackup Volume Manager service (vmd)for the location of the media. vmd, in this case, 
returns only the robot number and the type RSM for the robot. 

Since Microsoft RSM manages the media and slots in RSM robots, the Media Manager 
volume database does not contain slot information for media in an RSM robot.

ltid then queries the volume database to retrieve the identifier (GUID or Globally 
Unique ID) assigned by RSM. ltid sends this information, along with the media name to 
the Media Manager RSM process (rsmd). 

rsmd forwards the request to the Microsoft RSM software (the Removable Storage service 
running in Windows 2000). The Removable Storage service locates the media and directs 
the robotics to mount the media in the drive. When the host (where Media Manager is 
installed) receives a success response from the Removable Storage service, it allows the 
requesting application (for example, NetBackup) to start sending data to the drive.

Configuring RSM Robotic Control
Before adding any devices, it is important to verify that the Removable Storage service is 
aware of your device. Use the Removable Storage Manager applet (see “Microsoft RSM 
Interface” on page 270) to verify this.
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Configuring RSM Drives in Media Manager
Adding RSM-attached robots is similar to adding any robot in Windows 2000. But instead 
of specifying the corresponding robot type for the device, you specify RSM as the Media 
Manager robot type. See “Adding Robots” on page 27 for information on configuring 
RSM robots.

As an alternative to using the Devices node of the NetBackup Administration Console, 
the following example uses the tpconfig command to configure an RSM robot:

tpconfig -add -robot 123 -robtype rsm -robpath changer0

The command returns:

Added robot number 123 of type RSM to configuration

Configuring RSM Drives in Media Manager
Before configuring any device make sure that the Removable Storage service is aware of 
your device, by using the Removable Storage Manager applet (see “Microsoft RSM 
Interface” on page 270). Also, in order to configure an RSM drive, first configure the 
corresponding robot and be sure to specify this robot when configuring the drive. 

Configuring a drive is similar to configuring any other drive on a Windows 2000 device 
host. See “Adding Drives” on page 33 for information on configuring RSM drives.

As an alternative to using the Devices node of the NetBackup Administration Console, 
the following example uses the tpconfig command to configure an RSM drive:

tpconfig -add -drive -type dlt -name Tape0 -robot 123 -robtype rsm
                                                             -robdrnum 1

The command returns: 

added drive index 0 of type dlt to configuration

Verifying a Configuration
You can use the tpconfig -d command to verify your configuration, which displays 
results similar to the following:

Index DriveName                 DeviceName   Type  Multihost  Status
***** *********                 **********   ****  *********  ******
  0   Drive0                    \\.\Tape0     dlt      NO       UP
        RSM(123) Definition     DRIVE=1

  Currently defined robotics are:
  RSM(123)   RSM Device Name = \\.\Changer0,
             volume database host = host5
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Adding RSM Volumes
Activating a Configuration
If your changes are complete, stop and restart the NetBackup Device Manager service 
(this also stops and restarts any robotic processes).

1. Stop the NetBackup Device Manager service using Stop/Restart Device Manager 
Service, found on the Actions menu of the Devices node of the NetBackup 
Administration Console.

2. Start the NetBackup Device Manager service using Stop/Restart Device Manager 
Service.

Adding RSM Volumes
Because the devices and media are directly managed by Microsoft RSM, RSM keeps track 
of volumes using its own database.

The method for adding media for an RSM robot is as follows: 

1. Use the Microsoft RSM applet (see “Microsoft RSM Interface” on page 270) to move 
volumes from the Free Media Pool (the default media pool) to the NetBackup Media 
Pool. All volume activity (for example, mounts or dismounts) is through the 
NetBackup Media Pool.

Media names have to be unique within the Microsoft RSM library, even among 
different media types. For Media Manager to recognize media names they should be 
on both the Media Name and Side Name in the Microsoft RSM property sheet for the 
media.

The media ID used in the Media Manager volume database is the last six characters of 
the RSM media name. Therefore, two volumes with RSM media names of A000001 
and B000001 are not considered to be unique by Media Manager.

If the last six characters of the RSM media name contain spaces, only the characters 
back to the first space are used. For example, for an RSM media name of AA BBB 
CCCC, the Media Manager media ID will be CCCC.

2. Since RSM volumes are tracked by their physical and partition GUIDs, volumes that 
are added must be located in the RSM database to capture their GUIDs. Therefore 
volumes added by Media Manager have to exist within the RSM NetBackup Media 
Pool for that robot.

Define the volumes for Media Manager using one of the following procedures:

- Update the volume configuration as explained in “Updating the Volume 
Configuration for a Robot” on page 97.
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Removing Tapes from the Robot
- Add new volumes as explained in “Adding New Volumes” on page 63.

Update the configuration when media has been moved or may have moved 
residences (see “Removing Tapes from the Robot” on page 273). 

3. Use Show Contents and Compare Contents with Volume Configuration from the 
Robot Inventory dialog of the Media node to verify your configuration.

4. The NetBackup “Allow media overwrite” setting must allow overwrite on MTF1 (this 
is necessary because Free Media Labels are in MTF format). To set this,

a. From the NetBackup Administration Console, click the Host Properties node.

b. In the Host Properties window select the media server and click Actions > 
Properties.

c. On the Media tab in the dialog box that appears, select the MTF1 setting.

Removing Tapes from the Robot

1. Use the Media Manager eject command, as explained in “Moving Volumes” on 
page 73 to remove the media from the RSM library.

2. Remove the media from the library as directed by the Removable Storage Manager 
interface. RSM moves volumes that have been ejected to the Off-line Media library.

Media Manager moves the volume to standalone in the Media Manager volume 
database. Media Manager also moves the volume to the RSM NetBackup Standalone 
Media media pool.

Robot Inventory Operations
Media Manager considers an RSM robot as one that supports barcodes. The following 
sequence explains what occurs when you select an operation that requires a robotic 
inventory for an RSM robot:

1. Media Manager requests volume information from the Removable Storage service.

2. The Removable Storage service responds by providing a list of media names and 
associated information from its database. Media Manager then displays a list of 
volumes obtained from the service along with their RSM and Media Manager media 
types.
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vm.conf Map Entries For RSM Robots
The following table indicates an example of information displayed by Media 
Manager:

3. Media Manager maps the RSM media types into Media Manager media types, as 
explained in step 4 or step 5.

4. If this is an operation that does not require updating the volume configuration, Media 
Manager uses the media type defaults for RSM robots (see the table, “Default Media 
Types for RSM Robots” on page 111) when it creates its report.

5. If this is an operation that requires updating the volume configuration, Media 
Manager selects the media type as follows:

a. Media Manager tries to use mappings that you have set for this update using the 
Media Type Mappings dialog box (to access this dialog box, click Media type 
mappings in the Update Options dialog box). See “Changing the Update 
Options” on page 101.

b. If you have not set any media type mappings, Media Manager tries to use the 
RSM_mediatype settings in the vm.conf file (see “vm.conf Map Entries For RSM 
Robots” on page 274).

c. If vm.conf does not exist or if it does not map the media type, Media Manager 
uses the default for RSM robots (see the table, “Default and Allowable RSM 
Media Types” on page 275).

vm.conf Map Entries For RSM Robots
See “Media Manager Configuration File (vm.conf)” on page 243 for an overview of the 
vm.conf file.

Example RSM Information

RSM Media Name
Robot Contents 
RSM Media Type

Robot Contents
Media Manager Media Type

MC120 AIT1_8mm 8mm

NN0402 DDS_4mm 4mm

002455 MP2_8mm 8mm
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vm.conf Map Entries For RSM Robots
The second column in the following table shows the defaults that Media Manager uses 
when assigning media types in RSM robots. The third column shows the media types to 
which you can change the defaults, by creating map entries in vm.conf.

Default and Allowable RSM Media Types

RSM Media Type Default Media Manager Media 
Type

Allowable Media Types 
Through Mappings

DDS_4MM 4MM 4MM

MINI_QIC QCART (1/4-inch cartridge) QCART

TRAVAN QCART QCART

QIC QCART QCART

MP_8MM 8MM 8MM

MP2_8MM 8MM 8MM

AME_8MM 8MM 8MM

AIT1_8MM 8MM 8MM

DLT DLT DLT

STK_EAGLE HCART (1/2-inch cartridge) HCART

LTO_ULTRIUM HCART HCART

LTO_ACCELIS HCART HCART

IBM_MAGSTAR_3590 HCART HCART

IBM_MAGSTAR_MP HCART HCART

STK_DATA_D3 HCART HCART

CLEANER_CARTRIDGE HC_CLN (1/2-inch cartridge) HC_CLN, 8MM_CLN, 
DLT_CLN

UNKNOWN HCART HCART, 4MM, 8MM, QCART, 
DLT
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vm.conf Map Entries For RSM Robots
If the default types do not provide the desired mapping, you can change the defaults by 
creating a vm.conf file and adding RSM_mediatype entries to it.

For example, the following vm.conf entry maps the RSM media type unknown to the 
8MM media type. Without this entry, Media Manager assigns unknown to HCART media 
types.

RSM_UNKNOWN = 8MM

The third column in the table shows the media types that Media Manager allows you to 
specify in RSM_mediatype entries. For example, you cannot specify the following entry. 
This entry is illegal because Media Manager does not permit you to map RSM UNKNOWN to 
the 8MM cleaning media type.

RSM_UNKNOWN = 8MM_CLN
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Glossary
access control list (ACL)

Security information associated with files on some file systems. 

ACS

Automated Cartridge System. ACS can refer to any of the following:

� A type of Media Manager robotic control. This robot type is supported only by 
NetBackup DataCenter servers.

� The StorageTek (STK) system for robotic control.

� The highest-level component under STK’s ACS library software, which refers to a 
specific standalone robotic library or to multiple libraries connected with a media 
passthru mechanism.

active job

A job for which NetBackup is currently processing backup or restore data.

activity logs

See “debug logs.”

activity monitor

A NetBackup administration utility that displays information about NetBackup jobs and 
provides limited control over them.

administration client

See “remote administration console.” 

administrator

A user that is granted special privileges to install, configure, and manage the operation of 
a system, network, or application.
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AIT

Sony Advanced Intelligent Tape, a type of tape drive or media type.

alternate-client restore

See “redirected restore (different client).”

alternate-target restore

See “redirected restore (different target).” 

alternate path restore

See “redirected restore (different path).” 

alternate read server

A server used to read a backup image which was originally written by a different media 
server. The media server specified as Alternate Read Server must have access to the media 
containing the backup image or images it is configured to read.

archive

A special kind of backup where NetBackup backs up the selected files, and if the backup 
is successful, deletes the files from the local disk. In this manual, references to backups 
also apply to the backup portion of archive operations except where otherwise noted.

archive bit

A file-status bit that the Microsoft based operating system sets when it writes a file, 
thereby indicating that the file has changed.

attributes for a policy

Configuration parameters that control the behavior of NetBackup during operations 
involving this policy.

autochanger

See “robotic library.” 

autoloader

See “robotic library.” 

automatic backup

A scheduled backup by the master server.
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back up

The act of copying and saving files and folders to storage media.

backup

Refers to the process of copying and saving files and directories to storage media. For 
example, the backup is complete. This term can also refer to the collection of data that 
NetBackup saves for a client during a backup or archive. For example, duplicate the backup.

Backup is two words when used as a verb. For example, back up the file.

backup, archive, and restore interface

The name of the NetBackup Microsoft Windows and Java based user interfaces for clients. 
On servers these interfaces can be started through the NetBackup Administration 
Console.

backup window

The period of time during which backups can begin.

block size

The number of bytes in each block of data written on the media during a backup.

bp

A backup, archive, and restore utility for users on NetBackup UNIX clients. It has a 
character-based, menu interface that can be run from terminals that do not have X 
Windows capabilities.

bpadm

An administrator utility that runs on NetBackup UNIX servers. It has a character-based, 
menu interface that can be run from terminals that do not have X Windows capabilities.

bp.conf file

A NetBackup configuration file on UNIX servers and also on UNIX, Macintosh, and OS/2 
clients.

bp.ini file

NetBackup initialization file for Novell NetWare target clients.

bpcd

NetBackup Client service on Windows and the NetBackup Client daemon on UNIX. 
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bprd

NetBackup Request Manager service on Windows and NetBackup Request daemon on 
UNIX.

cancel a job

Terminating a job and removing it from the job queue.

carousel

See “robotic library.” 

catalogs

Internal NetBackup and Media Manager databases. These catalogs contain information 
about configuration, media, devices, status, errors, and the files and directories in the 
stored backup images.

CDF

Context-dependent file, which is a type of directory structure on a Hewlett-Packard 
system.

changer

See “robotic library.” 

class

See “policy.”

client

The system with the files to back up, archive, or restore.

client-user interface

See “user interface.”

cluster

See master and media server cluster.

command lines

Commands that users can execute either from the system prompt or in scripts.

compression

The process of compacting data to enable more efficient transmission and storage.
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configuration

The parameters that govern the behavior of an application. This term can also refer to the 
manner in which a network or system is laid out or connected (for example, a network 
configuration).

consolidated eject

A process of ejecting media for more than one Vault session at a time. A Consolidated 
Eject can be performed for one or more logical vaults at one time.

consolidated report

A process of generating reports for more than one Vault session at a time. A Consolidated 
Report can be performed for one or more logical vaults at one time. Consolidated reports 
are organized by report title, not by vault.

cpio

A UNIX command that can be used for copying files to or from a cpio archive on disk or 
tape.

ctime

The time that a UNIX inode was changed.

cumulative-incremental backup

A backup that is scheduled by the administrator on the master server and backs up files 
that have changed since the last successful full backup. All files are backed up if no prior 
backup has been done. Also see “differential-incremental backup.” 

daemon

A program on a UNIX system that runs in the background and performs some task (for 
example, starting other programs when they are needed). Daemons are generally referred 
to as services or processes on Windows server systems.

database-agent clients

Clients with additional NetBackup software that is designed to back up relational 
databases.

database-extension clients

See “database-agent clients.” 
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debug logs

Logs that can be optionally enabled for specific NetBackup and Media Manager programs 
and processes and then used to investigate problems.

destination storage unit

A storage unit to which Vault sends the data from a duplication operation. If the 
duplicated backup images are to be vaulted, then the destination storage unit must 
correspond to the robotic volume group.

device delays

Delays caused by the device that are beyond the control of the storage application. An 
example is the time required to position tape under the read and write heads. 

device host

A host (that has Media Manager installed) where a drive or robotic control is attached or is 
defined.

device monitor

A Media Manager administration utility that provides monitoring and manual control of 
Media Manager storage devices. For example, an administrator or computer room 
operator can use this utility to manually reset devices or set them to the UP or DOWN 
state.

DHCP

Dynamic host configuration protocol. This TCP/IP protocol automatically assigns 
temporary IP addresses to hosts when they connect to the network.

differential-incremental backup

Scheduled by the administrator on the master server and backs up files that have changed 
since the last successful incremental or full backup. All files are backed up if no prior 
backup has been done. Also see “cumulative-incremental backup.” 

directory depth

The number of levels below the current directory level that the NetBackup interfaces 
show in their directory and file list displays.

directory tree

The hierarchical structure in which files are organized on a disk. Each directory lists the 
files and directories that are directly below it in the tree. On UNIX, the topmost directory 
is called the root directory.
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disaster recovery

Recovering data from backups after a disk crash or other catastrophe.

disk

Magnetic or optical disk storage media.

disk-image backup

A bit-by-bit rather than a file system backup of a disk drive on a Windows platform.

DLT

Digital-linear tape or tape drive type.

Domain Name Service (DNS)

A program that handles name translation for network communications.

drive cleaning

The use of a special cleaning tape to clean the heads on a drive.

duplicate image

A copy of a backup image.

eject

Move media out of a robotic library.

encryption

Provides additional security by encrypting backup data on the client. This capability is 
available only with the NetBackup Encryption option.

entry and exit ports

See “media access port.” 

exclude list

A list that designates files or directories to exclude from automatic backups.

expiration (image)

The date and time when NetBackup stops tracking a backup image.
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expiration (volume)

The date and time when the physical media (tape) is considered to be no longer usable.

external media ID

This is an identifier written on a media cartridge or canister to help the operator identify 
the volume before inserting it into a drive or robot. For labeled media, the external media 
ID should be the same as the media ID recorded on the media.

EVSN

See “external media ID.”

FlashBackup

A special type of raw-partition backup that requires the NetBackup FlashBackup 
separately-priced option (this option is available only for NetBackup DataCenter).

flush level

Controls how often Netbackup clears its log files on a Novell NetWare or Microsoft 
Windows client platform.

fragment

A part of a backup or archive image. NetBackup can be configured to divide images into 
fragments when they exceed a certain size or span tapes.

frequency (backup)

How often NetBackup performs scheduled backups. For example, if the frequency is 
seven days then backups occur once a week.

FROZEN media state

If a volume is FROZEN, NetBackup keeps it indefinitely and can restore from it but not 
use it for further backups or archives.

full backup

A backup that copies, to a storage unit, all files and directories that are beneath a specified 
directory.

FULL media state

If this appears in a report or listing, it indicates the volume is FULL and cannot hold more 
data or be used for further backups.
284 NetBackup BusinesServer Media Manager System Administrator’s Guide for Windows



global attributes

NetBackup configuration attributes that affect all policies.

GDM Dashboard

The name for the Global Data Manager interface. The Dashboard enables monitoring job 
and drive activity on multiple master servers, as well as providing alerts to problem 
conditions.

GDM Managed Server

A NetBackup master server that appears as a managed master server in the left pane of 
the GDM Dashboard.

GDM Server

A NetBackup master server that has the Global Data Manager license activated. When 
logging into this host, the user can monitor the activity on multiple master servers using 
the GDM Dashboard interface. If the host has installed the Advanced Reporter option, the 
reports show information on multiple master servers.

Global Data Manager (GDM)

A separately-priced option (for UNIX servers) that provides an interface with a tree view 
where the administrator can view and administer multiple master servers. The server 
where the option is installed is called a GDM Server.

Global Device Database

A single host that serves as the repository for global device configuration information. 
When you install NetBackup, by default the master server is configured as the global 
device database host.

GNU tar

A public domain version of the UNIX tar program.

goodies directory

A directory containing programs, scripts, and other files that are not formally supported.

GUI

Graphical user interface.
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hard link 

On UNIX, a hard link is a pointer to the inode for the data. On a Windows server, a hard 
link is a directory entry for a file. Every file can be considered to have at least one hard 
link. On NTFS volumes each file can have multiple hard links, and a single file can appear 
in many directories (or even in the same directory with different names).

heap level

A parameter for memory-heap debugging on a Novell NetWare or Windows NetBackup 
client.

hierarchical storage management

The process of automatically migrating selected files from a managed file system to 
specified migration levels on secondary storage, while maintaining transparent access to 
those files.

host

A computer that executes application programs.

host name

Name by which a host computer is identified by programs and other computers in the 
network.

HSM

See storage migrator.

image

The collection of data that NetBackup saves for an individual client during each backup or 
archive. The image contains all the files, directories, and catalog information associated 
with the backup or archive.

import

The process of recreating NetBackup records of images so the images can be restored.

include list

A list that designates files or directories to add back in from the exclude list.

incremental backup

See “cumulative-incremental backup” and “differential-incremental backup.” 
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inject

Move media into a robotic library.

inport

See “media access port.” 

inode

A UNIX data structure that defines the existence of a single file.

install_path

Directory where NetBackup and Media Manager software is installed. The default on 
Windows servers is C:\Program Files\VERITAS and on UNIX it is /usr/openv.

jbpSA

The Java-based NetBackup interface for performing user backups, archives, and restores.

jnbSA

The Java-based NetBackup interface for administrators.

job

A parcel of work submitted to a computer. NetBackup jobs are backups, archives, or 
restores.

kernel

The nucleus of an operating system.

keyword phrase

A textual description of a backup.

kill a job

See “cancel a job.”

label

Identifier of a tape or optical disk volume. A recorded label includes a media ID.

A barcode label allows a barcode scanner to be used for media tracking.

library

See “robotic library.”
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link

See “hard link” or “symbolic link.” 

LMF - Library Management Facility

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

This robot type is supported only by NetBackup DataCenter servers.

load

(noun) Amount of work that is being performed by a system or the level of traffic on a 
network. For example, network load affects performance.

(verb) Copy data to internal memory. For example, load the installation program.

(verb) Used to indicate tape drive initialization done when new media is being added.

logs

Files where a computer or application records information about its activities.

mailslot

See “media access port.” 

man pages

Online documentation provided with UNIX computer systems and applications.

Master and media server cluster

A NetBackup master server and the remote media servers that it is using for additional 
storage. It is possible to configure clusters only with NetBackup DataCenter servers. 
NetBackup BusinesServer supports only a single server, the master.

Master of Masters

A NetBackup host where Global Data Manager software is installed. When logging into 
this host, the interface has a tree view where the administrator can view and administer 
multiple master servers.

master server

The NetBackup server that provides administration and control for backups and restores 
for all clients and servers in a master and media server cluster. NetBackup BusinesServer 
supports only a single server and it is the master.
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media

Physical magnetic tapes, optical disks, or magnetic disks where data are stored.

media access port

A slot or other opening in a robot where you can insert or remove a tape without having 
to access the interior of the robot. After inserting a tape, you move it to a slot by using an 
inject command. Prior to removing a tape, you move it to the port by using an eject 
command. The inject and eject commands are supported through the add and move 
screens in the Media Manager administration interface.

media host

NetBackup server to which the job (client) is sending the data.

media ID

An identifier that is written on a volume as part of the recorded label.

Media Manager

Software that is part of NetBackup and manages the storage devices and removable 
media.

Media Manager Host

Host where Media Manager is installed (may have devices attached).

media server

A NetBackup server that provides storage within a master and media server cluster. The 
master can also be a media server. A media server that is not the master is called a remote 
media server. NetBackup BusinesServer does not support remote media servers.

menu interface

A character-based interface for use on terminals that do not have graphical capabilities.

mount 

Make a volume available for reading or writing.

mount point

The point where a file system on a disk logically connects to a system’s directory structure 
so the file system is available to users and applications.
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MPX

See “multiplexing.” 

mtime

The point in time when a UNIX or NTFS file is modified.

multiplexing

The process of sending concurrent-multiple backups from one or more clients to a single 
storage device and interleaving those images onto the media.

multiplexed group

A set of backups that were multiplexed together in a single multiplexing session.

NDMP

Network data management protocol. NetBackup requires the NetBackup for NDMP 
separately-priced option to support NDMP.

NetBackup Client service

NetBackup Windows service that runs on clients and servers and listens for connections 
from NetBackup servers and clients in the network. When a connection is made, this 
service starts the necessary programs.

NetBackup configuration options

On UNIX servers and on UNIX and Macintosh, clients, these settings are made in the 
bp.conf file. On NetWare target and OS/2 clients, they are in the bp.ini file. On 
Windows servers and Windows clients, these settings are called properties and are made 
through the Backup, Archive, and Restore interface or the Host Properties dialog in the 
NetBackup Administration Console.

NetBackup databases

See catalogs. 

NetBackup Database Manager service

NetBackup Windows service that runs on the master server and manages the NetBackup 
internal databases (called catalogs). This service must be running on the master server 
during all NetBackup administrative operations.
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NetBackup Device Manager service

The NetBackup Windows service that runs on a NetBackup server and starts the robotic 
control processes and controls the reservation and assignment of volumes. This service 
runs only if the server has devices under Media Manager control. The process is ltid.

NetBackup properties

Same as NetBackup configuration options but are called NetBackup properties on 
Microsoft Windows platforms.

NetBackup Request Manager service

The NetBackup Windows service that runs on the master server and starts the scheduler 
and receives requests from clients.

NetBackup Volume Manager service

A NetBackup Windows service that runs on a NetBackup server, allows remote 
administration of Media Manager, and manages volume information. The process is vmd.

NIS

Network information service.

NLM

NetWare loadable module.

NFS

Network file system.

nonrobotic

See “standalone.” 

ODL

Optical disk library. This robot type is supported only by NetBackup DataCenter servers.

offsite volume group

A volume group in which media will appear after having been ejected from the robot for 
vaulting. When Vault ejects media it is moved from the robotic volume group to the 
off-site volume group.
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offsite volume pool

A volume pool that contains media that is to be ejected and vaulted. Backup images 
written to an off-site volume pool by an original NetBackup backup policy or by Vault’s 
duplication feature will be ejected and vaulted. More than one off-site volume pool can be 
specified for the Eject step of a Vault profile.

original backup

A backup image created by a backup job. A single backup image or all backup images 
created by an Inline Tape Copy (multiple copy) configuration are considered original 
backups. A backup image created by a duplication job is not an original backup.

outport

See “media access port.” 

partitions

The logical partitions into which a magnetic disk is divided.

patch

A program that corrects a problem or adds a feature to an existing release of software.

path length

Number of characters in a pathname.

pathname

The list of directories in the path to a destination directory or file.

PC clients

NetBackup clients that have Microsoft Windows, Macintosh, or IBM OS/2 operating 
systems.

peername

The name by which a computer identifies itself when establishing connections to other 
systems.

policy

Defines the backup characteristics for a group of one or more clients that have similar 
backup requirements.
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port

A location used for transferring data in or out of a computer.

Also see “media access port.” 

primary copy

The copy of an image that NetBackup uses to satisfy restores. When NetBackup duplicates 
an image, the original is designated as the primary copy.

privileges

The tasks or functions that a user, system, or application is authorized to perform.

profile

A vault profile is a way to save configuration settings. Specific parameters for duplication, 
catalog backup, eject, and report or any combination of these steps, are configured within 
a profile.

progress report

Log where NetBackup records events that occur during user operations.

proxy restore

A proxy restore allows the user to restore files that he has write access to, on a machine 
other than his desktop. The files must be in a backup of the machine to which they are 
being restored.

QIC

Quarter-inch-cartridge tape.

queued job

A job that has been added to the list of jobs to be performed.

raw-partition backup

Bit-by-bit backup of a partition of a disk drive on UNIX. On Windows, this is called a 
disk-image backup.

rbak

The program that Apollo clients use to read data from tape during a restore.
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recorded media ID

This is an identifier written as part of the label on a volume and used by Media Manager 
to ensure that the correct volume is mounted. The recorded media ID should match the 
external media ID.

redirected restore (different client)

Restoring files to your client when they were originally backed up from a different client. 
The administrator using the interface on the master server can direct a restore to any client 
(this variation is called a server directed restore).

redirected restore (different target)

On a Novell NetWare server platform running the NetBackup target version of client 
software, this operation restores files to a different target than the one from which they 
were backed up.

redirected restore (different path)

Restores files to a different directory than the one from which they were backed up.

registry

A Microsoft Windows database that has configuration information about hardware and 
user accounts.

remote administration console

A Windows NetBackup client that has the administration interface software installed and 
can be used to administer NetBackup servers.

remote media server

A media server that is not the master. Note that only NetBackup DataCenter supports 
remote media servers. NetBackup BusinesServer supports only a single server, the master.

residence

In Media Manager, information about the location of each volume is stored in a volume 
database. This residence entry contains information, such as robot number, robot host, 
robot type, and media type.

resource

A Novell NetWare term that refers to a data set on the target. For example, in DOS, 
resources are drives, directories, and files. Also see “target service.” 
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restore

(verb) The act of restoring selected files and directories from a previous backup or archive 
and returning them to their original directory locations (or to a different directory).

(noun) The process of restoring selected files and directories from a previous backup and 
returning them to their original directory locations (or to a different directory).

retention level

An index number that corresponds to a user-defined retention period. There are 10 levels 
from which to choose (0 though 9) and the retention period associated with each is 
configurable. Also see “retention period.” 

retention period

The length of time that NetBackup keeps backup and archive images. The retention 
period is specified on the schedule.

robotic arm

The component of a robotic library that physically selects the media (tape or optical disk).

robotic library

Refers to a robot and its accompanying software. A robotic library includes a collection of 
tapes or optical platters used for data storage and retrieval. For example, a Tape Library 
DLT (TLD) refers to a robot that has TLD robotic control.

robotic volume group

A volume group from which media will be ejected and vaulted. When Vault duplicates 
backups, they are duplicated to media in the robotic volume group.

root

The highest level directory in a hierarchical directory structure. In MS-DOS, the root 
directory on a drive is designated by a backslash (for example, the root on drive C is C:\). 
On UNIX, the root directory is designated by a slash (/).

Also, a UNIX user name having administration capability.

RS-232

An industry-standard interface for serial communications and sometimes used for 
communicating with storage peripherals. 
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RSM Interface

Application in Windows 2000 used to manage Removable Storage Manager (RSM) 
devices.

RSM - Removable Storage Manager

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

Also, a component of the Windows 2000 operating system that manages storage devices.

RVSN

See “recorded media ID.” 

schedules 

Controls when backups can occur in addition to other aspects of the backup, such as: the 
type of backup (full, incremental) and how long NetBackup retains the image.

SCSI

Small computer system interface. This is a type of parallel interface that is frequently used 
for communicating with storage peripherals.

server-directed restore

Using the user interface on the master server to restore files to any client. Only the 
administrator can perform this operation.

server independent restore

Restoring files by using a NetBackup server other than the one that was used to write the 
backup. This feature is available only with NetBackup DataCenter.

server list

The list of servers that a NetBackup client or server refers to when establishing or 
verifying connections to NetBackup servers. On a Windows server and Microsoft 
Windows clients, you update the list through a dialog box in the interface. On a UNIX 
server and UNIX and Macintosh clients, the list is in the bp.conf file. On NetWare target 
and OS/2 clients, the list is in the bp.ini file.

service

A program on a Windows server system that runs in the background and performs some 
task (for example, starting other programs when they are needed). Services are generally 
referred to as daemons on UNIX systems.
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session

An instance of NetBackup checking its schedules for backups that are due, adding them to 
its worklist, and attempting to complete all jobs in the worklist. For user backups and 
archives, a session usually consists of a single backup or archive.

Session (Vault)

A vault session consists of executing a particular profile or profiles.

shared drives

See “Shared Storage Option (SSO).” 

Shared Storage Option (SSO)

A separately priced VERITAS software option that allows tape drives (standalone or in a 
robotic library) to be dynamically shared among multiple NetBackup and Storage 
Migrator servers.

This option is supported only on NetBackup DataCenter servers.

SMDR

Storage management data requestor, a Novell NetWare program that provides its services 
transparently to all SMS modules and lets remote and local modules communicate with 
one another.

SMS

Novell NetWare storage management services.

source volume group

A volume group from which Vault can select backups to duplicate. This parameter is used 
to restrict the list of backups from all backups that reside on media in any volume group 
to backups that reside on media in a single volume group. Where a volume group 
corresponds to a particular robot, the profile will duplicate only backups on media in that 
robot. The Source Volume Group is normally only specified if you have multiple robots 
attached to the same server, for example you want to duplicate backups that reside in 
robot 0 to media that reside in robot 1.

SSO

See “Shared Storage Option (SSO).” 

stacker

Usually a small robotic library that contains one drive only. See “robotic library.” 
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standalone

A qualifier used with drives and media to indicate they are not associated with a robot. 
For example, a standalone tape drive is one where you must manually find and insert 
tapes before using them. A standalone volume is one that is located in a standalone drive 
or is stored outside of a drive and designated as standalone in the volume configuration.

status code

A numerical code, usually accompanied by a troubleshooting message, that indicates the 
outcome of an operation.

storage migrator

Refers to the VERITAS Storage Migrator line of hierarchical storage management products 
for UNIX and Windows. These products make extra room on a disk by transparently 
moving data to other storage and then transparently retrieving the data when it is needed 
by a user or application.

Storage Migrator is available only for NetBackup DataCenter servers.

storage unit

Refers to a storage device where NetBackup or Storage Migrator stores files. It can be a set 
of drives in a robot or consist of one or more single tape drives that connect to the same 
host.

SUSPENDED media state

If a volume is SUSPENDED, NetBackup can restore from it but cannot use it for backups. 
NetBackup retains a record of the media ID until the last backup image on the volume 
expires. 

symbolic link

On a UNIX system, this is a pointer to the name of the file that has the source data.

TapeAlert

Allows reactive cleaning for most drive types and is a function of the tape drive.

tape format

The format that an application uses to write data on a tape.

tape marks

A mark that is recorded between backup images on a tape.
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tape overhead

The space required for data that is not part of the backup images. For example, tape marks 
and catalogs of what are on the tape are considered overhead.

tape spanning

Using more than one tape to store a single backup image.

tar

Tape Archive program that NetBackup uses to extract backup images during a restore.

target

See “target service.” 

target service

A Novell NetWare service that needs storage management. The SMS views all services 
(for example, print services, communication services, workstations) as targets.

Target Service Agent

A Target-service agent is a Novell NetWare agent that prepares the target's data for SMS 
during a backup and for the target during a restore.

TLD - Tape Library DLT

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

TLH - Tape Library Half-inch

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

This robot type is supported only by NetBackup DataCenter servers.

TLM - Tape Library Multimedia

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

This robot type is supported only by NetBackup DataCenter servers.

TL4 - Tape Library 4MM

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.
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TL8 - Tape Library 8MM

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

timeout period

The period of time that an application has allotted for an event to occur.

TIR

See “true image restore.” 

tpconfig

A Media Manager administration utility for configuring devices which is started from the 
command line. On UNIX, it has a character-based menu interface that can be run from 
terminals that do not have X Windows capabilities. tpconfig also has a command line 
interface.

transfer rate

The rate at which computer information is transferred between a source and a destination.

transport

See “robotic arm.” 

true image restore

Restores the contents of a directory to what it was at the time of any scheduled full or 
incremental backup. Previously deleted files are ignored.

TS8 - Tape Stacker 8MM

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

TSA

See “Target Service Agent.” 

TSD - Tape Stacker DLT

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.
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TSH - Tape Stacker Half-inch

A Media Manager designation for a category of robot. For the specific vendor types and 
models in this category, see the VERITAS support web site.

This robot type is supported only by NetBackup DataCenter servers.

unassigned media

Media that contain no valid images. A piece of unassigned media has an entry in the 
volumes database but no entries in the images database. Unassigned Media do not have a 
“time assigned” in the Media section of the GUI.

user interface

The program used to perform user backups, archives, and restores.

user operation

A backup, archive, or restore that is started by a person on a client system.

Vault

Vault is a separately-priced NetBackup option that provides offsite backup management. 
Vault automatically duplicates specified backup images, and automates the process of 
offsite media rotation (a critical component of any backup or disaster recovery strategy). 
Vault manages offsite storage and retrieval of media for original backups, duplicate 
backups, and catalog backups. Additionally, NetBackup Vault generates reports to track 
the location and content of each piece of media.

vault

In the context of the NetBackup Vault, a vault is logical entity associated with a particular 
robot that acts as a designated holding place for backups that will eventually be sent to a 
physical offsite vault. The term ‘vault’ is used to refer both to the process, and to the 
physical storage location of a set of tapes offsite.

vault process

Vaulting is the process of choosing backup images to duplicate or eject, optionally 
duplicating backups, ejecting duplicate or original media, storing it at an offsite location, 
and later returning expired media to your robot. Vaulting is an integral part of the disaster 
recovery process.

verbose flag

Configuration file entry that causes a higher level of detail to be written in the logs.
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verify

An operation that compares the list of files that are actually on a volume with what 
NetBackup has recorded as being on it. The data that is on the media is not verified.

vmadm

A Media Manager administrator utility for managing volumes. It runs on UNIX and has a 
character-based, menu interface that can be run from terminals.

vm.conf

A Media Manager configuration file with entries that include the servers that can manage 
local devices and default media ID prefixes for media that do not contain barcodes.

volume

Media Manager volumes are logical units of data storage or cleaning capability on media 
that have been assigned media IDs and other attributes, which are recorded in the Media 
Manager volume database.

volume configuration

Refers to configuration information that is stored in the Media Manager volume database.

volume database

An internal database where Media Manager keeps information about volumes. All hosts 
(where Media Manager is installed) have a volume database. However, the database is 
empty unless the host is designated as a volume database host.

volume database host

The host (where Media Manager is installed) that contains information about the volumes 
that Media Manager uses in a device. Because NetBackup BusinesServer supports only a 
single server, the volume database host is always on the same server.

volume group

A set of volumes that are configured within Media Manager to reside at the same physical 
location (for example, in a specific robot).

volume pool

A set of volumes that are configured within Media Manager to be used by a single 
application and are protected from access by other applications and users.

wakeup interval

The time interval at which NetBackup checks for backups that are due.
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wildcard characters

A character that can be used to represent other characters in searches.

Microsoft Windows

(noun) Describes a line of operating systems developed by Microsoft, Inc.

For more information on the Windows operating systems that NetBackup supports, refer 
to the VERITAS support web site at http://www.support.veritas.com.

Windows

(adjective) Used to describe a specific product or clarify a term. Some examples are: 
Windows 95, Windows 98, Windows NT, Windows 2000, Windows servers, Windows 
clients, Windows platforms, Windows hosts, and Windows GUI.

Windows servers

A term that defines the Windows server platforms that NetBackup supports; those 
platforms are: Windows NT and 2000.

Windows clients

A term that defines the Windows client platforms that NetBackup supports; those 
platforms are: Windows 95, 98, ME, NT, 2000, XP (for 32- and 64-bit versions), and LE.

Windows Display Console

A NetBackup-Java interface program that runs on Windows 2000, NT, 98, and 95 
computers. Users can start this interface on their local system, connect to a UNIX system 
that has the NetBackup-Java software installed, and then perform any user operations 
that their permissions allow.

WORM media

Write-once, read-many media for optical disks. NetBackup BusinesServer does not 
support WORM media.

xbp

The X Windows-based backup, archive, and restore program for users on NetBackup 
UNIX clients.
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Refresh rate, changing 148
Removable Storage Manager (RSM)

adding volumes 272
barcode operations 273, 275
configuring drives 271
media Pools 269
media requests 270
overview 270
removing tapes 273
robot types 29
robots 99, 110

Removing
volumes 97

Replace media 87
ReqId (see Request ID)
Request ID field

drive status 145
pending requests 145

Requests
overview 153
assigning 154
denying 158
display pending 153
example assignment 156

identification number
drive status 145
pending requests 145

resubmitting 158
REQUIRED_INTERFACE, vm.conf entry 
248
Reset drive 152, 198
Residence

defined 63
for move volumes 75
in update options 103
update volume configuration 98

Retention period
expiring backups, with bpexpdate 83

right-click shortcut menus 7
Robot

attributes 215
barcode rules 122
barcode update 132
destination for move volume 76
device file 31
device host 29
drive number 36
for new volume 68
hos 49
host, definition 51
inventory 72, 91
inventory and compare contents 94
number 29
process 220
type 29
update volume configuration 97
volume database host 30
with more than one type of drive 72

Robot type
RSM 214
TL4 214
TL8 214
TLD 214
TS8 214
TSD 214

Robotic
cleaning 226
control process 221
device file 31
library 36
test utilities 220

robtest 220, 241
RSM_ vm.conf entry 249
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rsmd, command 162

S
Scratch pool

adding 56
changing to 58
overview 230

SCRATCH_POOL, vm.conf entry 249
SERVER, vm.conf entry 24, 249
Shared field

drive status 143
Shortcut menus 7, 20, 53, 147
Show robot contents 93
Slot number

add volume 69
for move volumes 77

Sony robot slot diagram
LIB-304 (TL8) 252

Standalone drive
add drive 36

Status
drive initial configuration 34
volume 52

STK robot slot diagram
9730 (TLD) 266
9738 (TLD) 266
L20 (TLD) 267

Stop/Restart Device Manager service 24
Storage devices

steps for attaching 23
Sun robot slot diagram

StorEdge L1000 (TLD) 254
StorEdge L400 (TL8) 258
StorEdge L9 (TLD) 259

T
Table-driven robotics 220
Tape

device installer 23
drivers 23
installer 23

TapeAlert 226
Tapes and tape files

assigning requests 154
example of handling a request 156
labels 144
mode 146
time requested 146

Terminating drive assignment 152
Time

assigned 51
field 146

tl4d command 163
tl8cd command 164
tl8d command 164
tldcd command 167
tldd command 167
Toolbars, viewing and customizing 12, 46
tpclean command 170
tpconfig, command 173
tpreq command 181
tpunmount

command 183
ts8d command 184
tsdd command 185
Type field

4mm 143
8mm 143
dlt 143
hcart 143
qscsi 143

U
Up drive

standard mode (AVR) 138
Update and rescan barcodes 132
Update robot

procedure 99
update options 101

Update volume configuration
when not to use 98
when to use 97

Updating
barcodes 132

User field
drive status 144
pending requests 146

Using Media Manager devices with other 
applications 1

V
VERBOSE, vm.conf entry 250
VERITAS support web site 23, 27
vm.conf file

adding SERVER entries 24
AUTHORIZATION_REQUIRED entries 
243
CLIENT_PORT_WINDOW entries 244
DAYS_TO_KEEP_LOGS entries 245
DISABLE_AUTO_PATH_CORRECTIO
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N entries 245
DISALLOW_NONNDMP_ON_NDMP_
DRIVE entries 245
DO_NOT_EJECT_STANDALONE 
entries 246
mapping Backup Exec media type 
entries 243
MEDIA_ID_BARCODE_CHARS entries 
246
MEDIA_ID_PREFIX entries 247
overview 243
PREFERRED_GROUP entries 247
PREVENT_MEDIA_REMOVAL entries 
248
RANDOM_PORTS entries 248
REQUIRED_INTERFACE entries 248
RSM_ entries 249, 276
SCRATCH_POOL entries 249
SERVER entries 249
VERBOSE entries 250

vmadd command 186
vmchange command 189
vmcheckxxx command 195
vmd

security 236
vmdelete command 197
vmoprcmd command 198
vmpool command 201
vmquery command 204
vmrule command 208
vmupdate command 210
Volume configuration wizard 8, 72
Volume database host

definition 3
for robot 30

Volume group
add volume 70
changing name 87
definition 228
deleting 79
for move volume 77
pending request field 147
rules for assigning 228
volumes list 49, 51

Volume pool
overview 55, 228
add volume 71
adding 56

changing attributes 57
changing for a volume 58
configuring a scratch pool 58, 230
DataStore pool 48
deleting 59
for update robot 109
in volume list 51
NetBackup pool 48, 51

Volumes
adding (see Adding)
assigned 82
barcode 50
changing (see Changing)
cleaning count

attribute 86
volumes list 52

creation time and date 53
deleting (see Deleting)
description for new volume 69
first time mounted 52
group (see Volume group)
header device 36
last time mounted 52
maximum mounts allowed 70
media ID column 50
media ID style 69
moving 73, 232
moving actions menu 74
optical disk partner 52
recycling 89
replacing 87
robot number 49, 51
robot, host 49, 51
side/face 52
slot 51
status 52
time assigned 51
volume pool (see Volume pool)

Volumes to move
for move volume 76

W
Wizard

device configuration 7, 26, 37, 222
volume configuration 8, 72

Write enabled
field 144
tape 146
Index 311


	VERITAS NetBackup BusinesServer™ 4.5
	Media Manager System Administrator’s Guide
	About This Guide
	Audience
	Organization
	Related Documents
	Accessibility
	Conventions
	Type Style
	Notes and Cautions
	Key Combinations
	Command Usage
	Terms

	Getting Help

	Introduction to Media Manager
	Media Manager Features
	Media Manager Hosts
	Media Manager-Controlled Storage Devices
	Media Manager Volumes
	Mounting and Using Volumes

	Media Manager Administration Utilities
	Starting the Media Manager Administration Utilities
	Shortcut Menus

	Device and Media Configuration Overview

	Configuring Storage Devices
	Starting Device Management
	Using the Device Management Window
	Menus and Commands
	Toolbars
	Tree Pane
	Global Topology Pane
	Devices Pane
	Status Bar
	Shortcut Menus and Commands
	Tool Tips
	Customizing the Window
	Allowable Media Manager Characters

	Performing Initial Device Configuration
	Media Manager Security

	Using the Device Configuration Wizard to Configure Devices
	Starting the Wizard
	Rerunning the Wizard
	External Device Mapping Files

	Managing Partially-Configured Devices
	Adding Robots
	Dialog Box Entries for Adding and Changing Robots

	Adding Drives
	Dialog Box Entries for Adding or Changing Drives

	Managing Robots and Drives
	Changing a Robot Configuration
	Changing the Configuration of a Drive
	Deleting Robots
	Deleting Drives

	Printing Your Device Configuration
	Robot and Drive Configuration Example

	Managing Media
	Starting Media Management
	Using the Media Management Window
	Menus and Commands
	Toolbars
	Tree Pane
	Volumes Pane
	Status Bar
	Shortcut Menus and Commands
	Tool Tips
	Customizing the Window
	Allowable Media Manager Characters

	Administering Media on Other Hosts
	Configuring Volume Pools
	Adding a New Volume Pool or Scratch Volume Pool
	Changing the Attributes of a Volume Pool
	Changing the Volume Pool Assignment for a Volume
	Deleting a Volume Pool

	Methods Available for Injecting and Ejecting Volumes
	Methods for Injecting Volumes into a Robot
	Methods for Ejecting Volumes From a Robot
	Inject and Eject Functions Available by Robot Type

	Adding New Volumes
	Methods Available for Adding Volumes
	Adding Volumes - Using the Robot Inventory Update Option
	Adding Volumes - Using the Actions Menu
	Dialog Box Entries for New Volumes

	Using the Volume Configuration Wizard
	Wizard Limitations
	What To Expect In This Wizard
	Before You Start This Wizard
	To Start This Wizard

	Moving Volumes
	Moving Volumes - Using the Robot Inventory Update Option
	Moving Volumes - Using the Actions Menu
	Dialog Box Entries for Move Volumes

	When to Delete Volumes
	Deleting Volumes
	Deleting a Volume Group

	Ejecting Volumes From Robots (Actions Menu Command)
	Deassigning Volumes
	Determining Which Application is Using a Volume
	Deassigning NetBackup Volumes

	Changing the Attributes for a Volume
	Dialog Box Entries for Change Volumes

	Changing the Volume Group of a Volume
	Replacing Volumes
	Replacing a Volume Without Reusing the Media ID
	Replacing a Volume and Reusing the Media ID

	Recycling Volumes
	Recycling Volumes Under the Same Media ID
	Recycling Volumes Under a New Media ID


	Managing Media in Robots
	Robot Management Overview
	Robot Inventory Operations (Inventory Robot Dialog)
	Checking Barcodes (Rescan/Update Barcodes Dialog)

	Showing the Contents of a Robot
	Comparing Robot Contents with the Volume Configuration
	Updating the Volume Configuration for a Robot
	When to Use Update Volume Configuration
	When Not to Use Update Volume Configuration
	To Update the Volume Configuration for a Robot
	Changing the Update Options
	Update Options
	Examples of Updating a Volume Configuration

	Configuring Barcode Rules
	Adding a New Barcode Rule
	Dialog Box Entries for Adding and Changing Barcode Rules
	Changing a Barcode Rule
	Deleting a Barcode Rule

	Configuring Media ID Generation Rules
	Adding a New Media ID Generation Rule
	Changing a Media ID Generation Rule
	Deleting a Media ID Generation Rule
	Dialog Box Entries for Adding and Changing Media ID Generation Rules

	Rescaning and Updating Barcodes for a Robot
	When to Use Rescan/Update
	When Not to Use Rescan/Update
	To Rescan/Update Barcodes


	Monitoring Storage Devices
	Starting Device Monitor
	Using the Device Monitor Window
	Menus and Commands
	Toolbars
	Global Topology Pane
	Drives Status Pane
	Pending Requests Pane
	Status Bar
	Shortcut Menus and Commands
	Tool Tips
	Customizing the Window
	Allowable Media Manager Characters

	Controlling the NetBackup Device Manager Service
	Administering Devices on Other Hosts
	Changing the Operating Mode of a Drive
	Changing Mode Example

	Resetting a Drive
	Adding or Changing a Drive Comment
	Handling Pending Requests and Pending Actions
	Pending Requests
	Pending Actions

	Assigning a Drive to a Pending Request
	Assigning a Drive Example 1
	Assigning a Drive Example 2

	Resolving Pending Actions
	Resubmitting Requests
	Denying Requests

	Media Manager Commands and Processes
	Media Manager Reference Topics
	Robot Overview
	Media Manager Robot Types
	Media Manager Media Types
	Robot Attributes
	Table-Driven Robotics
	Robotic Test Utilities
	Robotic Processes

	Correlating Device Files to Physical Drives When Adding Drives
	Correlating On Windows Hosts
	Correlating On UNIX Hosts

	Drive Cleaning
	Frequency-Based Cleaning
	On-Demand Cleaning
	TapeAlert
	Using a Cleaning Tape

	Volume Pools and Volume Groups
	Volume Pools
	Volume Groups
	Volume Pools and Groups Example
	Scratch Volume Pools
	Moving Volumes

	Barcodes
	Barcode Rules
	Media ID Generation Rules

	vmd Security
	Possible NetBackup and Media Manager Conflicts
	NetBackup Authentication/Authorization
	Media Manager Server-Based vmd Security
	Media Manager Enhanced vmd Authorization

	How Media Manager Selects a Drive for a Robotic Mount Request
	Administrators Quick Reference
	Media Manager Commands
	Log Files

	Media Manager Configuration File (vm.conf)
	Example vm.conf File


	Robot Drive and Slot Layouts
	ADIC Scalar 218 (TLD)
	Exabyte 430 Sony LIB-304 (TL8)
	ADIC VLS DLT (TSD)
	ATL 2/28 DLT Library (TLD)
	ATL P1000 Sun StorEdge L1000 (TLD)
	ATL M1500 M4 Data M1500 (TLD)
	Breece Hill Q2.15 IBM 7337-305 IBM 3447-105 (TLD)
	Breece Hill Q7 (TLD)
	Compaq 35/70 (TLD)
	Exabyte 10i, 10e, 10h Exabyte 210 Exabyte EZ17 (TS8)
	Exabyte 18D (TLD)
	Exabyte 220 ADIC Scalar AIT 220 Sun StorEdge L400 (TL8)
	Exabyte 230D (TLD)
	HP SureStore 1/9 Sun StorEdge L9 (TLD)
	ADIC Fastor (TLD)
	NEC Autoloader DLT (TLD)
	Overland Data LXBx110 Overland Data LXBx210 Compaq TL891 Compaq TL892 (TLD)
	Overland Data Library Pro (TL8)
	Overland Data NEO Overland Data LxL1u11 (TLD)
	Compaq Storage Works MSL 5026 Compaq Storage Works MSL 5052 (TLD)
	STK 9730 STK 9738 DELL 130T HP SureStore E 3/30 (A4853A) (TLD)
	STK L20 NCR 6461 (TLD)

	Microsoft Removable Storage Manager (RSM)
	Media Manager and Microsoft RSM
	Considerations When Using Microsoft RSM
	Microsoft RSM Interface

	Media Requests Involving an RSM Robot
	Configuring RSM Robotic Control
	Configuring RSM Drives in Media Manager
	Verifying a Configuration
	Activating a Configuration

	Adding RSM Volumes
	Removing Tapes from the Robot
	Robot Inventory Operations
	vm.conf Map Entries For RSM Robots

	Glossary
	Index


